Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,807 Members 52,872 Now Online
XDA Developers Android and Mobile Development Forum

How to reduce blur when taking picture

Tip us?
 
htcm7
Old
(Last edited by htcm7; 6th February 2014 at 05:34 AM.)
#1  
htcm7's Avatar
Senior Member - OP
Thanks Meter 108
Posts: 225
Join Date: Jul 2013
Location: Currently, on Earth
Default How to reduce blur when taking picture

Hi guys,

Sometime you got blur picture when using Camera even you took it with steady hand.
This is happen because gyro sensor in G2 is not working/calibrate

Here is how to check it whether is working or not
1) Go to hidden menu by dial 3845#*80X#, replace X with your phone model. This is only for models 800/801/802, etc, for other models search this forum how to enter Hidden Menu
2) Choose Device test -> Individual item -> camera OIS, put your phone and flat surface, don't move it and then click Start
3) The result should be Gyro : PASS, Hall : PASS, Driver : PASS

If you get Gyro : FAIL, then you should calibrate your sensor. Go to Settings -> General -> Gestures -> Motion sensor calibration.

After calibration, check again your camera OIS, now it should be pass all test.
The Following 9 Users Say Thank You to htcm7 For This Useful Post: [ Click to Expand ]
 
ali_ign
Old
#2  
ali_ign's Avatar
Senior Member
Thanks Meter 36
Posts: 144
Join Date: Jan 2011
Location: Shiraz
Quote:
Originally Posted by htcm7 View Post
Hi guys,

Sometime you got blur picture when using Camera even you took it with steady hand.
This is happen because gyro sensor in G2 is not working/calibrate

Here is how to check it whether is working or not
1) Go to hidden menu by dial 3845#*80X#, replace X with your phone model. This is only for models 800/801/802, etc, for other models search this forum how to enter Hidden Menu
2) Choose Device test -> Individual item -> camera OIS, put your phone and flat surface, don't move it and then click Start
3) The result should be Gyro : PASS, Hall : PASS, Driver : PASS

If you get Gyro : FAIL, then you should calibrate your sensor. Go to Settings -> General -> Gestures -> Motion sensor calibration.

After calibration, check again your camera OIS, know it should be pass all test.

when i in ois test and select start i got failed ! (invalid vendor ) ! i'm on rayglobe flex v4 !
 
dpk3
Old
#3  
Member
Thanks Meter 8
Posts: 46
Join Date: Sep 2010
+1

Sent from my LG-D802 using xda app-developers app
 
htcm7
Old
#4  
htcm7's Avatar
Senior Member - OP
Thanks Meter 108
Posts: 225
Join Date: Jul 2013
Location: Currently, on Earth
Quote:
Originally Posted by ali_ign View Post
when i in ois test and select start i got failed ! (invalid vendor ) ! i'm on rayglobe flex v4 !
I guest flex ROM doesn't have hidden menu apk since this is not based on stock firmware.
 
Porcifouin
Old
#5  
Junior Member
Thanks Meter 2
Posts: 11
Join Date: May 2014
Location: Strasbourg, France
Wow, that's a pretty cool and easy trick, worked on my side, thank you !
 
dracushor87
Old
#6  
Junior Member
Thanks Meter 1
Posts: 7
Join Date: Nov 2010
Location: Bucharest
it did work. thanks mate!
 
mood_coolman
Old
#7  
Member
Thanks Meter 0
Posts: 45
Join Date: Apr 2014
When i enter hiden menu i choose device test and that message showed up "press ok to run aat device will be restared" i press ok and nothing happen and the message still appeared, i'm on cloudy g3 1.2.

---------- Post added at 09:01 PM ---------- Previous post was at 08:27 PM ----------

When i select device test this message showed up "press ok to run AAT device will be restarted" then it stay like that when i press ok nothing heppen till i forced it to stop,i'm on cloudy g3 1.2. D802

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...