Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,782 Members 45,800 Now Online
XDA Developers Android and Mobile Development Forum

Building error need help

Tip us?
 
skinzy98
Old
#1  
skinzy98's Avatar
Senior Member - OP
Thanks Meter 499
Posts: 1,672
Join Date: May 2012
Location: spartanburg
Default Building error need help

I have been working with one other person to build liquid smooth for the Samsung vibrant. The device is no longer supported so we have worked our way through all the errors that should have appeared with an unsupported device. This so the error I'm getting noe when the build is almost finished. My friend literally just resynced and built it without this error so I need some help as he has not seen this error. I'm using Ubuntu 13.10 java jdk 6 and this is the error

target Dex: Gallery2
target Dex: Contacts
target Dex: Dialer
target Dex: Launcher3
collect2: error: ld returned 1 exit status
make: *** [/home/skinzy98/liquid/out/target/product/vibrantmtd/obj/SHARED_LIBRARIES/libwebviewchromium_intermediates/LINKED/libwebviewchromium.so] Error 1
make: *** Waiting for unfinished jobs....

Sent from my Nexus 4 using xda app-developers app


Current Phone: Nexus 4
Previous Phones: Samsung galaxy vibrant, T-mobile HTC One S
 
skinzy98
Old
#2  
skinzy98's Avatar
Senior Member - OP
Thanks Meter 499
Posts: 1,672
Join Date: May 2012
Location: spartanburg
Just a comment my friend seems to think it could be something with my build environment but he's not sure. Any help?

Sent from my Nexus 4 using xda app-developers app


Current Phone: Nexus 4
Previous Phones: Samsung galaxy vibrant, T-mobile HTC One S
 
kostoulhs
Old
#3  
kostoulhs's Avatar
Senior Member
Thanks Meter 143
Posts: 212
Join Date: Jul 2013
Location: Kavala
Quote:
Originally Posted by skinzy98 View Post
I have been working with one other person to build liquid smooth for the Samsung vibrant. The device is no longer supported so we have worked our way through all the errors that should have appeared with an unsupported device. This so the error I'm getting noe when the build is almost finished. My friend literally just resynced and built it without this error so I need some help as he has not seen this error. I'm using Ubuntu 13.10 java jdk 6 and this is the error

target Dex: Gallery2
target Dex: Contacts
target Dex: Dialer
target Dex: Launcher3
collect2: error: ld returned 1 exit status
make: *** [/home/skinzy98/liquid/out/target/product/vibrantmtd/obj/SHARED_LIBRARIES/libwebviewchromium_intermediates/LINKED/libwebviewchromium.so] Error 1
make: *** Waiting for unfinished jobs....

Sent from my Nexus 4 using xda app-developers app
I also have this error, did you find a solution to share it? I am compiling for Galaxy Ace 3 LTE
 
skinzy98
Old
#4  
skinzy98's Avatar
Senior Member - OP
Thanks Meter 499
Posts: 1,672
Join Date: May 2012
Location: spartanburg
Quote:
Originally Posted by kostoulhs View Post
I also have this error, did you find a solution to share it? I am compiling for Galaxy Ace 3 LTE
I'm pretty sure that all of a sudden the error went away after I repo synced after a couple days. It seems to be something they were changing. If not try installing a different java. I think 6 not 7

clean installs are love. clean installs are life


Current Phone: Nexus 4
Previous Phones: Samsung galaxy vibrant, T-mobile HTC One S
 
kostoulhs
Old
#5  
kostoulhs's Avatar
Senior Member
Thanks Meter 143
Posts: 212
Join Date: Jul 2013
Location: Kavala
Quote:
Originally Posted by skinzy98 View Post
I'm pretty sure that all of a sudden the error went away after I repo synced after a couple days. It seems to be something they were changing. If not try installing a different java. I think 6 not 7

clean installs are love. clean installs are life
i have oracle JDK 6 somewhere i read that you should change branches to framework/base from kitkat3 to kitkat2
 
skinzy98
Old
#6  
skinzy98's Avatar
Senior Member - OP
Thanks Meter 499
Posts: 1,672
Join Date: May 2012
Location: spartanburg
I didn't have to use that I think I changed to javasun maybe. I searched that error also and I believe overstack had something about it

clean installs are love. clean installs are life


Current Phone: Nexus 4
Previous Phones: Samsung galaxy vibrant, T-mobile HTC One S
Thread Tools
Display Modes


TRENDING IN THEMER...