FORUMS

XDA Picks: Best Apps of the Week (June 27 – July 4)

Apps are at the front and center of any smartphone experience, and with over a … more

HTC One M9 Developer Edition Android 5.1 OTA

The Developer Edition of the HTC One M9 is receiving an over-the-air update to Android 5.1. … more

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

Wifi and data switch off randomly.

1,078 posts
Thanks Meter: 161
 
By simacca, Senior Member on 17th April 2014, 07:07 PM
Post Reply Subscribe to Thread Email Thread
15th July 2014, 12:56 PM |#31  
simacca's Avatar
OP Senior Member
Flag Kent, uk
Thanks Meter: 161
 
More
Quote:
Originally Posted by Shonky*

I do. New S5 - about 3 weeks old. SM-G900I (Australian)

Wifi is off and just clicking it goes to that half greyed out state. If I exit and come back to settings it's back to off.

Haven't installed heaps of apps:

1) No adblockers
2) Not rooted
3) No Xposed framework
4) 3G/4G network still appears to be working ok once Wifi goes off
5) *Seems* to happening in the evening (not 100% sure on this)
6) Airplane mode on/off fixes it (as does reboot)
7) There is no connection optimiser that I can find.
8) Don't think it was happening until recently (i.e. when new was OK).
9) I do use MultiWindow occasionally (usually web links in Gmail opening Chrome)

Can't really afford to factory reset at this point.

If it annoys you enough and you can't solve the problem the only thing left to try Will have to be a factory reset. It solved the problem for me. I am now rooted (towelroot) with adblockers and the problem still hasn't returned.

I know it's a pain to factory reset because you lose everything and have to start again, but it is a last resort and may solve the problem for you.

Sent from my SM-G900F using Tapatalk
 
 
15th July 2014, 01:08 PM |#32  
Member
Thanks Meter: 4
 
More
Yeah not the end of the world, but I don't have heaps of time to muck around with it and there's the risk that it will just happen again when I set it all up the same.

It would be nice if Android could do the full backup restore like iPhones/iTunes can.
15th July 2014, 03:33 PM |#33  
simacca's Avatar
OP Senior Member
Flag Kent, uk
Thanks Meter: 161
 
More
Quote:
Originally Posted by Shonky*

Yeah not the end of the world, but I don't have heaps of time to muck around with it and there's the risk that it will just happen again when I set it all up the same.

It would be nice if Android could do the full backup restore like iPhones/iTunes can.

There is rumour that Android will be introducing a similar function soon.

Sent from my SM-G900F using Tapatalk
16th July 2014, 12:09 AM |#34  
fffft's Avatar
Senior Member
Thanks Meter: 667
 
More
Quote:
Originally Posted by Unofficial 4.4.3 update changelog

frequent data connection dropout fix ...
Wi-Fi auto-connect fix

http://bgr.com/2014/03/31/android-4-...ate-changelog/


Quote:
Originally Posted by Shonky

It would be nice if Android could do the full backup restore like iPhones/iTunes can.

You can have this today if you install a third party custom recovery e.g. TWRP


.
16th July 2014, 12:37 AM |#35  
Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by fffft

http://bgr.com/2014/03/31/android-4-...ate-changelog/




You can have this today if you install a third party custom recovery e.g. TWRP


.

To me neither of those fixes are for this problem. Either way I'm looking at months before a Samsung update most likely.

I'm trying not to hack this one too much so haven't rooted etc.
21st July 2014, 04:40 PM |#36  
Member
Thanks Meter: 4
 
More
Well to report back, I've done nothing extreme (like factory resets) and it seems fixed. What I DID change was that I changed the "Keep Wifi on during sleep" setting back to "Always" rather than "Only when plugged in" which I think I had at the time.

It doesn't seem to affect battery life too much and it is quite possible that this setting could cause a problem.
Last edited by Shonky*; 22nd July 2014 at 12:06 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes