FORUMS

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more

[Q] Need driver help for my KF - ADB is not detecting the device when in TWRP Mode

67 posts
Thanks Meter: 2
 
By shadowblade2652, Member on 29th June 2014, 08:45 AM
Post Reply Subscribe to Thread Email Thread
9th July 2014, 04:52 PM |#11  
LinearEquation's Avatar
Senior Member
Flag Midwest
Thanks Meter: 432
 
More
Quote:
Originally Posted by shadowblade2652

nonononono it's quite weird
In fastboot mode, the device is easily recognized by the computer. i can flash and have no problems whatsoever. When I try to use TWRP to copy the image to the device, that's where I get the issue.

If you want, copy and paste your environment path here. Let's check and make sure it looks good.

Sent from my Nexus 7 Flo running Paranoid Android 4.4.4 using XDA premium 4 mobile app
 
 
10th July 2014, 05:30 AM |#12  
OP Member
Flag San Francisco
Thanks Meter: 2
 
More
Quote:
Originally Posted by LinearEquation

If you want, copy and paste your environment path here. Let's check and make sure it looks good.

Sent from my Nexus 7 Flo running Paranoid Android 4.4.4 using XDA premium 4 mobile app

And what do you mean by that? What is the environment path?

I know it can be flashed in fastboot as the computer recognizes it and fastboot detects it as a device. It's just that in twrp the computer is unable to find any drivers for it.
10th July 2014, 01:46 PM |#13  
LinearEquation's Avatar
Senior Member
Flag Midwest
Thanks Meter: 432
 
More
Quote:
Originally Posted by shadowblade2652

And what do you mean by that? What is the environment path?

I know it can be flashed in fastboot as the computer recognizes it and fastboot detects it as a device. It's just that in twrp the computer is unable to find any drivers for it.

In order for your tablet to be recognized in fastboot, you would have had to set the path. I think your bs'n me.

Sent from my Nexus 7 Flo running Paranoid Android 4.4.4 using XDA premium 4 mobile app
11th July 2014, 08:32 AM |#14  
OP Member
Flag San Francisco
Thanks Meter: 2
 
More
Quote:
Originally Posted by LinearEquation

In order for your tablet to be recognized in fastboot, you would have had to set the path. I think your bs'n me.

Sent from my Nexus 7 Flo running Paranoid Android 4.4.4 using XDA premium 4 mobile app

m8 I have no idea what you are talking about.

I started the cyanogen mod tutorial that they have on the wiki, and I got to flashing the custom bootloader and the twrp recovery mode. After that, the device wasn't recognized during TWRP mounting so I wasn't able to mount and copy over the CM image for installation. That's why I am stuck now. Could you please link me to or attach the kindleOS stock rom so I can flash it and go back to stock kindleOS. Right now I have an expensive brick and it's seriously bugging me.
11th July 2014, 11:06 PM |#15  
OP Member
Flag San Francisco
Thanks Meter: 2
 
More
Quote:
Originally Posted by LinearEquation

In order for your tablet to be recognized in fastboot, you would have had to set the path. I think your bs'n me.

Sent from my Nexus 7 Flo running Paranoid Android 4.4.4 using XDA premium 4 mobile app

Do you mean the windows path? If you do, I used the installer I found on this website along with the kindle fastboot drivers found from amazon and it was already added to the path.
15th July 2014, 02:44 AM |#16  
OP Member
Flag San Francisco
Thanks Meter: 2
 
More
another shameless self bump.
19th July 2014, 03:39 AM |#17  
OP Member
Flag San Francisco
Thanks Meter: 2
 
More
bump?
20th July 2014, 02:14 PM |#18  
Senior Member
Flag Singapore
Thanks Meter: 2
 
Donate to Me
More
im facing the same problem here, i restored my kf hd 8.9 back to stock using this thread: http://forum.xda-developers.com/show....php?t=2468988

however, i just cant connect to the device via adb. fastboot is working, so the drivers are fine. adb has been enabled on the device's settings panel.

i need adb to root the device and reinstall the 2nd bootloader for custom roms.
21st July 2014, 07:17 AM |#19  
stunts513's Avatar
Recognized Contributor
Flag New Braunfels, TX
Thanks Meter: 619
 
Donate to Me
More
It might actually be a driver problem, switching between twrp, fastboot, and a android os have caused issues for me before where I NAD to uninstall the driver and reinstall it, and sometimes it would have a USB composite USB device I'd have to remove to fix it(had a bird of 1949 so I new it was the kindle).
21st July 2014, 09:07 PM |#20  
OP Member
Flag San Francisco
Thanks Meter: 2
 
More
surprisingly restoring back to stock and then doing it again worked. I'm now running 4.4.4

Thanks for the help stunts, sjj, and linear

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes