Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,023 Members 40,744 Now Online
XDA Developers Android and Mobile Development Forum

[APP][4.4][ROOT] SDFix: Modify device permissions to allow apps to write to MicroSD

Tip us?
 
seebold
Old
#111  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Question Root, fix and unroot -- possible?

Dear developers,

thanks for the work on the "sdcard issue on kitkat". I really longing for the old behavior but have a bad feeling to let my phone rooted. I have read, that I can root and unroot my HTC one m8. My question: Is it possible to root my phone, use this app to fix the bug/feature/issue and unrrot the device at the end? Or will the unroot procedure restore all changes? Did anyone try?

Thanks and keep it up!
Seebold
 
Bio24
Old
#112  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Jun 2013
I try this app, but third party app still could not write on SD card... any solution? My phone Xperia Z1 compact firmware 14.4.A.0.108

Any Z1 compact user have suggestions ?
 
CEM90
Old
#113  
Junior Member
Thanks Meter 1
Posts: 13
Join Date: Mar 2013
I'm glad I found this app. I was tired of the restrictions.

Sent from my SM-N900A using XDA Free mobile app
 
Alexandros1972
Old
#114  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: May 2008
Default No effect on rooted Xperia Z-Ultra 4.4.4

I've tried SdFix on z-ultra 14.4.A.0.108 rooted and still i cannot move any applications at all in the micro-sd
 
m0han
Old
#115  
m0han's Avatar
Senior Member
Thanks Meter 485
Posts: 1,140
Join Date: Apr 2012
Quote:
Originally Posted by tliebeck View Post
.... a simple app which modifies KitKat devices to allow user-installed applications to write to the MicroSD card on devices with two storage locations.
....... let me know if the app does not work for you, and what type of device/ROM/etc you're using.....
using Xolo Q3000 device with Stock Rooted Android v4.4.2. used this app. all seemed well. but.... (i just hope this is not deemed off-topic here....)

i'm trying to use onandroid v9.51 to create nandroid backups while the device is running. see pics of command output and also platform.xml.



i even tried making changes to /mnt/media_rw like in the pic below (right). still, no go!



any idea why the file system remains read-only? please suggest a workaround or alternate methods. i'm not knowledgeable enough. many thanks in advance.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes