Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,354 Members 43,955 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Cubot X6 Support

Tip us?
 
SomeOneX
Old
#11  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: May 2012
Default Boost the Cubot X6

I think the Cubot X6 has two big problems:

1. You have only 1 GB RAM
2. You can only use 1,4 GB internal memory for the apps

The first problem is easy to solve. You can use the Roehsoft RAM Expander to create a swap file. Therefore you can increase the RAM up to 4 GB. It works very well!

The second problem is more difficult. I tried to install Link2SD, but I always get the error message: "Link2SD invalid package". Maybe the Cubot X6 (official Rom 1.0) is not compatible with the current Link2SD version??? I don't know.

Then I look in the following vold.fstab file

PHP Code:
## Vold 2.0 Generic fstab 
## - San Mehat (san@android.com) 
##  

####################### 
## Regular device mount 
## 
## Format: dev_mount <label> <mount_point> <part> <sysfs_path1...>  
## label        - Label for the volume 
## mount_point  - Where the volume will be mounted 
## part         - Partition # (1 based), or 'auto' for first usable partition. 
## <sysfs_path> - List of sysfs paths to source devices 
###################### 

## Example of a standard sdcard mount for the emulator / Dream 
# Mounts the first usable partition of the specified device 
dev_mount sdcard /storage/sdcard0 emmc@fat /devices/platform/goldfish_mmc.0 /devices/platform/mtk-msdc.0/mmc_host 
dev_mount sdcard2 
/storage/sdcard1 auto /devices/platform/goldfish_mmc.1 /devices/platform/mtk-msdc.1/mmc_host 
## Example of a dual card setup 
# dev_mount left_sdcard  /mnt/sdcard1  auto /devices/platform/goldfish_mmc.0 /devices/platform/mtk-sd.0/mmc_host/mmc0 
# dev_mount right_sdcard /mnt/sdcard2  auto /devices/platform/goldfish_mmc.1 /devices/platform/mtk-sd.2/mmc_host/mmc2 

## Example of specifying a specific partition for mounts 
# dev_mount sdcard /mnt/sdcard 2 /devices/platform/goldfish_mmc.0 /devices/platform/msm_sdcc.2/mmc_host/mmc1 
dev_mount usbotg /mnt/usbotg auto /devices/platform/mt_usb 
and tried to modify it.But I failed again.

Maybe someone has a better solution to solve the second problem.

(Excuse my bad english)
 
insx
Old
#12  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Mar 2011
I managed to install the official 1.0 from needrom and all seems good so far.
 
SomeOneX
Old
#13  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: May 2012
The 1.0 Rom is good, but it doesn't solves all problems.

By the way, I installed Link2SD 3.5.1 and it works!!! Perfect!

Gesendet von meinem CUBOT X6 mit Tapatalk
 
smokiedawson
Old
#14  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jun 2013
Default Keyboard calibration problems

Hi, is anyone else having problems with the keyboard? I installed the latest 1.0 ROM, hoping it would fix but no it didn't. Problem is it seems the keys are not calibrated properly with what is displayed on the screen. Seem to have to hit the top part of letters out anything on the keyboard for it to register the correct key, example I might hit ? But I will get a . this is really annoying add I spend more time fixing errors than inputting. Couple of questions, is there any way to recalibrate the screen?
Would installing muii room solve the issue - noticed someone on here is using it.
Have also tried swiftkey etc, but doesn't help.
Really hippie someone can help add it's so annoying not to be able to type properly.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...