Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,742 Members 37,364 Now Online
XDA Developers Android and Mobile Development Forum

SD card stopped being recognized abruptly

Tip us?
 
hakam3akasheh
Old
(Last edited by hakam3akasheh; 29th April 2014 at 06:39 AM.) Reason: No title for the query
#1  
Junior Member - OP
Thanks Meter 0
Posts: 10
Join Date: Apr 2013
Default SD card stopped being recognized abruptly

Hi
My Xperia Z2 tablet stopped recognizing the SD card. It was perfect before turning it off. When I check "storage" under settings it says mount SD card. Nothing happens when I try to mount it. Is this an SD card issue or a tablet issue?
Thanks
 
QualQuek
Old
#2  
QualQuek's Avatar
Senior Member
Thanks Meter 60
Posts: 376
Join Date: Oct 2012
Location: Paris
Quote:
Originally Posted by hakam3akasheh View Post
Hi
My Xperia Z2 tablet stopped recognizing the SD card. It was perfect before turning it off. When I check "storage" under settings it says mount SD card. Nothing happens when I try to mount it. Is this an SD card issue or a tablet issue?
Thanks
What is your SDCard?
Have you tried to reformat it on your comp then re put it in your phone?
French Android Games Tester Youtube Channel
Shou Screen Recorder for Android
Sony Xperia Z1 - C6903 - KK 4.4.2 Stock ROM Rooted by [NUT] - Sony Xperia Z2 Tablet Stock ROM
 
hakam3akasheh
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 10
Join Date: Apr 2013
Quote:
Originally Posted by QualQuek View Post
What is your SDCard?
Have you tried to reformat it on your comp then re put it in your phone?
My card is Samsung 64 GB Class 10, bought from ebay. I had a movie on the card which I was watching on the tablet last night. This morning however, the tablet did nor recognise the card. All it says under "storage" is mount card, and i tried mounting the card but nothing happens. The card was not formatted on a computer, but erased by the tablet before being used.
The reason I mentioned ebay is because, according to google, many cards on ebay are fake. I'm only hoping it's the card not the tablet.

Thanx
 
aeon101
Old
#4  
Member
Thanks Meter 7
Posts: 62
Join Date: Jan 2006
Location: Prague
What File Manager are you using? This happened 2 times on my Xperia Z Ultra and 2 HC 10 32 GB cards were destroyed...but it happened only by using Total Commander, since that time I do not work with him anymore and everything is fine...
 
hakam3akasheh
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 10
Join Date: Apr 2013
Quote:
Originally Posted by aeon101 View Post
What File Manager are you using? This happened 2 times on my Xperia Z Ultra and 2 HC 10 32 GB cards were destroyed...but it happened only by using Total Commander, since that time I do not work with him anymore and everything is fine...
I did not install a file manager. The tablet came with File commander, and that's the one I use.
 
jai23
Old
#6  
Junior Member
Thanks Meter 3
Posts: 18
Join Date: Apr 2014
There are a lot of fake/faulty sd cards on eBay, try it in a different device.
 
JAID1
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jul 2014
Default Same SD, same problem

Quote:
Originally Posted by hakam3akasheh View Post
My card is Samsung 64 GB Class 10...
Thanx
My card is exactly the same (I think) Samsung miniSDXC 64GB. Bought from a normal retailer. Similar problem to yours (I think)

I have not been able to find a solution.

The SD worked fine for a couple months. I notice there is no click upont pressing the card in (as the Sony manual describes) but it seems to sit a fair way in. Sometimes when viewed in Settings the card is visible but never when the phone is plugged into a USB port of the computer. Mostly it shows instantaneously when you push it in and then dissappears as quickly and the request to mount a card shows.

On one of the few times it stayed visible (not with the USB cable in) it showed about 12GB used. It seems to have been coming on and off intermitently during use. Accordingly, some photographs end up going to it and then not being accessible and some, or most, just end up in the main phone memory. This is assumed as a number of photographs taken are not showing. I have sent them from the phone main memory via dropbox as the computer can access none on the phone at all...perhaps because I have pathed them to the SD.

Will get and try another SD card but one possibilty is that this may be a problem with the SD card housing in the telephone.

.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...