Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,198 Members 41,020 Now Online
XDA Developers Android and Mobile Development Forum

Moto G 4g LTE - Sandisk ultra 32gb microsd card won't mount

Tip us?
 
-HuntDX-
Old
#121  
-HuntDX-'s Avatar
Senior Member
Thanks Meter 173
Posts: 812
Join Date: Feb 2011

 
DONATE TO ME
It only occurs with my UHS-I 16GB Toshiba. but fine with 8GB Transcend.

Sent from my XT1039 using XDA Premium 4 mobile app
Device: Moto G LTE
ROM: Stock 4.4.4 | Unlocked | Rooted | CWM 6.0.5.0

Device: Nokia Lumia 620
ROM: WP8.1 Dev Preview | Lumia Black

Phone: iPad mini Retina Disp.
ROM: iOS 7.1.1

Retired Device: 5320XM, Nokia 6300, Xperia X8, Xperia Ray
 
Halv
Old
#122  
Halv's Avatar
Member
Thanks Meter 0
Posts: 34
Join Date: Dec 2010

 
DONATE TO ME
Just ordered the Moto G LTE from Tesco Mobile in the UK. Not sure if it's relevent but the phone was out of stock there for a week or two and has now gone up 5 in price. Does this mean these could be a new batch or something?

I'm just asking because I'm currently looking for a Micro SD card online and I'm not sure whether or not to take the risk of buying a Class 10.

Is there much difference (noticeable) between class 10 and class 6. This will be a 32GB micro SD.
 
spatuluk
Old
#123  
spatuluk's Avatar
Junior Member
Thanks Meter 0
Posts: 22
Join Date: Jun 2010
Location: Manchester
I received my Moto G 4G (XT1039, Android 4.4.3) from Tesco yesterday. I put in a 32gb Sandisk Ultra sdcard that used to live in my Sony Ericsson SK17i, and it said the card was damaged (reformat?). I let it reformat, thinking the phone would do it best, and it worked - I could store stuff on the card...

...until this morning, when I noticed that some of the games I'd downloaded last night had vanished from the menu. Then I spotted the 'Blank SD card' notification. I tried a restart, but it's still supposedly blank. It's definitely not, as I can read the contents using my SK17i.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes