Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,798 Members 50,206 Now Online
XDA Developers Android and Mobile Development Forum

[KITCHEN] ArchiKitchen - Android Kitchen (WIP) [Linux]

Tip us?
 
ShinySide
Old
#1251  
ShinySide's Avatar
Senior Member
Thanks Meter 1532
Posts: 1,223
Join Date: Nov 2013
Location: IHB
Quote:
Originally Posted by bombaybadboy View Post
this is the first time i have seen this error and its always worked before for my i9500
 
Code:
Select Code
CHOICE: ku
/home/bbb/ArchiKitchen/archi: line 700: cd: tools/kernel/mkbootimg: No such file or directory
gcc -o unpackbootimg.o -ffunction-sections -O3 -c unpackbootimg.c -Werror
unpackbootimg.c: In function ‘read_padding’:
unpackbootimg.c:28:10: error: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Werror=unused-result]
     fread(buf, count, 1, f);
          ^
unpackbootimg.c: In function ‘main’:
unpackbootimg.c:87:14: error: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Werror=unused-result]
         fread(tmp, BOOT_MAGIC_SIZE, 1, f);
              ^
unpackbootimg.c:99:10: error: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Werror=unused-result]
     fread(&header, sizeof(header), 1, f);
          ^
unpackbootimg.c:182:10: error: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Werror=unused-result]
     fread(kernel, header.kernel_size, 1, f);
          ^
unpackbootimg.c:195:10: error: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Werror=unused-result]
     fread(ramdisk, header.ramdisk_size, 1, f);
          ^
unpackbootimg.c:209:14: error: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Werror=unused-result]
         fread(second, header.second_size, 1, f);
              ^
unpackbootimg.c:224:14: error: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Werror=unused-result]
         fread(dtb, header.dt_size, 1, f);
              ^
cc1: all warnings being treated as errors
make: *** [unpackbootimg.o] Error 1
ERROR! Something went wrong with compilation of mkbootimg!


it worked fine 9 days ago any ideas guys
I posted the exact same error like 2-3 pages ago. It's only with osmosis' mkbootimg tho. I compiled cms and aosps with out a hitch

Sent from my GT-I9505 using XDA Premium 4 mobile app
Donations Accepted here


Don't change your wants or where you want to be just because the other has.
The Following User Says Thank You to ShinySide For This Useful Post: [ Click to Expand ]
 
bombaybadboy
Old
(Last edited by bombaybadboy; 28th July 2014 at 12:06 AM.)
#1252  
bombaybadboy's Avatar
Recognized Contributor
Thanks Meter 17202
Posts: 7,445
Join Date: Apr 2012
Location: wolverhampton
Quote:
Originally Posted by ShinySide View Post
I posted the exact same error like 2-3 pages ago. It's only with osmosis' mkbootimg tho. I compiled cms and aosps with out a hitch

Sent from my GT-I9505 using XDA Premium 4 mobile app
This was from I9500XXUGNG3 latest firmware and i built with no problems the day it was released. I have since then reinstalled ubuntu as duel boot with my win 8.1 and thought i had missed something

I still have the original boot.img from first time i built from this firmware so im ok this time. I was just worried about next time i need to update my rom. I just used kernel kitchen and manually made edits without any problems

Sent from my GT-I9500 using Tapatalk 2
 
prdog1
Old
#1253  
prdog1's Avatar
Recognized Contributor
Thanks Meter 4419
Posts: 7,778
Join Date: Mar 2012
Location: Houston, Texas
Quote:
Originally Posted by bombaybadboy View Post
This was from I9500XXUGNG3 latest firmware and i built with no problems the day it was released. I have since then reinstalled ubuntu as duel boot with my win 8.1 and thought i had missed something

Sent from my GT-I9500 using Tapatalk 2
remove -Werror from the makefile in tools/kernel/mkboot.img and it will run.
TEAM MiK / TEAM CLEAN
Current Devices:
Samsung Galaxy SIII-I535
The Following User Says Thank You to prdog1 For This Useful Post: [ Click to Expand ]
 
bombaybadboy
Old
#1254  
bombaybadboy's Avatar
Recognized Contributor
Thanks Meter 17202
Posts: 7,445
Join Date: Apr 2012
Location: wolverhampton
Quote:
Originally Posted by prdog1 View Post
remove -Werror from the makefile in tools/kernel/mkboot.img and it will run.
Thanks that worked

Sent from my GT-I9500 using Tapatalk 2
 
prdog1
Old
#1255  
prdog1's Avatar
Recognized Contributor
Thanks Meter 4419
Posts: 7,778
Join Date: Mar 2012
Location: Houston, Texas
Quote:
Originally Posted by bombaybadboy View Post
Thanks that worked

Sent from my GT-I9500 using Tapatalk 2
It's not only Osmosis version. Have seen the same problem in the Ubuntu threads. That is always the fix.
TEAM MiK / TEAM CLEAN
Current Devices:
Samsung Galaxy SIII-I535
The Following User Says Thank You to prdog1 For This Useful Post: [ Click to Expand ]
Tags
dsixda kitchen justarchi android chef
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes