Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,675 Members 46,287 Now Online
XDA Developers Android and Mobile Development Forum

Galaxy S3 - Kitkat Discussion Thread

Tip us?
 
Zaphodspeaks
Old
(Last edited by Zaphodspeaks; Yesterday at 05:48 PM.)
#221  
Zaphodspeaks's Avatar
Senior Member
Thanks Meter 31
Posts: 197
Join Date: Oct 2013
Quote:
Originally Posted by DocHoliday77 View Post
IME, neither store employees or tech support (or any other employee for that matter) have a clue about anything that isn't directly related to their job. (Reading from the screen, selling you a new device, etc). Not even the ones who help via the T-Mobile support forums ever get this info, and they seem to be the most knowledgeable of anyone in just about every area.
I will admit though, I have been wondering about it myself, but it still just doesn't make sense to not release it.

And as for the store employees, some said the same thing about 4.3, but as it turned out, they either just didn't know, or were lying in hopes of getting folks to buy new devices.
All I know for sure anymore though, is Samsung did fully develop and release a final RC 4.4.2 to T-Mobile. And with how aggressive they've been with their competition lately, it just doesn't make any sense to me why they wouldn't release it. (Especially when the T999L and T999N variants are still considered relatively new). I do honestly wonder if it just didn't get buried under some supervisors pile of paperwork or accidentally deleted or ignored an email.....who knows at this point.

In the end though, it still doesn't matter too much to me. Aside from not having WiFi calling, the Sprint port has still been one of the best roms I've run to date. And for those who are wanting something fresh and new, there will be some more roms ported over pretty soon. In particular, look out for TMS3KK, and quite possibly S3rx in the near future. (S3rx v4 is currently being worked on for AT&T and I'm sure will be ported for us shortly after its completed.)

There may not be much direct development on the T999 anymore, but its not quite dead yet!
When I purchased my S3 about 6 months or so ago, it looked like I knew more about the Device then they did.. I asked all kinds of normal every day questions, like if it supported NFC, or Wireless Charging.. just to see if the salesman knew his stuff.. and I couldn't get a straight answer from any of them.. As a hobby I like to keep up with all the latest stuff, and I'm sure more than half the people on this forum do the exact same thing and would make a better salesman than those guys at the local cell store.. Sometimes I wonder how they even got their jobs.. When I bought my S3 they said it did not support wireless charging, and I called *ull****... and came back when I got my adapter and showed them..

Edit: I have had my Asus Epad Transformer Tf101 for a couple of years, and with Developers like timduru that develop the KatKiss rom, which just makes my old TF101 feeling brandnew.. I have nothing but respect for those developers that keep old devices going with the latest stuff. I know it doesn't bring in the big bucks, but I have been dabbling with Android and what you guys do to compile the rom is nothing short of amazing..
====================================
Device: Asus TF101 (Currently rocking Katkiss 4.4.4)
Device: Nexus 7 2012 16gig.. (Broken)
Device: Nexus 7 2013 Flo 32gig, (Currently Rocking PACROM 4.4.4)
Device: Samsung Galaxy S3 LTE T999L T-Mobile (S3Rx 3.0 T-Mobile, and Carbon 4.4.4 with DKP Kernel)
====================================
 
yahanna
Old
#222  
Member
Thanks Meter 3
Posts: 42
Join Date: Jun 2014
Quote:
Originally Posted by sector4 View Post
Yes it it. At least the one in our forums does. I had it installed already. The Light version wouldn't load passed selecting the Lang at setup. But the 2.5 beta worked great.

http://forum.xda-developers.com/show....php?t=2770980
Hi sector.. On the 1st page to the link it says I need a 4.3 modem and bootloader. I still got 4.3 JB. Is it ok to install on my phone?
 
sector4
Old
#223  
Junior Member
Thanks Meter 0
Posts: 12
Join Date: Aug 2011
Quote:
Originally Posted by yahanna View Post
Hi sector.. On the 1st page to the link it says I need a 4.3 modem and bootloader. I still got 4.3 JB. Is it ok to install on my phone?
I was on 4.3 nc2 and used it.

Sent from my SM-G900T using XDA Premium 4 mobile app
 
Perseus71
Old
#224  
Perseus71's Avatar
Recognized Contributor
Thanks Meter 3368
Posts: 5,678
Join Date: Feb 2011
Location: Atlantis

 
DONATE TO ME
Quote:
Originally Posted by yahanna View Post
Hi sector.. On the 1st page to the link it says I need a 4.3 modem and bootloader. I still got 4.3 JB. Is it ok to install on my phone?
Quote:
Originally Posted by sector4 View Post
I was on 4.3 nc2 and used it.
Discussion about a particular Thread should happen on THAT thread not here. Don't Sidetrack/derail this thread.
 
SpeedsterPaul
Old
(Last edited by SpeedsterPaul; Yesterday at 06:19 PM.)
#225  
Junior Member
Thanks Meter 2
Posts: 12
Join Date: Jun 2014
Quote:
Originally Posted by Perseus71 View Post
Do I understand right that T999L and T999N haven't got the update either ?
Yeah we don't have it either

Sent from my SGH-T999N using XDA Free mobile app
 
Perseus71
Old
#226  
Perseus71's Avatar
Recognized Contributor
Thanks Meter 3368
Posts: 5,678
Join Date: Feb 2011
Location: Atlantis

 
DONATE TO ME
Quote:
Originally Posted by SpeedsterPaul View Post
Yeah we don't have it either
Thanks. That makes it even more weirder. Those Devices should have got it.

A careful digging revealed that T-mo is the only one whose app "My Account" that clearly identified the CiQ and User information Gathering policies. So perhaps, samsung is required to unbundle CiQ for their sake and have that included in that app. Potentially that could be the reason. Perhaps WiFi Calling is having issues with 4.4.2 ?
 
DocHoliday77
Old
#227  
DocHoliday77's Avatar
Recognized Contributor
Thanks Meter 5183
Posts: 7,431
Join Date: May 2011
Location: HuntsVegas!!!

 
DONATE TO ME
Quote:
Originally Posted by Perseus71 View Post
Do I understand right that T999L and T999N haven't got the update either ?
Nope. Only the T999V and afaik every other Qualcomm based S3 has been updated. Only the T999, T999L and T999N have not.

---------- Post added at 02:24 PM ---------- Previous post was at 02:16 PM ----------

Quote:
Originally Posted by Perseus71 View Post
Thanks. That makes it even more weirder. Those Devices should have got it.

A careful digging revealed that T-mo is the only one whose app "My Account" that clearly identified the CiQ and User information Gathering policies. So perhaps, samsung is required to unbundle CiQ for their sake and have that included in that app. Potentially that could be the reason. Perhaps WiFi Calling is having issues with 4.4.2 ?
For CiQ, ours is the only one that's kept it included for some time now, afaik anyway. And I don't think wifi calling is the issue. If T-Mobile had actually tested the RC and found it didn't work right, it would've been sent back to Samsung for further debugging. To my knowledge, T-Mobile hasn't even tested it yet. Apparently they got the RC and have just done nothing.
The past few releases, I've gotten wind of testing going on prior to release, even managed to get a leaked build out first. But not this time. Its like they got the memo, but never read it!

The Following 2 Users Say Thank You to DocHoliday77 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes