Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,225 Members 53,499 Now Online
XDA Developers Android and Mobile Development Forum

Lg phones apn type grayed out

Tip us?
 
Montrose480
Old
#11  
Junior Member
Thanks Meter 1
Posts: 5
Join Date: Jun 2013
Location: Andalusia
Okay I have figured out my problem I had flashed the 20 G version of 4. 4.2 KitKat and in so doing it was not letting me edit so I flashed back to 4.1 .2 did not root my phone set my APN settings and allowed the phone to update from the phone's software update once the phone was updated to the new 4.4.2 KitKat from at&t I rooted my phone and used to the SqLite editor to go in and change my settings now my picture messages works... I did not delete anything I only changed the two settings that were mentioned buy one of the commentators in the section

Sent from my QMV7A using XDA Free mobile app
The Following User Says Thank You to Montrose480 For This Useful Post: [ Click to Expand ]
 
ratkiley
Old
(Last edited by ratkiley; 7th July 2014 at 02:36 AM.) Reason: Add the attachments
#12  
Junior Member
Thanks Meter 2
Posts: 5
Join Date: Nov 2012
Location: Denver

 
DONATE TO ME
Default Solution for Android 4.4.2 (Build E98020G) on Straight Talk (AT&T LTE)

I tried every solution I could find on the web for changing the APNs on my rooted LG Optimus G Pro E980, but at first, nothing worked. Eventually, I came to this solution:

Although the /system/etc/apns-config.xml file has several, misleading APN values in it, this file is not used to store the APN records in Android 4.4.*. Instead, APNs are stored in the /data/data/com.android.providers.telephony/databases/telephony.db SQLite database.

However, the stock version of Android supplied by AT&T for the Optimus G Pro - Android 4.4.2 (Build E98020G), has disabled the ability to add working APN settings through the system APN settings dialog by defaulting all new APNs to have the (apn) type="default,dun". The settings screen does not let you change this value, so you have to edit the values directly in the SQLite database.

None of the free SQLite-database-editors in the Android market were able to edit the read-only /data/data/com.android.providers.telephony/databases/telephony.db file (after following instructions for editing the APN in the database in the folder where it is stored).

So, using ES File Manager (search for "com.estrongs.android.pop" on google play), I copied it to my SD-Card, copied to my computer and edited it with SQLite Database Browser (a SourceForge project identified as sqlitebrowser).

VERY IMPORTANT: The permissions change both when copying it to and when copying it from the SD-Card. So, I had to set the permissions back to the original telephony.db permissions & owner, (matching the other .db files in the /data/data/com.android.providers.telephony/databases/ folder):

RW-RW----

VERY IMPORTANT:Change the file owner and group back to "radio" from "root". If you do not change the owner back when you copy the file back to the /data/data/com.android.providers.telephony/databases/telephony.db path, the phone.apk process will repeatedly crash until it restarts your phone (and your phone will keep rebooting until you delete the telephony.db file that is owned by "root").

So, to make it easier for you to change your APN settings on your phone, I have attached my working telephony.db file. It contains only one APN record for Straight Talk on AT&T's LTE network. I deleted all of the other APNs, per Straight Talk's APN instructions.

After making this change to the APNs stored in the telephony.db, renaming the old telephony.db file for a backup, copying over the new telephony.db, changing the permissions & owner of the file, and rebooting, I was able to send and receive text messages and picture messages (MMS) to myself.

Note: My phone came with the correct "Service Center Address" setting, because it was an AT&T branded phone before I brought it to Straight Talk. However, you may need to change this setting if you came from another carrier with your phone. The correct setting for Straight Talk customers on the AT&T LTE network should be (the same as it is for AT&T customers on an AT&T plan):

Code:
Select Code
+13123149810
Also, there is a rumor spreading around the internet that you cannot send MMS messages when your WIFI is connected (instead of a 4G LTE connection). That is false: my phone sends and receives MMS messages while the WIFI is connected.

If you are curious, I also attached the database dump of the telephony.db auto-generated by SQLite Database Browser. It is a text file called "telephony-dump.sql".
Attached Files
File Type: zip telephony.zip - [Click for QR Code] (2.9 KB, 15 views)
File Type: zip telephony-dump.zip - [Click for QR Code] (2.1 KB, 4 views)
The Following User Says Thank You to ratkiley For This Useful Post: [ Click to Expand ]
 
brodood
Old
(Last edited by brodood; Yesterday at 10:46 PM.) Reason: Added step
#13  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jul 2014
Angry Finally an answer WITHOUT ROOT

It is possible to change the APN type without SQLite or root. The guys at my work figured this out. It is kind of a tricky workaround, but this is tested and working on LG Optimus G Pro, G Flex, and G2 with the MMS issues.

1. Go to the APN Settings and reset them to default. After that you should only see the AT&T APN
2. With the SIM card in the phone open Mobile Networks (get to the screen where you can click on Access Point names.)
3. DO NOT POWER OFF THE PHONE FOR THIS PART! On that screen and with the phone still on, slide the SIM out. You should get a prompt asking to reset the phone. DO NOT RESET THE PHONE.
4. After the prompt click on Access Point Names. There should be no APNs here. If the AT&T APN is still here go back to step 1.
5. Now you need to create a new APN whit the SIM is removed. The APN should be as follows:
Name: Straight Talk MMS
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: 66.209.11.33
mmsport: 80
mmsc: http: // mms-tf. net - This is spaced for Junior User restrictions. Should be no spaces.
authtype:none
type: mms
THE APN TYPE SHOULD ONLY BE FOR MMS. DO NOT PUT ANYTHING ELSE IN THE "TYPE" FIELD
6. Now with everything typed in DOUBLE CHECK EVERYTHING. If it is correct you can save this APN. Once it is saved there will still be no APNs on the APN page.
7. Pull the battery and put the SIM back in the phone.
8. Go back to the APN settings and DO NOT open the APN you just created or it will reset the entire process!!!!! If you did everything right the Straight Talk MMS APN you just made should not have the selection bubble. If you have a selection bubble on the Straight Talk MMS, go back to Step 1.
9. Make another new APN as Follows:
Name: Straight Talk
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: (blank)
mmsport: (blank)
mmsc: (blank)
Mcc: 310
Mnc : 410
type: default
10. Save this APN and select it. You should get LTE shortly after that.

That's it! If you want MMS without root this is the only other workaround I know of! This was tested on multiple Optimus G Pro, G Flex, and G2 and is working! Hope it Helps.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes