Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,541 Members 54,125 Now Online
XDA Developers Android and Mobile Development Forum

[Fix:] Broken LTE/Mobile Data/GPS

Tip us?
 
UnknownTroll1
Old
(Last edited by UnknownTroll1; 12th June 2014 at 05:43 PM.)
#1  
UnknownTroll1's Avatar
Senior Member - OP
Thanks Meter 24
Posts: 159
Join Date: Jul 2013
Default [Fix:] Broken LTE/Mobile Data/GPS

Hello XDA,

As many of you have been flashing custom ROMs; some of you have had an issue regarding broken mobile data/LTE/GPS has arisen. I too had this same issue when I was flashing ROMs and decided to post my fix. This is a guide that MAY fix your problem. NO GUARANTEES


For this to work properly you MUST be on a STOCK TW ROM. I used S3R.x's ROM but you can use whatever works for you. After you have gone back to a Stock TW ROM follow the steps outlined below:

1. Enter the Samsung service mode by typing this code into the dial pad *#197328640#
2. Then go to Mainmenu>UMTS>Common>NV REBUILD>NV REBUILD> (Important: don't exit the menu yet!)
3. Wait 30+ sec
4. Long press power button and select "Restart / Reboot"
5. Now check your GPS from any software that may use GPS like "Maps" or "GPS Status"
6. Flash your favorite ROM and go about your merry way!

Credit: S3R.x ROM Development Thread

Again this is a fix that worked for me and may not work for everyone. Also if any of this info is wrong or needs corrections, I am always open to suggestions!
Device: AT&T S3
ROM: Quantum ROM w/ Quantum Kernel
Hit the button if I helped you out!
The Following 2 Users Say Thank You to UnknownTroll1 For This Useful Post: [ Click to Expand ]
 
demonflame5
Old
#2  
Junior Member
Thanks Meter 0
Posts: 12
Join Date: Jul 2014
I get a connection problem or invalid MMI code error.

I can still make phone calls and sends and receive texts though.
 
UnknownTroll1
Old
#3  
UnknownTroll1's Avatar
Senior Member - OP
Thanks Meter 24
Posts: 159
Join Date: Jul 2013
Quote:
Originally Posted by demonflame5 View Post
I get a connection problem or invalid MMI code error.

I can still make phone calls and sends and receive texts though.
Are you on a stock TW ROM?

Sent from Mission Control
Device: AT&T S3
ROM: Quantum ROM w/ Quantum Kernel
Hit the button if I helped you out!
 
Fuoman
Old
#4  
Junior Member
Thanks Meter 1
Posts: 1
Join Date: Jul 2014
Default 4.4.2 gps issue

Quote:
Originally Posted by UnknownTroll1 View Post
Hello XDA,

As many of you have been flashing custom ROMs; some of you have had an issue regarding broken mobile data/LTE/GPS has arisen. I too had this same issue when I was flashing ROMs and decided to post my fix. This is a guide that MAY fix your problem. NO GUARANTEES


For this to work properly you MUST be on a STOCK TW ROM. I used S3R.x's ROM but you can use whatever works for you. After you have gone back to a Stock TW ROM follow the steps outlined below:

1. Enter the Samsung service mode by typing this code into the dial pad *#197328640#
2. Then go to Mainmenu>UMTS>Common>NV REBUILD>NV REBUILD> (Important: don't exit the menu yet!)
3. Wait 30+ sec
4. Long press power button and select "Restart / Reboot"
5. Now check your GPS from any software that may use GPS like "Maps" or "GPS Status"
6. Flash your favorite ROM and go about your merry way!

Credit: S3R.x ROM Development Thread

Again this is a fix that worked for me and may not work for everyone. Also if any of this info is wrong or needs corrections, I am always open to suggestions!
Worked wonders on stock rom after 4.4.2 update. had lost all gps and glonass, now the reset has brought my phone back from almost being thrown out of a 3 story high window to the ground. I also reset gps from the GPS Status app as well and downloaded the Xtra data and a-gps data. locks in seconds now. Thanks so much for the assistance.
Devo
The Following User Says Thank You to Fuoman For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes