Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,912 Members 40,819 Now Online
XDA Developers Android and Mobile Development Forum

[TWRP][PORT] Holofied Themes 480x800

Tip us?
 
Captain_Throwback
Old
#91  
Captain_Throwback's Avatar
Retired Moderator / Recognized Contributor
Thanks Meter 8767
Posts: 10,166
Join Date: Aug 2008
Location: Bensalem, PA

 
DONATE TO ME
Quote:
Originally Posted by Modding.MyMind View Post
You can still check out the port before you mess with the keyboardtemplate just so you are aware, but yea, I normally get that out of the way since it doesn't take me long at all.

Sent from my C525c using Tapatalk
It seems like everything ported okay! I had to change the font values as the default font was too large for the resolution I'm porting to. The only issue I seem to be having is that with the Black theme, the theme colors won't change. I'm stuck with orange highlights with light blue text, for some reason. Not sure what's up with that.
Device 1: HTC One (M8)/831C | Hardware Version: 0005

Baseband: 1.08.20.0612_4 | PRI: 2.62_003 | PRL: 56019
Recovery: TWRP 2.7.1.0

Device 2: HTC Jewel/PJ75100 (EVO 4G LTE) | Hardware Version: 0003

Baseband: 1.13.11.1105 | PRI: 3.02_003 | PRL: 56018
Recovery: TWRP 2.7.1.0b

Device 3: HTC Shooter/PG86100 (EVO 3D) | Hardware Version: 0002
Baseband: 1.09.00.0108 | PRI: 1.55_003 | PRL: 22100
Recovery: TWRP 2.7.1.0

Device 4: HTC Supersonic/PC36100 (EVO 4G) | Hardware Version: 0004
Baseband: 2.15.00.01.15 | PRI: 2.33_003 | PRL: 40460
Recovery: TWRP 2.7.1.0
The Following User Says Thank You to Captain_Throwback For This Useful Post: [ Click to Expand ]
 
Modding.MyMind
Old
#92  
Modding.MyMind's Avatar
Senior Member - OP
Thanks Meter 1362
Posts: 1,545
Join Date: Nov 2013
Location: Richmond, Virginia

 
DONATE TO ME
Quote:
Originally Posted by Captain_Throwback View Post
It seems like everything ported okay! I had to change the font values as the default font was too large for the resolution I'm porting to. The only issue I seem to be having is that with the Black theme, the theme colors won't change. I'm stuck with orange highlights with light blue text, for some reason. Not sure what's up with that.
Something on your end then. I can confirm that my port changes colors lol.

Sent from my C525c using Tapatalk
 
Captain_Throwback
Old
#93  
Captain_Throwback's Avatar
Retired Moderator / Recognized Contributor
Thanks Meter 8767
Posts: 10,166
Join Date: Aug 2008
Location: Bensalem, PA

 
DONATE TO ME
Quote:
Originally Posted by Modding.MyMind View Post
Something on your end then. I can confirm that my port changes colors lol.

Sent from my C525c using Tapatalk
I have no idea what, though. Was hoping for a little insight, lol.

---------- Post added at 01:14 PM ---------- Previous post was at 01:11 PM ----------

I just found something that's off with the port - the brightness scale no longer goes to 100. That value apparently got ported as well, lol.
Device 1: HTC One (M8)/831C | Hardware Version: 0005

Baseband: 1.08.20.0612_4 | PRI: 2.62_003 | PRL: 56019
Recovery: TWRP 2.7.1.0

Device 2: HTC Jewel/PJ75100 (EVO 4G LTE) | Hardware Version: 0003

Baseband: 1.13.11.1105 | PRI: 3.02_003 | PRL: 56018
Recovery: TWRP 2.7.1.0b

Device 3: HTC Shooter/PG86100 (EVO 3D) | Hardware Version: 0002
Baseband: 1.09.00.0108 | PRI: 1.55_003 | PRL: 22100
Recovery: TWRP 2.7.1.0

Device 4: HTC Supersonic/PC36100 (EVO 4G) | Hardware Version: 0004
Baseband: 2.15.00.01.15 | PRI: 2.33_003 | PRL: 40460
Recovery: TWRP 2.7.1.0
The Following User Says Thank You to Captain_Throwback For This Useful Post: [ Click to Expand ]
 
Modding.MyMind
Old
#94  
Modding.MyMind's Avatar
Senior Member - OP
Thanks Meter 1362
Posts: 1,545
Join Date: Nov 2013
Location: Richmond, Virginia

 
DONATE TO ME
Quote:
Originally Posted by Captain_Throwback View Post
I have no idea what, though. Was hoping for a little insight, lol.

---------- Post added at 01:14 PM ---------- Previous post was at 01:11 PM ----------

I just found something that's off with the port - the brightness scale no longer goes to 100. That value apparently got ported as well, lol.
Would you copy and past that line from the ui for me? Thanks for letting me know.

Sent from my C525c using Tapatalk
 
Captain_Throwback
Old
#95  
Captain_Throwback's Avatar
Retired Moderator / Recognized Contributor
Thanks Meter 8767
Posts: 10,166
Join Date: Aug 2008
Location: Bensalem, PA

 
DONATE TO ME
Quote:
Originally Posted by Modding.MyMind View Post
Would you copy and past that line from the ui for me? Thanks for letting me know.

Sent from my C525c using Tapatalk
Code:
Select Code
<data variable="tw_brightness_pct" min="10" max="100" />
It doesn't appear in the stock ui.xml, though - just in the Holofied theme.
Device 1: HTC One (M8)/831C | Hardware Version: 0005

Baseband: 1.08.20.0612_4 | PRI: 2.62_003 | PRL: 56019
Recovery: TWRP 2.7.1.0

Device 2: HTC Jewel/PJ75100 (EVO 4G LTE) | Hardware Version: 0003

Baseband: 1.13.11.1105 | PRI: 3.02_003 | PRL: 56018
Recovery: TWRP 2.7.1.0b

Device 3: HTC Shooter/PG86100 (EVO 3D) | Hardware Version: 0002
Baseband: 1.09.00.0108 | PRI: 1.55_003 | PRL: 22100
Recovery: TWRP 2.7.1.0

Device 4: HTC Supersonic/PC36100 (EVO 4G) | Hardware Version: 0004
Baseband: 2.15.00.01.15 | PRI: 2.33_003 | PRL: 40460
Recovery: TWRP 2.7.1.0
The Following User Says Thank You to Captain_Throwback For This Useful Post: [ Click to Expand ]
 
Modding.MyMind
Old
#96  
Modding.MyMind's Avatar
Senior Member - OP
Thanks Meter 1362
Posts: 1,545
Join Date: Nov 2013
Location: Richmond, Virginia

 
DONATE TO ME
Quote:
Originally Posted by Captain_Throwback View Post
Code:
Select Code
<data variable="tw_brightness_pct" min="10" max="100" />
It doesn't appear in the stock ui.xml, though - just in the Holofied theme.
Interesting, the script shouldn't be working that value at all. Which means I'm probably gonna need to fix up my conditional block checks.

Sent from my C525c using Tapatalk
 
Modding.MyMind
Old
#97  
Modding.MyMind's Avatar
Senior Member - OP
Thanks Meter 1362
Posts: 1,545
Join Date: Nov 2013
Location: Richmond, Virginia

 
DONATE TO ME
@Captain_Throwback, I found the problem and am working out a solution. That value for brightness is being modified within the XX wrapper function found in my script. The XX function searches for x="" values per line that is read during the while loop but I didn't take in to account that since I am using egrep that it will also grab values from any words that end with the letter x and follows after it with ="". That is why max="" is being modified because max="" matches x="". I will have to fix this for all values being searched since they all resemble the same outcome. Thanks for bringing this to my attention. This definitely needs to be fixed.

Sent from my C525c using Tapatalk
The Following User Says Thank You to Modding.MyMind For This Useful Post: [ Click to Expand ]
 
Modding.MyMind
Old
#98  
Modding.MyMind's Avatar
Senior Member - OP
Thanks Meter 1362
Posts: 1,545
Join Date: Nov 2013
Location: Richmond, Virginia

 
DONATE TO ME
@Captain_Throwback,

https://github.com/ModdingMyMind/TWR...8c2fe3a83be613

Problem resolved.

Sent from my C525c using Tapatalk

The Following User Says Thank You to Modding.MyMind For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes