Post Reply

[Q] Partially failed root?

OP arrrgh

11th June 2014, 06:48 PM   |  #1  
OP Member
Thanks Meter: 5
 
49 posts
Join Date:Joined: Jan 2011
More
Can someone explain why this is happening:

After unlocking, I started with flashing stock-17.1.1.A.0.402-sirius-repack.img from http://techerrata.com/browse/twrp2/sirius and was able to get to the new recovery ok. I then proceeded to flashing superuser. After flash and reboot I tried installing busybox but the install failed (, I got the superuser prompt as expected but install still failed. Xposed framework also failed to install with error about not being able to write to system. AdAway also couldn't write to hosts file.

Then I flashed Doom's CWM-Based Recovery 6.0.4.7 from http://forum.xda-developers.com/show....php?t=2702001 and everything started working.. busybox/xposed/adaway installed fine etc.

Why couldn't I install the above when running TRWP?
11th June 2014, 08:30 PM   |  #2  
beloero's Avatar
Member
Flag Fulda
Thanks Meter: 34
 
39 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by arrrgh

Can someone explain why this is happening:

After unlocking, I started with flashing stock-17.1.1.A.0.402-sirius-repack.img from http://techerrata.com/browse/twrp2/sirius and was able to get to the new recovery ok. I then proceeded to flashing superuser. After flash and reboot I tried installing busybox but the install failed (, I got the superuser prompt as expected but install still failed. Xposed framework also failed to install with error about not being able to write to system. AdAway also couldn't write to hosts file.

Then I flashed Doom's CWM-Based Recovery 6.0.4.7 from http://forum.xda-developers.com/show....php?t=2702001 and everything started working.. busybox/xposed/adaway installed fine etc.

Why couldn't I install the above when running TWRP?


I've experienced the same and found that the official TWRP Kernel doesn´t have enabled write permissions for the device.

Just take DooMloards unofficial build for .402:
http://forum.xda-developers.com/show....php?t=2764971

I hope this helps you.
Last edited by beloero; 11th June 2014 at 08:33 PM.
The Following User Says Thank You to beloero For This Useful Post: [ View ]
12th June 2014, 01:07 AM   |  #3  
OP Member
Thanks Meter: 5
 
49 posts
Join Date:Joined: Jan 2011
More
Cheers, yeah, I figured it was something like that..
1st August 2014, 08:44 PM   |  #4  
irishrally's Avatar
Senior Member
California
Thanks Meter: 501
 
3,317 posts
Join Date:Joined: Jun 2009
I'm having a similar issue with adaway not writing the hosts file and Root Exporter can't change to R/W. I'm on 314, used Easy Root and installed Supesu from the play store. Is there any way around this without installing a custom.recovery?
1st August 2014, 11:27 PM   |  #5  
BanziBaby's Avatar
Senior Member
Thanks Meter: 73
 
326 posts
Join Date:Joined: Oct 2010
@irishrally I had to remove SuperSU then flash ClockworkMod SuperUser to get AdAway to work right, with SuperSU it always failed to copy the hosts file, with CWM SuperUser it copies & applies it with no issues.
The Following User Says Thank You to BanziBaby For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Z2 Q&A, Help & Troubleshooting by ThreadRank