Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,770,879 Members 43,738 Now Online
XDA Developers Android and Mobile Development Forum

Lg phones apn type grayed out

Tip us?
 
Montrose480
Old
#11  
Junior Member
Thanks Meter 1
Posts: 5
Join Date: Jun 2013
Location: Andalusia
Okay I have figured out my problem I had flashed the 20 G version of 4. 4.2 KitKat and in so doing it was not letting me edit so I flashed back to 4.1 .2 did not root my phone set my APN settings and allowed the phone to update from the phone's software update once the phone was updated to the new 4.4.2 KitKat from at&t I rooted my phone and used to the SqLite editor to go in and change my settings now my picture messages works... I did not delete anything I only changed the two settings that were mentioned buy one of the commentators in the section

Sent from my QMV7A using XDA Free mobile app
The Following User Says Thank You to Montrose480 For This Useful Post: [ Click to Expand ]
 
ratkiley
Old
(Last edited by ratkiley; 7th July 2014 at 02:36 AM.) Reason: Add the attachments
#12  
Junior Member
Thanks Meter 3
Posts: 5
Join Date: Nov 2012
Location: Denver

 
DONATE TO ME
Default Solution for Android 4.4.2 (Build E98020G) on Straight Talk (AT&T LTE)

I tried every solution I could find on the web for changing the APNs on my rooted LG Optimus G Pro E980, but at first, nothing worked. Eventually, I came to this solution:

Although the /system/etc/apns-config.xml file has several, misleading APN values in it, this file is not used to store the APN records in Android 4.4.*. Instead, APNs are stored in the /data/data/com.android.providers.telephony/databases/telephony.db SQLite database.

However, the stock version of Android supplied by AT&T for the Optimus G Pro - Android 4.4.2 (Build E98020G), has disabled the ability to add working APN settings through the system APN settings dialog by defaulting all new APNs to have the (apn) type="default,dun". The settings screen does not let you change this value, so you have to edit the values directly in the SQLite database.

None of the free SQLite-database-editors in the Android market were able to edit the read-only /data/data/com.android.providers.telephony/databases/telephony.db file (after following instructions for editing the APN in the database in the folder where it is stored).

So, using ES File Manager (search for "com.estrongs.android.pop" on google play), I copied it to my SD-Card, copied to my computer and edited it with SQLite Database Browser (a SourceForge project identified as sqlitebrowser).

VERY IMPORTANT: The permissions change both when copying it to and when copying it from the SD-Card. So, I had to set the permissions back to the original telephony.db permissions & owner, (matching the other .db files in the /data/data/com.android.providers.telephony/databases/ folder):

RW-RW----

VERY IMPORTANT:Change the file owner and group back to "radio" from "root". If you do not change the owner back when you copy the file back to the /data/data/com.android.providers.telephony/databases/telephony.db path, the phone.apk process will repeatedly crash until it restarts your phone (and your phone will keep rebooting until you delete the telephony.db file that is owned by "root").

So, to make it easier for you to change your APN settings on your phone, I have attached my working telephony.db file. It contains only one APN record for Straight Talk on AT&T's LTE network. I deleted all of the other APNs, per Straight Talk's APN instructions.

After making this change to the APNs stored in the telephony.db, renaming the old telephony.db file for a backup, copying over the new telephony.db, changing the permissions & owner of the file, and rebooting, I was able to send and receive text messages and picture messages (MMS) to myself.

Note: My phone came with the correct "Service Center Address" setting, because it was an AT&T branded phone before I brought it to Straight Talk. However, you may need to change this setting if you came from another carrier with your phone. The correct setting for Straight Talk customers on the AT&T LTE network should be (the same as it is for AT&T customers on an AT&T plan):

Code:
+13123149810
Also, there is a rumor spreading around the internet that you cannot send MMS messages when your WIFI is connected (instead of a 4G LTE connection). That is false: my phone sends and receives MMS messages while the WIFI is connected.

If you are curious, I also attached the database dump of the telephony.db auto-generated by SQLite Database Browser. It is a text file called "telephony-dump.sql".
Attached Files
File Type: zip telephony.zip - [Click for QR Code] (2.9 KB, 31 views)
File Type: zip telephony-dump.zip - [Click for QR Code] (2.1 KB, 7 views)
The Following 2 Users Say Thank You to ratkiley For This Useful Post: [ Click to Expand ]
 
brodood
Old
(Last edited by brodood; 28th July 2014 at 10:46 PM.) Reason: Added step
#13  
Junior Member
Thanks Meter 3
Posts: 1
Join Date: Jul 2014
Angry Finally an answer WITHOUT ROOT

It is possible to change the APN type without SQLite or root. The guys at my work figured this out. It is kind of a tricky workaround, but this is tested and working on LG Optimus G Pro, G Flex, and G2 with the MMS issues.

1. Go to the APN Settings and reset them to default. After that you should only see the AT&T APN
2. With the SIM card in the phone open Mobile Networks (get to the screen where you can click on Access Point names.)
3. DO NOT POWER OFF THE PHONE FOR THIS PART! On that screen and with the phone still on, slide the SIM out. You should get a prompt asking to reset the phone. DO NOT RESET THE PHONE.
4. After the prompt click on Access Point Names. There should be no APNs here. If the AT&T APN is still here go back to step 1.
5. Now you need to create a new APN whit the SIM is removed. The APN should be as follows:
Name: Straight Talk MMS
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: 66.209.11.33
mmsport: 80
mmsc: http: // mms-tf. net - This is spaced for Junior User restrictions. Should be no spaces.
authtype:none
type: mms
THE APN TYPE SHOULD ONLY BE FOR MMS. DO NOT PUT ANYTHING ELSE IN THE "TYPE" FIELD
6. Now with everything typed in DOUBLE CHECK EVERYTHING. If it is correct you can save this APN. Once it is saved there will still be no APNs on the APN page.
7. Pull the battery and put the SIM back in the phone.
8. Go back to the APN settings and DO NOT open the APN you just created or it will reset the entire process!!!!! If you did everything right the Straight Talk MMS APN you just made should not have the selection bubble. If you have a selection bubble on the Straight Talk MMS, go back to Step 1.
9. Make another new APN as Follows:
Name: Straight Talk
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: (blank)
mmsport: (blank)
mmsc: (blank)
Mcc: 310
Mnc : 410
type: default
10. Save this APN and select it. You should get LTE shortly after that.

That's it! If you want MMS without root this is the only other workaround I know of! This was tested on multiple Optimus G Pro, G Flex, and G2 and is working! Hope it Helps.
The Following 3 Users Say Thank You to brodood For This Useful Post: [ Click to Expand ]
 
erik_delcast
Old
#14  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Aug 2013
Location: lake city

 
DONATE TO ME
Quote:
Originally Posted by Firebourne View Post
I have an at&t e980 and im on straight talk updated to 4.4.2 kitkat. When i went to put my APN settings back in the APN Type was grayed out and i couldnt send MMS. I found the solution on the Androud Forum site but cant find the link it was under the g2 forum. Basically you have to be rooted and install SQLite Editor and go to data/data/com.android.providers.telephony/databases then click on telephony.db and then carriers. Delete all of the APNs but the one listed as LGE DEFAULT and then the Straight Talk one change the apn type line from "default" to "default,mms,supl" and then make everything else match what the other says as far as the values that you didnt input yourself then save and reboot and it will be changed and editable from then on. I dont know if anyone else will need this and my instuctions may not be clear, but i figured an answer is better then no answer. any questions just ask ill do what i can to help
i did it all and got it to work but when i was trying to exit out something went wrong and i must have changed something else because now i get no service at all for anything besides wifi. please help!
 
ackliph
Old
#15  
Senior Member
Thanks Meter 104
Posts: 379
Join Date: Jan 2010
Location: Little Rock
Quote:
Originally Posted by erik_delcast View Post
i did it all and got it to work but when i was trying to exit out something went wrong and i must have changed something else because now i get no service at all for anything besides wifi. please help!
It is important that once you have entered all the info for the new APN, you must press the menu button and select save. Then one you are back to the previous screen, select the radio button next to your new APN to select it.
HTC Inspire 4G *sold*
Samsung Galaxy Exhibit - SlimBean *wow*
HTC ONE XL *sold*
Samsung Galaxy Nexus *sold*
LG Nexus 4 *sent back*
Samsung Galaxy S II SGH-T989 Hercules
LG Optimus G Pro LG-E980
AT&T GoPhone 2GB Unlimited
 
TVCCS
Old
#16  
Junior Member
Thanks Meter 3
Posts: 14
Join Date: Jan 2011
Angry Yes, it worked on my LG Optimus G Pro

I agree that's one helluva clever workaround...tried it and got the custom MMS APN setting in as described, then got the selectable ST APN as described into the phone as well. The first couple of times I tried to send an MMS it was still stuck in the proverbial Sending loop going nowhere - but then it decided on try number three to go through...weiiiiiiiiiird indeed.

I may still end up rooting and changing the APN database...this is a deliberate attempt by AT&T to block carriers like Straight Talk from having MMS functionality...a very subversive workaround to the prospect of Congress passing new unlocking legislation. I'd love to have been a fly on the wall when the managers, engineers and the lawyers discussed this little scheme. I have some lawyers of my own I'm gonna run this one by - yes I'm talking to you AT&T and whomever else was in on this little collusionary party - I hope LG didn't sign off on this little scheme...would be interesting to know if the KitKat updates anywhere else in the world disabled APN's in the same way. The Hill isn't going to like this much when they find out, nor The White House.

Thanks for the non-root suggestion, strange as it is. For those of you trying this one, it took several reboots before the MMS messages started working correctly...I was about to give up and re-root, and bingo, it worked. What a kluge just to try and block functionality...naughty naughty.



Quote:
Originally Posted by brodood View Post
It is possible to change the APN type without SQLite or root. The guys at my work figured this out. It is kind of a tricky workaround, but this is tested and working on LG Optimus G Pro, G Flex, and G2 with the MMS issues.

1. Go to the APN Settings and reset them to default. After that you should only see the AT&T APN
2. With the SIM card in the phone open Mobile Networks (get to the screen where you can click on Access Point names.)
3. DO NOT POWER OFF THE PHONE FOR THIS PART! On that screen and with the phone still on, slide the SIM out. You should get a prompt asking to reset the phone. DO NOT RESET THE PHONE.
4. After the prompt click on Access Point Names. There should be no APNs here. If the AT&T APN is still here go back to step 1.
5. Now you need to create a new APN whit the SIM is removed. The APN should be as follows:
Name: Straight Talk MMS
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: 66.209.11.33
mmsport: 80
mmsc: http: // mms-tf. net - This is spaced for Junior User restrictions. Should be no spaces.
authtype:none
type: mms
THE APN TYPE SHOULD ONLY BE FOR MMS. DO NOT PUT ANYTHING ELSE IN THE "TYPE" FIELD
6. Now with everything typed in DOUBLE CHECK EVERYTHING. If it is correct you can save this APN. Once it is saved there will still be no APNs on the APN page.
7. Pull the battery and put the SIM back in the phone.
8. Go back to the APN settings and DO NOT open the APN you just created or it will reset the entire process!!!!! If you did everything right the Straight Talk MMS APN you just made should not have the selection bubble. If you have a selection bubble on the Straight Talk MMS, go back to Step 1.
9. Make another new APN as Follows:
Name: Straight Talk
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: (blank)
mmsport: (blank)
mmsc: (blank)
Mcc: 310
Mnc : 410
type: default
10. Save this APN and select it. You should get LTE shortly after that.

That's it! If you want MMS without root this is the only other workaround I know of! This was tested on multiple Optimus G Pro, G Flex, and G2 and is working! Hope it Helps.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes