Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,981 Members 39,107 Now Online
XDA Developers Android and Mobile Development Forum

Call answer issue

Tip us?
 
haidar000
Old
#11  
Junior Member
Thanks Meter 1
Posts: 1
Join Date: Apr 2012
Default Call answer issue

Dear l3opard,

i was reading this discusion and i thought my case is similar to yours

let me tell you my story perhaps it will answer your questions.

i recently bought the Xperia Z2 and i faced 2 main issues:

A- During calls, the other party cannot hear me well (microphone problem) ( even the .314 update did not solve it )
B- When answering calls the other party hears a vibration ( your case)

talking about problem B let me tell you when it happens and when it doesn t. if you answered while the phone is vibrating the vibration will continue and the caller will hear it, but if you answer between two vibrations the caller wont hear anything.

I assure you it is not your fault, it is sony's fault, i had couples of years ago Xperia P it had the SAME PROBLEM and when i bought the Z2 i assumed that SONY would have solved it. But i was surprised that the problem is always the same

in my opinion these small issues are reasons for loosing potential customers ( i am one of them) because i directly returned the phone ( i guess ill be getting the M8)

Hope i helped u
The Following User Says Thank You to haidar000 For This Useful Post: [ Click to Expand ]
 
ZPaul2Fresh8
Old
#12  
ZPaul2Fresh8's Avatar
Senior Member
Thanks Meter 153
Posts: 387
Join Date: Mar 2012
Quote:
Originally Posted by l3opard View Post
Sorry for the empty post... So, first, I have the .402 firmware, locked bootloader, rooted with some xposed modules. Everything work fine, exept one annoying calling issue... When I'm answering a call, I feel a strong, short vibration and the other party is complaining about a strange loud noise right after I answered. Anybody have this issue? I'm going nuts searching all over for similar problem, but I can't find anything...

Sent from my D6503 using XDA Premium 4 mobile app
Funny that I came across this because earlier my wife called me and said it sounded real windy when I answered... But I was in complete silence... Very interested in this outcome.
Current Devices:
Sony Xperia Z2 D6503 LTE (Arriving 6-24-14)
Samsung Galaxy Note 3 N900T Jet Black (AT&T)
Samsung Galaxy S4 I337 Ceramic White

Retired Devices:
Samsung Galaxy S4 I337 Black Mist (Sold on Swappa 2/26/14)
Samsung Galaxy Note SGH-i717 Ceramic White (Sold on Swappa 4/18/13)
Apple iPhone 4 (Sold on Swappa)
 
bdithug
Old
#13  
bdithug's Avatar
Senior Member
Thanks Meter 187
Posts: 757
Join Date: Mar 2012
Location: Burlington
I'm pretty sure this is caused by vibration while ringing. Then when you answer the phone at a particular time, it vibrates from the ring tone just as the call connects. I've heard it too, but only on incoming calls. Outgoing calls I've never heard it nor has anyone ever commented about it.

Sent from my D6503 using XDA Free mobile app
 
l3opard
Old
#14  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Feb 2012
Thank you all for the feedback
Apparently the only solution to avoid this issue is to try to answer the phone between two vibrations... Well, kind of funny. By the way, I done fresh .314 firmware flash but nothings change. Fortunately, at me, the microphone is working fine.

Thank you again for the help and please let me know if any solution will be available for this.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes