Android 5.0.2 and New Factory Images For Nexus 7 (Wi-Fi) Available

Android 5.0 is has been publicly available since early November, and the … more

Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Htc One m7 -wifi stuck "turning on"

OP bag3ra

29th April 2014, 05:22 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2014
Hei guys !

I have a htc one with unlocked bootloader and s-off.


Yesterday my phone started to experience some trouble with the wi-fi connections. When i turn on the wi-fi it remains stuck on "turning on" and i can't turn it off anymore. I tried to more options by clicking on the 3 dots in the right corner but no succes..all options but "Advanced" are greyed out.

I already tried to flash a custom rom (Viper rom) and reflashed stock ruu and the problem persisted.


Any of you experienced similar problems?
29th April 2014, 09:58 AM   |  #2  
Senior Member
Thanks Meter: 491
 
1,057 posts
Join Date:Joined: Jan 2012
I had that problem on another type of phone. It was hardware. You've already factory reset and changed the OS. The only other thing I can think of is to pull the battery (and you probably don't want to do this yourself). Good luck. I would send the phone in for warranty repair, if you can.
29th April 2014, 11:01 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2014
Unfortunately i can't rma the handset for repair because it was bought second hand.

I thought maybe it was another way to resolve this issue.. I found it odd because while i was using the device over the wifi connection it just disconnected and would not connect back on. No other glitch , fireworks or nothing..
11th June 2014, 12:57 PM   |  #4  
Senior Member
Thanks Meter: 112
 
673 posts
Join Date:Joined: Nov 2009
Same problem here,

it suddenly stopt working.
it trying to connect and stays there.
reboot is fixing it for a few minutes and problem is there
again.

i have the problem on multiple networks.

new firmware flashing didnt help,
new OS didnt help,
new Recovery didnt help...
12th June 2014, 12:45 PM   |  #5  
Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Aug 2013
More
I have the same exact problem.

It did turn on randomly one night after restoring a back up. Stayed on all night, gone in the morning.
The Following User Says Thank You to GeneFitz23 For This Useful Post: [ View ]
12th June 2014, 08:49 PM   |  #6  
Senior Member
Thanks Meter: 112
 
673 posts
Join Date:Joined: Nov 2009
Quote:
Originally Posted by GeneFitz23

I have the same exact problem.

It did turn on randomly one night after restoring a back up. Stayed on all night, gone in the morning.

Are u on custom Rom?

Did u fix the problem or does it still persists?

Sent from my HTC One using XDA Premium 4 mobile app
12th June 2014, 08:51 PM   |  #7  
Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Aug 2013
More
Quote:
Originally Posted by Gerton

Are u on custom Rom?

Did u fix the problem or does it still persists?

Sent from my HTC One using XDA Premium 4 mobile app

Im on ViperOne and the problem is still there.
12th June 2014, 09:13 PM   |  #8  
Senior Member
Thanks Meter: 112
 
673 posts
Join Date:Joined: Nov 2009
I Wil go back to stock soon and try if that helps. Don't think it will cause I think it's hardware related. But have to go stock when I want it to sent in for warranty.

Sent from my HTC One using XDA Premium 4 mobile app
14th June 2014, 05:40 PM   |  #9  
Senior Member
Thanks Meter: 112
 
673 posts
Join Date:Joined: Nov 2009
I bought a brand new second One M7 and flashed a backup from the "old" one. WiFi is working.

Running ARHD with experimental 14.11 I did a factory reset within TWRP 2.6.3.3 recovery on the "old" One and until now WiFi is already working for a day.

I thought it was hardware related but why is the "old" One working again....
And why is the new One has working WiFi with the exact same copy of OS....

Strange

Edit,
The "old" One WiFi stopt working.
Suddenly it was gone.
Going back to stock with that one and sent it in for repair.



Sent from my HTC One using XDA Premium 4 mobile app
Last edited by Gerton; 14th June 2014 at 07:46 PM.
15th August 2014, 09:33 PM   |  #10  
Senior Member
Thanks Meter: 112
 
673 posts
Join Date:Joined: Nov 2009
After a lot of sending and receiving, the phone stayed at HTC and they sent me an m8 for the inconvenience...

Ok. So I can't tell u guys what the problem was.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes