Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,232 Members 38,300 Now Online
XDA Developers Android and Mobile Development Forum

Droid Bionic on Straight Talk?

Tip us?
 
Cap'n Jazz
Old
#1  
Member - OP
Thanks Meter 9
Posts: 59
Join Date: Jan 2013
Default Droid Bionic on Straight Talk?

I'm trying to get Straight Talk working with this Bionic. Could someone help?
 
renegadeone8
Old
#2  
Member
Thanks Meter 9
Posts: 50
Join Date: Nov 2008
Default Not sure but...

I used to be a Verizon Wireless agent (Straight Talk piggy backs on their network.) If I remember right straight talk/net10/verizon's own prepaid phones are limited to 3G devices only. Policies may have changed, or I could potentially be wrong but I am going to guess that you won't be able to get it working on their network because they won't be able to issue you a compatible SIM
 
shadolis
Old
(Last edited by shadolis; 16th August 2014 at 08:23 AM.)
#3  
shadolis's Avatar
Member
Thanks Meter 8
Posts: 39
Join Date: May 2013
You have to edit the build.prop and create a local.prop (it probably doesn't exist). I recently put SlimKat 4.4.4 on my friend's Bionic, and got it working well with Straight Talk (Voice, MMS, Data, etc). Just edit build.prop with:
  • persist.radio.ap.phonetype=1
  • ro.mot.phonemode.vzw4gphone=0
  • ro.mot.phonemode.vzwglobalphone=1
  • ro.telephony.default_network=3
  • ro.telephony.gsm-routes-us-smsc=0
  • telephony.lteOnCdmaDevice=0

Create a local.prop file and add:

ro.telephony.ril.v3=signalstrength

Move this into /data/

Next, go into system/etc/ and get your apns-conf.xml file and delete all the entries you don't need, keeping only the one relevant to Straight Talk. In my friend's case:

Code:
<apns version="7">
  <apn carrier="StraightTalk ATT" mcc="310" mnc="410" apn="tfdata" port="80" mmsc="http://mms-tf.net" mmsproxy="mms3.tracfone.com" mmsport="80" type="default,supl,mms,hipri" />
</apns>
For the novices, to do this last part, you'll need a file manager like ES that can utilize root permissions after enabling in settings.

After this, any 4.3 or 4.4 ROM should let you edit APN settings, etc. You may need to set your radio to GSM (auto PRL) by going into your dialer and hitting *#*#4636#*#* and going into Phone Information then down to network type or whatever. I don't have a Motorola phone in front of me :P If that doesn't work, I've noticed GSM/WCDMA (auto PRL) works for some.

Good luck

Edit: I forgot one crucial thing you must do. You have to use RadioComm to enable GSM/UMTS bands. You can find it with Google. The version I used is 11.12.2. You'll either have a green or purple light on the right side, signifying that your phone is connected. It should show up in the status bar too. Steps:
  1. Ensure you have correct Motorola drivers and that device shows up in device manager (You may need to use Google USB driver, as this has worked with some Motorola phones for me)
  2. Ensure that USB is in PC Tools mode
  3. In Radiocomm go to MA->COMMON->MDM 6x00
  4. Go to the FTM Common1 tab, and wait for purple or green light on side
  5. Toward the top of NVAccess you'll see a select box. Scroll to NV item 1877 NV_RF_BC_CONFIG_I
  6. Click on read value
  7. Once read, replace the first 8 bytes with: 8703E80400000200 (back up original as a .txt file or something)
  8. Write the new value to the device and reboot

There's also a flashable zip that does this, but I've not tested it. Use at your own risk:
http://forum.xda-developers.com/atta...4&d=1336485537

All of the information I presented is from others, but I can't remember all the threads I got this from. I take no responsibility for any bricked phones or the like.
Verizon HTC One M8
Bootloader: Unlocked
Recovery: TWRP
ROM: GPE for M8VZW
Kernel: EliteLunar
Case: Spigen Slim Armor (Satin Silver)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes