Lockdown Pro 2 Brings Material Design and Media Support

Back in March of this year, we took a look at a rather innovated security application … more

Mural Watchface Brings 500px to Android Wear

On a traditional watch, you can’t really do too much to change its appearance once … more

Android 5.0 Favorite Features, Release November 3rd? – XDA TV

Google Confirms Android 5.0 Lollipop for November 3rd! That and much more … more

Prepare Your Build Machines: Ubuntu 14.10 Utopic Unicorn Now Official

Today is an important day for any and all Linux enthusiasts. One of the … more
Post Reply

[Q] Lg G2 D803 flashing problems

OP oakster15

22nd January 2014, 03:34 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Jan 2014
Hello everyone,

I'm trying to flash a rom for the first time and I've been fighting with TWRP for the last week or so. Here's what I've done. LG G2 D803 Rogers Canada

1. Rooted Device.
2. Installed TWRP Manager and Installed TWRP Recovery Image (2.6.3.2) and I can restore with no issues.
3. Downloaded latest PA 4.4 roms for my phone version (LG G2 D803), including the most recent GAPPS (mini modular). And transferred to phone.
4. Reboot into recovery.
5. Wipe Cache, Dalvik, Data, ... etc)
6. Select install ROM.
7. Get error right away (E:Error executing updater binary in zip)
8. Flashing rom FAILED.

What can I do to fix this?

My device is not supported on CWMR, so I'm not sure if that would work. Also, I've tried downloading older roms, so I'm pretty sure it's not a bad download issue.


Thanks for any help!
Last edited by oakster15; 22nd January 2014 at 03:50 PM. Reason: added info
23rd January 2014, 02:50 AM   |  #2  
gusly's Avatar
Member
Flag Pincourt
Thanks Meter: 15
 
96 posts
Join Date:Joined: Jan 2014
More
TWRP 2.6.3.2 isn't the latest release, so that might be your problem. Go here: http://forum.xda-developers.com/show....php?t=2469995 flash the new zip from your current TWRP, and you should be able to flash KitKat ROMs now. Or, if you prefer CWM, there's PhilZ Touch CWM here http://forum.xda-developers.com/show....php?t=2554053
The Following 2 Users Say Thank You to gusly For This Useful Post: [ View ]
24th January 2014, 02:02 PM   |  #3  
OP Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by gusly

TWRP 2.6.3.2 isn't the latest release, so that might be your problem. Go here: http://forum.xda-developers.com/show....php?t=2469995 flash the new zip from your current TWRP, and you should be able to flash KitKat ROMs now. Or, if you prefer CWM, there's PhilZ Touch CWM here http://forum.xda-developers.com/show....php?t=2554053

Gave you a thanks, it worked perfectly! Wohoo!
24th January 2014, 02:05 PM   |  #4  
gusly's Avatar
Member
Flag Pincourt
Thanks Meter: 15
 
96 posts
Join Date:Joined: Jan 2014
More
Quote:
Originally Posted by oakster15

Gave you a thanks, it worked perfectly! Wohoo!

No problem man. Had the same problem myself, so I knew how to fix it

Sent from my G2 using Tapatalk
9th March 2014, 05:47 PM   |  #5  
Brava27's Avatar
Senior Member
Flag Toronto
Thanks Meter: 128
 
734 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by gusly

No problem man. Had the same problem myself, so I knew how to fix it

Sent from my G2 using Tapatalk

Quote:
Originally Posted by oakster15

Gave you a thanks, it worked perfectly! Wohoo!

Hey guys. I'm having the hardest time flashing anything right now. I'm on the 2.6.3.2 and I get the binary updater problem so then I tried flashing other twrp then I get the fast boot error then I tried philz touch then I get boot certification verify error.
All I want to do is flash a 4.4.2 rom.
Canadian rom D803 here.

Thanks
17th March 2014, 02:49 PM   |  #6  
Junior Member
Thanks Meter: 2
 
13 posts
Join Date:Joined: Feb 2014
wootever's TWRP 2.6.3.4 oakster15 had posted above worked on my D803, however there are a couple of 2.6.3.4 download versions that didn't work when I flashed it while running TWRP 2.6.3.2. I'm not familar with loki but I'm guessing the one that worked had been "loki-fied".

---------- Post added at 09:49 AM ---------- Previous post was at 09:40 AM ----------

Quote:
Originally Posted by Brava27

Hey guys. I'm having the hardest time flashing anything right now. I'm on the 2.6.3.2 and I get the binary updater problem so then I tried flashing other twrp then I get the fast boot error then I tried philz touch then I get boot certification verify error.
All I want to do is flash a 4.4.2 rom.
Canadian rom D803 here.

Thanks

If you haven't' found this already, here is a great list for the D803 with several options that may work for you. http://forum.xda-developers.com/show....php?t=2611749

Hope this helps.
The Following User Says Thank You to agent3m For This Useful Post: [ View ]
18th August 2014, 03:14 PM   |  #7  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2014
Smile
Hey Guys,

As someone with a D803 variant of the G2, I had been pulling my hair out the last few days on this. Anyway, thanks to the Mahdi team, I was able to get TWRP 2.7.1.0 via this link:

https://www.mediafire.com/folder/hid9ny9jl91yx/TWRPS

The 4.4.4 rom I flashed was made by the Mahdi team and can be found here:

http://forum.xda-developers.com/show....php?t=2590700

Cheers!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in G2 Q&A, Help & Troubleshooting by ThreadRank