Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Stop Your Screen From Turning Off with KeepItOn

We all know the feeling of reading a news article orrather longdocument, when our screen … more

The XDA LG QPair Developer Challenge Voting Has Begun!

It seems like it was just yesterday that weannounced that we had paired up with LGto … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Black screen, no boot, random vibration

OP hohlbub

24th June 2014, 10:04 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2011
Ok, so my Galaxy S4 GT-I9505 won't boot up. Pretty common situation by what i have read on this and other forums so far but mine seems to behave a little different.

Since I've had the device it sometimes just randomly rebooted without any obvious reason but since it only occured once in a few month i did not investigate this any further.

Yesterday it suddenly got really slow when using some normal apps, nothing special (not like a little slow when the cpu is heavily used, but really really slow) it took about one minute for it to close any app and going back to the home screen etc, everything while still recording my actions so when it became unstuck just doing everything i tried in the meantime really fast, then again blocking. So far so good after a reboot that took 5 minutes (even the boot animation appeared extremely slow and fragmented) everything seemed normal.

Until it just freezed while i tried to make a phone call, during which it never dialed but just displaying the dialing animation, although i could switch back to the home screen and back to the "call" i could not end it or cancel it or anything, the phone behaved normal but the call stayed.
Then i tried rebooting it ...

... now it seems to be a brick, nothing will work it won't start up in any mode neither recovery, nor normal, nor download mode nothing.
After a few hours in the charger (i just left it there) suddenly the (untill then black) screen displayed the charging animation, when i tried to boot it then it just went back to a black screen.
After another hour it just started vibrating out of nowhere (and just stopped when i removed the battery).

Thats it, do you have any ideas on that ?

Some other info on the phone :
- rooted stock rom Android 4.4.2 from Vodafone
- tried adb, odin, but no connection to any pc possible at the moment
24th June 2014, 10:42 AM   |  #2  
Senior Member
Flag Netherlands
Thanks Meter: 313
 
1,971 posts
Join Date:Joined: May 2009
You have a faulty battery or some other damaged hardware.

Try to see if it boots with an other battery, if that fails then you have hardware damage.
24th June 2014, 11:01 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2011
Thanks for your quick reply! I'm going to try a different battery now ...
19th August 2014, 10:26 PM   |  #4  
jaggrey's Avatar
Senior Member
Thanks Meter: 15
 
173 posts
Join Date:Joined: Jun 2008
What ever happened with this? My wife's S4 started doing the exact same thing.

Sent from my HTC One_M8 using XDA Free mobile app
19th August 2014, 11:11 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2011
Oh, well I'm sorry I forgot to update the status here.
So I followed the instructions here and bought a new battery, unfortunately the problems didn't disappear.
As the S4 wasn't usable I sent it in to the repair service, which replaced the faulty electronic parts (the Mainboard as I guess). The defect was covered by the warranty in my case.
I don't know how I could help you here, in case the repair might not be covered by your warranty I would try replacing the battery.
Good luck
19th August 2014, 11:24 PM   |  #6  
jaggrey's Avatar
Senior Member
Thanks Meter: 15
 
173 posts
Join Date:Joined: Jun 2008
Quote:
Originally Posted by hohlbub

Oh, well I'm sorry I forgot to update the status here.
So I followed the instructions here and bought a new battery, unfortunately the problems didn't disappear.
As the S4 wasn't usable I sent it in to the repair service, which replaced the faulty electronic parts (the Mainboard as I guess). The defect was covered by the warranty in my case.
I don't know how I could help you here, in case the repair might not be covered by your warranty I would try replacing the battery.
Good luck

Thanks. I'll give that a try. I'm on T-Mobile here so I'm gonna go to the store and see what they can do, if anything.

Sent from my HTC One_M8 using XDA Free mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes