Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,569 Members 44,561 Now Online
XDA Developers Android and Mobile Development Forum

Cubot X6, Cheapest 8-Core Smartphone: Less Vibrant, but Agiler

Tip us?
 
sergiobarroso
Old
#141  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Feb 2008
Default Auto-rotation issue

Hi,

The auto-rotation is not working on my phone... I have it marked both in Brightness and in Accessibility, but it just doesn't work... Apps do work changing from portrait mode to landscape, when forced on open app, but I can't make it auto-rotate on browser, contacts, pictures, videos....
I already have the 1.0 rom version (from factory). Tryed an app to check the accelerometer (sensor status) and it changes the coordinates when I turn the phone, and with Android Sensor Box it also works.

What should I do? Flash the ROM? Anyone experienced a similar problem? Having the sensors working, it makes sense that it might be a software problem, right?

Please help
 
sergiobarroso
Old
#142  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Feb 2008
Quote:
Originally Posted by sergiobarroso View Post
Hi,

The auto-rotation is not working on my phone... I have it marked both in Brightness and in Accessibility, but it just doesn't work... Apps do work changing from portrait mode to landscape, when forced on open app, but I can't make it auto-rotate on browser, contacts, pictures, videos....
I already have the 1.0 rom version (from factory). Tryed an app to check the accelerometer (sensor status) and it changes the coordinates when I turn the phone, and with Android Sensor Box it also works.

What should I do? Flash the ROM? Anyone experienced a similar problem? Having the sensors working, it makes sense that it might be a software problem, right?

Please help
Flashed the ROM with the oficial ROM, and the problem remains... Argh.....
 
maschkan
Old
#143  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Feb 2011
Default Chrome sometimes locks the orientation.

Quote:
Originally Posted by sergiobarroso View Post
Flashed the ROM with the oficial ROM, and the problem remains... Argh.....
Happened to me as well. Chrome browser knows to lock the orientation. What helped me was clearing cash from CWM recovery. Pulling the buttery out seems to help as well.
 
rincal
Old
#144  
Junior Member
Thanks Meter 0
Posts: 15
Join Date: Sep 2010
link is dead - was there a problem with this?

Quote:
Originally Posted by shadow78 View Post
 
sergiobarroso
Old
#145  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Feb 2008
Quote:
Originally Posted by maschkan View Post
Happened to me as well. Chrome browser knows to lock the orientation. What helped me was clearing cash from CWM recovery. Pulling the buttery out seems to help as well.
Thank you for the tip, but the problem remains... Starting to think that I should return the phone...
 
bedeegc
Old
#146  
Senior Member
Thanks Meter 66
Posts: 139
Join Date: Feb 2011
Quote:
Originally Posted by sergiobarroso View Post
Thank you for the tip, but the problem remains... Starting to think that I should return the phone...
Phone is OK in my opinion, no problems with autorotation. It will not work (as on many other phones) with contacts, but all other programs no problem. I run the version 0.9 from 08 apr 2014 Official ROM.

Maybe a wrong Flash, could you try it again (see Needrom Cubot X6 official).
1st
CUBOT X6 Dual Sim
StockRom, but for how long..

2st
THL W100 Dual Sim
After replacing a new screen, this one is history

3nd
Samsung SGS I9000
Only as backup
 
sergiobarroso
Old
#147  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Feb 2008
Quote:
Originally Posted by bedeegc View Post
Phone is OK in my opinion, no problems with autorotation. It will not work (as on many other phones) with contacts, but all other programs no problem. I run the version 0.9 from 08 apr 2014 Official ROM.

Maybe a wrong Flash, could you try it again (see Needrom Cubot X6 official).
Thank you for your tip. I tryied flashing with 0.9, same problem. Can you please install in yours the Android Sensor Box app and check if in the Orientation Sensor everything works? In mine, the vertical doesn't move and the horizontal is stucked to the right. In the accelerometer the ball also is not moving in all directions....
 
bedeegc
Old
#148  
Senior Member
Thanks Meter 66
Posts: 139
Join Date: Feb 2011
Quote:
Originally Posted by sergiobarroso View Post
Thank you for your tip. I tryied flashing with 0.9, same problem. Can you please install in yours the Android Sensor Box app and check if in the Orientation Sensor everything works? In mine, the vertical doesn't move and the horizontal is stucked to the right. In the accelerometer the ball also is not moving in all directions....
Everything OK with my X6. Installed Android Sensor Box (Actually a Battery Drain App) maybe a bigger problem, what you have.
When the rest of the phone is OK, maybe you can send it back under guarantee...
1st
CUBOT X6 Dual Sim
StockRom, but for how long..

2st
THL W100 Dual Sim
After replacing a new screen, this one is history

3nd
Samsung SGS I9000
Only as backup
 
ferdyfist
Old
#149  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Dec 2010
Could anyone go through the step of calibration for the touchscreen?
I've just got the phone, so if anyone is interested, I can answer some questions about it!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes