Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,836 Members 41,887 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Immersive Mode: Disable Pie AND navigation bar

Tip us?
 
AndyMez
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 10
Join Date: Apr 2014
Default [Q] Immersive Mode: Disable Pie AND navigation bar

Hi,
I am using SideControl to navigate in immersive mode so I would like to disable PIE as well as the navigation bar showing up when swiping from the bottom.
So swiping up from the bottom touch area should bring me back to the home-screen. However, when enabling PIE, it obviously brings up PIE, when disabling PIE it brings up the navigation bar..
So how can I disable both?!

Thanks a lot!
 
Anu6is
Old
#2  
Anu6is's Avatar
Senior Member
Thanks Meter 2,349
Posts: 1,001
Join Date: Jul 2011

 
DONATE TO ME
You can't.
We wouldn't implement a feature that removes all navigation options
Maybe place pie on the left edge of the device

Sent from my Nexus 4 using Tapatalk
The Following User Says Thank You to Anu6is For This Useful Post: [ Click to Expand ]
 
cpanos
Old
#3  
cpanos's Avatar
Senior Member
Thanks Meter 296
Posts: 339
Join Date: Nov 2012
Location: Athens
Quote:
Originally Posted by AndyMez View Post
Hi,
I am using SideControl to navigate in immersive mode so I would like to disable PIE as well as the navigation bar showing up when swiping from the bottom.
So swiping up from the bottom touch area should bring me back to the home-screen. However, when enabling PIE, it obviously brings up PIE, when disabling PIE it brings up the navigation bar..
So how can I disable both?!

Thanks a lot!
You can try disabling the navbar in build prop by adding qemu.hw.mainkeys = 1
This way you can hide the navbar without the need for immersive mode (and thus pie).

Phone: Nexus 4 (E960)
ROM: android 4.4.4
Kernel: ak
Recovery: TWRP 2.7.1.0
Launcher: Nova launcher Prime

Other devices: Nexus 7 LTE (2013)
Previous devices: Nexus S (i9023)
 
AndyMez
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 10
Join Date: Apr 2014
Quote:
Originally Posted by cpanos View Post
You can try disabling the navbar in build prop by adding qemu.hw.mainkeys = 1
This way you can hide the navbar without the need for immersive mode (and thus pie).
Hi!
Thank you so much!!! This solved my problem!!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes