Post Reply

[DEV][GUIDE] Upgrading your Rom to 4.4.2 Sources

3rd July 2014, 11:48 PM   |  #51  
didhiy's Avatar
Senior Member
Flag Jakarta
Thanks Meter: 1,148
 
905 posts
Join Date:Joined: Mar 2011
More
Quote:
Originally Posted by JackpotClavin

Hey, what were those RIL patches? Just curious

Afaik ril is radio interface layer to handle telephony function, mostly taken from stock rom (rild, ril libs etc) as binaries (blobs) because lack the source code.
4th July 2014, 12:19 AM   |  #52  
Senior Member
Flag Chesapeake, VA
Thanks Meter: 47
 
199 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by didhiy

Afaik ril is radio interface layer to handle telephony function, mostly taken from stock rom (rild, ril libs etc) as binaries (blobs) because lack the source code.

Heh.. He meant the patch hashes on github... But what ril is...
The Following User Says Thank You to Yoinx For This Useful Post: [ View ]
13th July 2014, 05:31 PM   |  #53  
xlxfoxxlx's Avatar
Senior Member
Thanks Meter: 110
 
287 posts
Join Date:Joined: Aug 2010
@dr87 I'm guessing yes but is there more required to update a already built vzw 4.2 sourced ROM to 4.4.2 sources if I flash your s1 patch from mahdi. I flashed a 4.2 sourced AICP that I built then flashed the s1 patch and changed the lines in build.prop from 11a to 24a and so far everything seems fine, just curious.

Also if someone would be willing to give me some pointers on changing the source to make it true 4.4.2 based I would greatly appreciate it
21st August 2014, 10:14 PM   |  #54  
djvoleur's Avatar
Senior Member
Purgatory, AZ
Thanks Meter: 197
 
393 posts
Join Date:Joined: May 2010
Donate to Me
More
Code:
Which would you like? [aosp_arm-eng] 13
build/core/product_config.mk:222: *** Can not locate config makefile for product "mahdi_d801".  Stop.

** Don't have a product spec for: 'mahdi_d801'
** Do you have the right repo manifest?
What am I missing? Everything looks fine to me in device/lge/801
22nd August 2014, 12:18 AM   |  #55  
Recognized Developer / Recognized Contributor
Flag Philadelphia
Thanks Meter: 2,859
 
2,190 posts
Join Date:Joined: Mar 2011
Donate to Me
More
Quote:
Originally Posted by djvoleur

Code:
Which would you like? [aosp_arm-eng] 13
build/core/product_config.mk:222: *** Can not locate config makefile for product "mahdi_d801".  Stop.

** Don't have a product spec for: 'mahdi_d801'
** Do you have the right repo manifest?
What am I missing? Everything looks fine to me in device/lge/801

Not sure how Mahdi is setup but you probably need to add d801 to vendorsetup.sh in vendor/mahdi
22nd August 2014, 12:52 AM   |  #56  
djvoleur's Avatar
Senior Member
Purgatory, AZ
Thanks Meter: 197
 
393 posts
Join Date:Joined: May 2010
Donate to Me
More
I've add_lunch_combo full_d801-userdebug and it does the same thing...

Sent from my LG-D801 using Tapatalk
22nd August 2014, 05:03 AM   |  #57  
Recognized Developer / Recognized Contributor
Flag Philadelphia
Thanks Meter: 2,859
 
2,190 posts
Join Date:Joined: Mar 2011
Donate to Me
More
Quote:
Originally Posted by djvoleur

I've add_lunch_combo full_d801-userdebug and it does the same thing...

Sent from my LG-D801 using Tapatalk

look at how other devices are setup and use that as a reference...

I would expect you should add mahdi_d801 rather than full..

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in G2 Original Android Development by ThreadRank