Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,216 Members 53,500 Now Online
XDA Developers Android and Mobile Development Forum

Can't connect to Sony PC companion

Tip us?
 
Gnopps
Old
#1  
Member - OP
Thanks Meter 8
Posts: 96
Join Date: Aug 2010
Default Can't connect to Sony PC companion

My computer connects fine to my Z2 tablet via usb, both when in mtp-mode as well as in mass storage mode. I can browse the content the tablet via computer.

However Sony's own software, the pc companion can't find the tablet at all. There is no error message, just a complete blank when it is searching for the tablet.

I'm running Windows 7 and have tried uninstalling, reinstalling both the software and drivers but to no luck.

Anyone else with this problem or suggestion how to solve it?
 
Skogstoken
Old
#2  
Member
Thanks Meter 0
Posts: 56
Join Date: Apr 2014
Quote:
Originally Posted by Gnopps View Post
My computer connects fine to my Z2 tablet via usb, both when in mtp-mode as well as in mass storage mode. I can browse the content the tablet via computer.

However Sony's own software, the pc companion can't find the tablet at all. There is no error message, just a complete blank when it is searching for the tablet.

I'm running Windows 7 and have tried uninstalling, reinstalling both the software and drivers but to no luck.

Anyone else with this problem or suggestion how to solve it?

I couldnt get it to work either, tried everything, even wiping the tablet.

However what worked for me was connecting the Tablet through wifi. With that I could see the tablet in PC companion, however I still cant get USB connection to work. So try Wifi?
 
woggly4
Old
#3  
Junior Member
Thanks Meter 2
Posts: 24
Join Date: Dec 2008
I had the same problem. Could fix it this way:
  1. plug in usb-cable only to your computer
  2. start connection-progress within the software
  3. plug in the other end of the usb-cable when prompted to connect your computer and tablet
  4. voilą!
I never imagined, the connection-order of the usb-cable would make any difference, but it works now (whyever).

If it doesn't work for you, download, install and run the update service (http://www.sonymobile.com/global-en/...pdate-service/), follow the instructions until your computer installs new drivers (don't wipe your device and don't apply any update, just abort the progress at this point) and try again the steps above.
 
mtilson
Old
#4  
Junior Member
Thanks Meter 5
Posts: 22
Join Date: Oct 2008
Quote:
Originally Posted by woggly4 View Post
I had the same problem. Could fix it this way:
  1. plug in usb-cable only to your computer
  2. start connection-progress within the software
  3. plug in the other end of the usb-cable when prompted to connect your computer and tablet
  4. voilą!
I never imagined, the connection-order of the usb-cable would make any difference, but it works now (whyever).

If it doesn't work for you, download, install and run the update service (http://www.sonymobile.com/global-en/...pdate-service/), follow the instructions until your computer installs new drivers (don't wipe your device and don't apply any update, just abort the progress at this point) and try again the steps above.
Tried the above and still no luck.... Does anyone have any other suggestions? The tablet is recognized as a MTP device but will not connect to PC Companion. Ironically, when I first downloaded PC Companion, it did briefly connect to the device but it looked like additional windows drivers may have installed (?). I abruptly lost connection and have not been able to get it back. Any help would be greatly appreciated. Thanks
 
zabih107
Old
#5  
Senior Member
Thanks Meter 13
Posts: 133
Join Date: Aug 2012
I had same issue as u. I fixed it like this: I switched to a laptop that had windows 7 running on it instead of windows 8. Uninstalled pic companion and redownloaded from Sony site. And installed. I reset the tablet. After reset done. I ran the pc companion then I connected my tab to laptop USB. And now after 15 sec my tab was recognized and prompted for the. 402 update. That is how I fixed it.

Sent from my SGP512 using Tapatalk
 
Finire
Old
#6  
Member
Thanks Meter 12
Posts: 81
Join Date: Oct 2010
Location: New York
Default SGP561

So I picked up my Verizon LTE Xperia Z2 the other day SGP561, and am having the same issue with not being able to connect the PC Companion. Every time I try to "pair" it with my laptop (running Win 8.1) the PC Companion app tells me the pairing has failed, try again.

I've uninstalled the device from the computer, uninstalled PC Companion, factory reset the tablet, re installed the PC companion and tried again. Every time, it gives me the same error, and just will not pair.
I'm sorry, I forgot that my intelligence is no match for your ignorance.
 
KapaiKiwi
Old
#7  
Junior Member
Thanks Meter 2
Posts: 7
Join Date: Oct 2011
Location: Wellington
Default Instructions from Sony

I just had this issue, I assume you solved it but someone else might end up here looking like I did.

These were sent from John @ Sony support for the Z2 (Works for other models too though).


Running the software repair

Before you start you have to download the PC Companion software from http://www.sonymobile.com/gb/tools/pc-companion/ and install it on your PC.

Once installed on your PC, double-click the PC Companion icon on your desktop to start the update.

Please ensure your phone is powered off and not connected to the PC when you begin this process. You are not required to connect the phone until after step 10.

1. Install and open PC Companion then select Support Zone.

2. Phone Software Update.

3. Start.

4. Repair Phone

5. Continue

6. Accept data removal

7. Next

8. Wait for prepare

9. Select Phone

10. Follow the connection steps



Just did this myself and I am back up and running (Pitty it happened in the first place though)
The Following 2 Users Say Thank You to KapaiKiwi For This Useful Post: [ Click to Expand ]
 
Gnopps
Old
#8  
Member - OP
Thanks Meter 8
Posts: 96
Join Date: Aug 2010
Having reinstalled Windows it now worked for me..
 
canazei
Old
#9  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Aug 2014
Hi KapaiKiwi,
Thanks a lot for your instructions. After to navigate through the web whithout success (and reading very strange solutions) I have followed your procedure and finally I have fixed my Xperia LT15i.
I had deleted services and applications in order to optimize my phone until I reached a point where my USB connection failed. I had no way to reflash it and i felt lost.
This morning I had the plan to get a new phone. Thanks to you I have saved a lot of money!!!

From Barcelona, Catalonia

CATALONIA IS NOT SPAIN

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


MediaTek Continues Steps Towards Being Developer-Friendly

Not too long ago MediaTek was very closed off towards the mobile developer … more

Sony PS4 Remote Play Ported to All Android Devices

Im pretty sure that every informed gamer out there perked their ears up when Sony came out … more

Change Your Samsung Galaxy S2’s Dialer Background in Real Time

As with anything, if youve looked at something long enough, things can … more