Post Reply

[Q] I9505G OTA Upgrade Fails

12th June 2014, 10:45 PM   |  #1  
OP Member
Thanks Meter: 4
 
44 posts
Join Date:Joined: Mar 2011
I rooted my I9505G running 4.4.2 bit did not replace the boot loader or the ROM. I just installed Supet-SU.

I've had two 4.4.3 OTA downloads but they fail an assert for build.prop. I've checked \system\build.prop and it if unaltered and contains the string the assert is linking for.

Do I need to unroot before upgrading? I just assumed that I would have to reroot after upgrading. I didn't expect a fail as I haven't altered the boot loader.
12th June 2014, 11:08 PM   |  #2  
Yes you'll need to flash original FireWire with Odin but before proceeding with the flash run triangle away it should be ok then

Sent from my GT-I9505 using Tapatalk
13th June 2014, 04:28 PM   |  #3  
OP Member
Thanks Meter: 4
 
44 posts
Join Date:Joined: Mar 2011
FireWire? What's that? I don't think I flashed anything like that.
13th June 2014, 04:51 PM   |  #4  
Joku1981's Avatar
Senior Member
Thanks Meter: 556
 
1,807 posts
Join Date:Joined: Jun 2012
Donate to Me
More
Quote:
Originally Posted by ruidh

FireWire? What's that? I don't think I flashed anything like that.

I think he means "Firmware"

Quote:
Originally Posted by ruidh

I rooted my I9505G running 4.4.2 bit did not replace the boot loader or the ROM. I just installed Supet-SU.

I've had two 4.4.3 OTA downloads but they fail an assert for build.prop. I've checked \system\build.prop and it if unaltered and contains the string the assert is linking for.

Do I need to unroot before upgrading? I just assumed that I would have to reroot after upgrading. I didn't expect a fail as I haven't altered the boot loader.

*SOLUTION: Take a look this guide for flash android 4.4.3 in your device: HERE
Last edited by Joku1981; 13th June 2014 at 06:45 PM.
14th June 2014, 01:12 PM   |  #5  
OP Member
Thanks Meter: 4
 
44 posts
Join Date:Joined: Mar 2011
Thanks. I'll give that a try.
15th June 2014, 03:46 AM   |  #6  
OP Member
Thanks Meter: 4
 
44 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by Joku1981

I think he means "Firmware"

I'm not sure about Odin here. I never altered the stock recovery.

Quote:

*SOLUTION: Take a look this guide for flash android 4.4.3 in your device: HERE

That page has some problems. Power+VolUp is needed to boot into recovery, not Power+VolDown. I can get into recovery and select install from external memory. I copied the update onto my sdcard but it still fails with the same assert fail

Verifying update package...
assert failed: get.prop("ro.product.device")== "jgedlte" || [...]

checking \system\build.prop I see the line
ro.product.device=jgedlte
as clear as day.

Build KOT49H.S001.131204
Android version: 4.4.2
Baseband version: I9505GUEUCML4
15th June 2014, 08:20 AM   |  #7  
Joku1981's Avatar
Senior Member
Thanks Meter: 556
 
1,807 posts
Join Date:Joined: Jun 2012
Donate to Me
More
Quote:
Originally Posted by ruidh

I'm not sure about Odin here. I never altered the stock recovery.



That page has some problems. Power+VolUp is needed to boot into recovery, not Power+VolDown. I can get into recovery and select install from external memory. I copied the update onto my sdcard but it still fails with the same assert fail

Verifying update package...
assert failed: get.prop("ro.product.device")== "jgedlte" || [...]

checking \system\build.prop I see the line
ro.product.device=jgedlte
as clear as day.

Build KOT49H.S001.131204
Android version: 4.4.2
Baseband version: I9505GUEUCML4

It's not my problem if you don't know read.
Attached Thumbnails
Click image for larger version

Name:	Sin título-2.jpg
Views:	36
Size:	60.5 KB
ID:	2799178  
15th June 2014, 01:19 PM   |  #8  
OP Member
Thanks Meter: 4
 
44 posts
Join Date:Joined: Mar 2011
I followed Method 2. I see what you're saying now.
24th June 2014, 03:06 AM   |  #9  
OP Member
Thanks Meter: 4
 
44 posts
Join Date:Joined: Mar 2011
None of these upgrade methods worked. I still had assert failures. I removed SuperSU after restoring all changes I made to /etc.

Somehow this morning the phone failed to connect to data services. Several apps failed when they tried to access the network.

I eventually reflashed a 4.4.3 rooted image from here http://forum.xda-developers.com/show....php?t=2772043 and restored my Titanium Backup.
22nd August 2014, 06:15 PM   |  #10  
OP Member
Thanks Meter: 4
 
44 posts
Join Date:Joined: Mar 2011
OTA upgrade to 4.4.4 succeeded after turning of SuperSU and reverting my change to \etc\permissions

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S 4 Q&A, Help & Troubleshooting by ThreadRank