Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,840 Members 41,166 Now Online
XDA Developers Android and Mobile Development Forum

[GUIDE] Backup/Restore/Repair Your EFS Partition [LS970]

Tip us?
 
baublitz
Old
#111  
Member
Thanks Meter 5
Posts: 86
Join Date: Jun 2012
OP do you answer pm?

This is my last ditch effort. Small back story: I somehow wiped EVERYTHING on my G2. EFS partition, ESN, data, SIM info., everything with dialer codes. All of my network information reads "unknown". I tried many methods from here on the forums to get this data back and it turns out I have lost my EFS partition- DNA for the network? I sent it to LG to get it fixed, having done a hard reset and leaving no trace of root. They sent it back without even asking and did no repairs. The note said "board bent". WTF?? How does the user bend the main board, especially when I never opened it? They voided my warranty and ripped off my IMEI/MEID sticker from the back of the phone.

Anyways, I am here with a brick. No network still. Here is what I have done:

1) .tot method to ZVC. Several more times... once to ZV7 where I lost touch capability. Luckily saved my arse with a micro->usb cable and a mouse.

2) attempted to root with ioroot25. Failed because the phone WILL NOT find recovery mode. adb, voldown+pwr then again from power off, and apps are unable to force the phone into recovery mode. I assume it is possible that my recovery mode is deleted?

3) Would have tried all of these "rewrite your efs/imei/etc" things but I can't do any without root. Can't root without recovery, can I?

4) Spent the last two weeks scouring the internet for a fix and going back to my Epic 4G temporarily.

Please help me, has anyone seen this before? Can anyone help me fix it? I am to the point where I would pay to have it fixed. Any experts out there? XDA has yet to let me down... I just need to know if I can fix it or if it is a brick so I can go searching for an old Sprint GS3.

Thanks all,

baublitz
 
Molson01
Old
#112  
Molson01's Avatar
Junior Member
Thanks Meter 0
Posts: 17
Join Date: Jun 2011
Exclamation Super helpful!

I'm going through this process after my MSID, MDN, ESN, MEID, IMEI all got zeroed out. Thanks LG.

Though, of course it is partially my problem I didn't see any warning about this issue, however, I feel it is unreasonable that a piece of commercial software would have this problem. (I know, I know, I wrecked 'said' software by rooting it, but still!)

I'm partly through this process, I did the initial ESN, MEID, IMEI restore, but I not 100% sure about my IMEI and ESN. Also, after doing the restore I set the MSID and MDN again, I was able to do PRL and a Profile updates, but it won't let me make phone calls. 1x and 3G are dead as described (of course I did a ##786# reset!) But 4G works like a champ!

Also, if I use my ICCID to calculate my ESN using the CDG website: https://www.cdg.org/devices/meid/mei...calculator.asp

I get a different number than if I use my MEID. Maybe I'll try the other one....
 
Molson01
Old
#113  
Molson01's Avatar
Junior Member
Thanks Meter 0
Posts: 17
Join Date: Jun 2011
DFS won't let me put in a different ESN, so I guess it knows the algorithm to calculate it and won't allow one that doesn't match your MEID?

Anyway it seems like Sprint mostly cares about the MEID which they call "serial number", totally a good thing to do because there is no other piece of information known as a serial number, wait, except the electronic serial number (ESN), thanks guys.

I had been getting really spotty service, sometimes it would say "Searching for service" when I knew I was in range, but I haven't seen that for a couple of days. But whenever I try to dial any number I get a message saying "Error code 16, switch 390", then it asks me to input my phone number, when I do, it says it is invalid and I should call my service provider (probably because I'm using an MVNO). I've got my MVNO looking into the "error code 16" issue now.

Anyone have any ideas on the "Error code 16"?

SMS is still not working either.
 
Molson01
Old
#114  
Molson01's Avatar
Junior Member
Thanks Meter 0
Posts: 17
Join Date: Jun 2011
Smile Voice/SMS/4G all working! 1x & 3G still missing - Can't get AAA Passwords...

I had been getting "Error code 16, switch 390" error, had my carrier take a look at it, then they gave me some instructions to refresh the PRL, Profile etc.

Here is the process I followed:
I fired up the dialer, used ##72786#, but it didn't ask for the MSL, I think the MSL was one of the pieces that was erased. Anyway, it asked if I wanted to set things to factory default, I say okay, and it reboots.

I initiated a PRL Update, that succeeded, but no reboot. I rebooted manually.
This time when it comes up it starts the "Handsfree Activation" process, this "activates" the phone, it immediately does another PRL update (on it's own), this time it reboots on it's own.
It comes up again, and looks for a firmware update, says I am up to date.
I try *99 - "the feature code you have entered is not valid" - Better than it used to be!
I try making a phone call - IT WORKS!
I try an SMS - IT WORKS!

Now I try running a Profile Update - "Update is complete", no automated reboot this time.
Doing a manual reboot - 4G works, 3G does not, and I'm not sure how to test 1x.

I'm pretty sure the remaining pieces are those data passwords that, apparently, we can't get.

I contacted Sprint, but of course they say I need to work with my MVNO service provider, even though I'm on their network.
But my MVNO RingPlus is not being super helpful, saying the only reason to get those passwords if if the phone were flashed or something, and they can't support me in those cases. Which, true it is rooted, but that is not the cause of this problem, as I have seen multiple posts about this happening to people with stock phones.

My next recourse would be to "Swap" service to a different device, then back to mine as apparently those data passwords would be regenerated. But I don't have any extra Sprint phones. If anyone has an MEID they wouldn't mind letting me "borrow" for a little bit I would be grateful.
 
Warren488
Old
#115  
Senior Member
Thanks Meter 10
Posts: 149
Join Date: Apr 2012
backing up efs is an absolute life saver, dont know what i would do if i hadnt done it
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes