Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,719 Members 38,248 Now Online
XDA Developers Android and Mobile Development Forum

Moto G 4g LTE - Sandisk ultra 32gb microsd card won't mount

Tip us?
 
cviniciusm
Old
#131  
cviniciusm's Avatar
Senior Member
Thanks Meter 63
Posts: 350
Join Date: Sep 2010
Location: Brasília - DF

 
DONATE TO ME
Hello,

Suggestion: someone could send a Moto G 4G Smartphone to IFIXIT to discover the SD host device.

More information about the thread/subject: http://en.wikipedia.org/wiki/SDHC
 
blackinches
Old
#132  
Senior Member
Thanks Meter 3
Posts: 170
Join Date: Oct 2009
Quote:
Originally Posted by NWKENT View Post
This is the one I use..works flawlessly in my XT1045 internal slot or as a MicroSDcard in the USB/Charge port..runs MP4 video perfectly..even with another card mounted also..I have (4) of these "Team" cards (1) 64GB, (3) 32GB..just ordered another 64GB, 10 minutes ago..I formatted them with WinXP FAT32 and have had excellent performance for more than one year now..


Sent from my:
(Jaocagomex debloated)
4.4_19.6.3 (Unlocked)
XT1080M Droid Maxx #2
http://waynekent.com/page6.html
Just ordered one of these off the egg for $26 and some change! promo code EMCPCHE66
The Following User Says Thank You to blackinches For This Useful Post: [ Click to Expand ]
 
NWKENT
Old
#133  
NWKENT's Avatar
Senior Member
Thanks Meter 468
Posts: 1,047
Join Date: Dec 2010
Just received and setup my second XT1045..adore these devices..have a 64GB card under the "back cover"..performs flawlessly just like my first XT1045..NO problems here with internal slot (or) OTG-USB..both like my 64GB just fine..

Sent from my 4.4.3_21.23.4
(Unlocked) XT1045 Moto G 4G LTE #2
http://waynekent.com/page6.html
"Praise Jah" YOU people.!
The Following User Says Thank You to NWKENT For This Useful Post: [ Click to Expand ]
 
Male_zvire
Old
#134  
Member
Thanks Meter 13
Posts: 84
Join Date: Mar 2012
My UK Moto G 4G with 4.4.4 - Samsung Micro SDXC EVO 64GB Class 10 UHS-I (P/N: MB-MP64DA) works perfect. In 4.4.3 card radomly unmounts...
The Following User Says Thank You to Male_zvire For This Useful Post: [ Click to Expand ]
 
aveyer
Old
#135  
Junior Member
Thanks Meter 1
Posts: 2
Join Date: Jun 2014
I've updated to android 4.4.4 now so I just tried my SanDisk 32GB Class 10 and it seems to be working fine now.
The Following User Says Thank You to aveyer For This Useful Post: [ Click to Expand ]
 
interessant
Old
#136  
Senior Member
Thanks Meter 7
Posts: 116
Join Date: Jun 2008
I was one of the very first to be affected by this issue. I wanted to reiterate my initial findings. The issue is more than likely related to different sd host controllers being sourced during manufacture -- or improper soldering job on the component. Since the exact same class 10 cards have been shown to work flawlessly on two 4.4.2 devices and failed on two 4.4.2 devices purchased within a two week period, all from amazon, there is no other valid explanation.

There is a possibility that 4.4.4 release tries to update the software/driver to work 'better' with the sd host controller's requirements, but if there is a hardware flaw, then software is just a work-around to an existing problem ( perhaps by modifying the latency, read/write wait times, etc )

Motorola should have released the different IMEI's related to the SD host controllers if they have already identified it so they can take them back and fix it before selling these new phones. If the same SD host controller is being used then it's a quality control issue during manufacture, or they got bad batches of sd host controllers from whoever supplied it.

As for me, I'm still running a class 10 32gb without issue on one of the four above mentioned phones without any updates except to 4.4.3 OTA.
The Following User Says Thank You to interessant For This Useful Post: [ Click to Expand ]
 
sanzoghenzo
Old
(Last edited by sanzoghenzo; 26th August 2014 at 08:15 PM.)
#137  
Member
Thanks Meter 2
Posts: 39
Join Date: Aug 2011
Location: Trento

 
DONATE TO ME
Hi all, I got the moto g a week ago, and I'm using a Sandisk Ultra 64GB micro sdxc U1 bought from amazon Italy some time ago (I used it in my previous phone). So far so good.

I really would like to use that sdcard formatted in ext4, and use drivedroid to bring with me some os images (and a portableapps partition). The problem is stock rom doesn't like ext4 sdcard, and the kernel doesn't allow to mount the drivedroid images as usb rw disks. I guess I'll wait till motorola releases the stock rom/kernel sources!


UPDATE: I spoke to soon... The SD card was the cause of frequent app freezes (I'm using rooted stock 4.4.4 on X1039 with xposed framework) that rendered the phone unusable. After forcing a reboot the phone says I have a bad sdcard. Even after reflashing the stock rom (the one with the unlocked bootloader waring removed you can find in this forum) I got this problems. After taking out the sd card everything seems to work fine (I have not installed xposed yet).

UPDATE 2: switching to a sandisk 8gb class 10 Uhs1 lying around solved my problems. Until I'll run out of space!
 
Xplorer4x4
Old
#138  
Xplorer4x4's Avatar
Senior Member
Thanks Meter 17
Posts: 256
Join Date: Mar 2010
I have the same card as the OP and can confirm its not working on my xt1045. Sad that it worked on a POS Kyocera Event and Moto Razr HD but not the Moto G which is a major step up from the Event and a not so bad replacement for the Razr HD Maxx that went out!
Phone: Moto G LTE XT1045
 
Kwen
Old
#139  
Senior Member
Thanks Meter 29
Posts: 253
Join Date: Nov 2006
Location: Montreal
Same problem with my Rogers/Fido XT1040, 4.4.3, no updates to 4.4.4 yet.
 
sand3rs
Old
#140  
Junior Member
Thanks Meter 1
Posts: 1
Join Date: Aug 2014
Default It works! Some phones are just bad.

I got one of these phones too and had the same problem, even with a smaller/slower memory card. I contacted Motorola support via chat and they claimed the pending system update to 4.4.4 may help, but could not say when I could expect it, and offered to send a 4 gig memory card in the meantime. The support person said the update depended on my carrier, but I bought it unlocked from Amazon and use a BYOD plan, which seemed to flummox them. I waited until the end of the return window, still no update available, and had Amazon send out a replacement, which was free and speedy and they gave me 30 days to send the old one back. It works fine with the same memory card:
SanDisk Ultra 32GB MicroSDHC Class 10 UHS Memory Card Speed Up To 30MB/s With Adapter, Frustration-Free Packaging - SDSDQU-032G-AFFP-A
and seems to have the same system version, 4.4.3. The one difference is that I put files on the card first, which some forum posters seem to think makes a difference, but the Motorola support person said it would not. I will try wiping it sometime soon to see if the replacement phone can still read it, but it looks more and more to me like some of these phones ship with this problem and some do not. I recommend buying it from Amazon and just returning it until you get one that works as it should.

Now it is just the phone I was looking for: compact, fast, good battery life, expandable memory, minimal/nonexistent carrier software bloat.

The Following User Says Thank You to sand3rs For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes