Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,779,023 Members 43,597 Now Online
XDA Developers Android and Mobile Development Forum

[RECOVERY][OFFICIAL][condor] TWRP 2.7.1.0 touch recovery

Tip us?
 
magicw
Old
(Last edited by magicw; 4th August 2014 at 11:23 AM.)
#201  
magicw's Avatar
Senior Member
Thanks Meter 85
Posts: 284
Join Date: Jan 2013
"fix permission" does not help at all. It simply fixes permissions in /system/app/ and /system/priv-app/ folders of the ROM which is on the phone.

But with Nandroid Manager you can check integrity of your backup folder. So if the app finds the backup you can open it and having a look at each single partition which was backed up.

Cache, data and system partition you even should be able to deep dive into subfolder structure - just double tap on the respective partition (but not on the md5 sum-file )

So if this works well - then obviously TWRP really has a problem with restoring. Honestly, I did not test restore function so far - so I cannot confirm oder deny this behavior.

Does respond with a specific failure message?
Attached Images
File Type: jpg ryf0i.jpg - [Click for QR Code] (73.1 KB, 137 views)
File Type: jpg ufucz.jpg - [Click for QR Code] (61.0 KB, 129 views)
File Type: jpg a8uw1.jpg - [Click for QR Code] (72.8 KB, 125 views)
currently mine: Moto E CM11 // GT-I9001 SlimKat ION
admin for: GT-I8190 (CM10.1 and CM11) and Moto E (rooted Stock)
 
alshanu
Old
#202  
alshanu's Avatar
Member
Thanks Meter 2
Posts: 34
Join Date: Feb 2013
Location: Trivandrum
Default recovery

Quote:
Originally Posted by z001600z View Post
I get Mismatched partition size (recovery)

Have a new phone updated to 4.4.4

Help, please.

tks.

---------- Post added at 12:08 PM ---------- Previous post was at 12:03 PM ----------

thanks for the quick reply! (and sorry for posting twice).

no, it wont go to recovery, gives bad command and hangs

i've also tried flashing original recovery 4.4.2-recovery.img but it gives

bad check fails for recovery.

tks.
me too have the same issue (KK 4.4.4)
anyone know the reason for this ?
 
olpiofort
Old
#203  
Junior Member
Thanks Meter 1
Posts: 23
Join Date: Dec 2007
Hello Guys,


yesterday i have updated the phone to 4.4.4 but unfortunatly it is impossible to flash back the recovery, the official twrp says mismatch partition size and the unofficial one (2.7.2) says aborted for permission not granted ? my model is an xt1021
 
Deadly
Old
#204  
Deadly's Avatar
Recognized Contributor
Thanks Meter 3907
Posts: 10,156
Join Date: Jul 2012
Location: Bangalore

 
DONATE TO ME
Quote:
Originally Posted by olpiofort View Post
Hello Guys,


yesterday i have updated the phone to 4.4.4 but unfortunatly it is impossible to flash back the recovery, the official twrp says mismatch partition size and the unofficial one (2.7.2) says aborted for permission not granted ? my model is an xt1021
Check the op. Mismatch size message is totally fine. It expects 10 mb where as its just compact in size (7mb)

As long as recovery loads, you are fine
"Thanks button is just to avoid "thanks" posts in threads. Nothing more than that. Don't ask in signature or post for it and defeat the purpose why it was introduced"
 
olpiofort
Old
#205  
Junior Member
Thanks Meter 1
Posts: 23
Join Date: Dec 2007
recovery does not Load, both versions
 
magicw
Old
#206  
magicw's Avatar
Senior Member
Thanks Meter 85
Posts: 284
Join Date: Jan 2013
Default additional partitions to back up?

I'm using onandroid script to run backups w/o booting into recovery.

Onandroid backs up far more partitions than TWRP does offer. Unfortunately in restore mode TWRP also does not offer those additional partitions.
Is it possible to make them available for backup and restore in TWRP as well for a full backup of userdata? If apps are moved to SD on either method (Link2SD, App2SD) only the app-links are backed up currently by TWRP but not the apps themselves.

From onandroid backup log - green ones are available in TWRP - red ones missing:
Code:
17:31:25 Backing up /boot...\c
17:31:27 Backing up /recovery...\c
17:31:32 Backing up /modem...\c
17:31:47 Backing up /system...\c
17:33:51 Backing up /data...\c
17:35:28 Backing up /cache...\c
17:35:30 Backing up /.android_secure...\c
17:36:04 Backing up /sd-ext...\c
currently mine: Moto E CM11 // GT-I9001 SlimKat ION
admin for: GT-I8190 (CM10.1 and CM11) and Moto E (rooted Stock)
 
Deadly
Old
#207  
Deadly's Avatar
Recognized Contributor
Thanks Meter 3907
Posts: 10,156
Join Date: Jul 2012
Location: Bangalore

 
DONATE TO ME
Quote:
Originally Posted by magicw View Post
I'm using onandroid script to run backups w/o booting into recovery.

Onandroid backs up far more partitions than TWRP does offer. Unfortunately in restore mode TWRP also does not offer those additional partitions.
Is it possible to make them available for backup and restore in TWRP as well for a full backup of userdata? If apps are moved to SD on either method (Link2SD, App2SD) only the app-links are backed up currently by TWRP but not the apps themselves.

From onandroid backup log - green ones are available in TWRP - red ones missing:
Code:
17:31:25 Backing up /boot...\c
17:31:27 Backing up /recovery...\c
17:31:32 Backing up /modem...\c
17:31:47 Backing up /system...\c
17:33:51 Backing up /data...\c
17:35:28 Backing up /cache...\c
17:35:30 Backing up /.android_secure...\c
17:36:04 Backing up /sd-ext...\c
There is a custom partition selection to select only ones that are used. So for mean time you can avoid unnecessary extra backups until they get added, if he adds
"Thanks button is just to avoid "thanks" posts in threads. Nothing more than that. Don't ask in signature or post for it and defeat the purpose why it was introduced"
 
alshanu
Old
#208  
alshanu's Avatar
Member
Thanks Meter 2
Posts: 34
Join Date: Feb 2013
Location: Trivandrum
Unhappy downgrade

I had downgraded my moto e xt1022 from 4.4.4 to 4.4.2 because I'm unable to flash custom recovery in my phone
I had sent PM to some geeks about this, but unfortunately they can't find the solution
 
Deadly
Old
#209  
Deadly's Avatar
Recognized Contributor
Thanks Meter 3907
Posts: 10,156
Join Date: Jul 2012
Location: Bangalore

 
DONATE TO ME
Quote:
Originally Posted by alshanu View Post
I had downgraded my moto e xt1022 from 4.4.4 to 4.4.2 because I'm unable to flash custom recovery in my phone
I had sent PM to some geeks about this, but unfortunately they can't find the solution
If you need solution to such things. Create a thread in Q&A section. Discussion might get answer from other people as well. Pm is secluded and most of times certain bugs can never be resolved in that way. Reading others reply can help you solve it.

And others in future if faced with same problem can read your thread. Pming for issues is no gain for anyone and may become little annoying too.
"Thanks button is just to avoid "thanks" posts in threads. Nothing more than that. Don't ask in signature or post for it and defeat the purpose why it was introduced"
 
shamps
Old
#210  
shamps's Avatar
Senior Member
Thanks Meter 109
Posts: 757
Join Date: Jan 2011
Quote:
Originally Posted by olpiofort View Post
recovery does not Load, both versions
Having the same issue, Cant root without a recovery, have unlocked my bootloader.

Were you able to flash the recovery?

if yes, please share how did you do it

thanks in advance!!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes