Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,110 Members 52,086 Now Online
XDA Developers Android and Mobile Development Forum

Galaxy S5 SM-G9008V Owners' Thread

Tip us?
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Jun 2014
Default S5 Root Kit

Hi all

I'm also stuck as I cannot find and download the referred to in this thread, can anyone offer a working link or email.

Thanks in advance
(Last edited by metri666; 8th July 2014 at 06:17 PM.) Reason: Update
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Mar 2012
Default Tripped Knox, but for what?

Hi Guys,

I feel like a complete n00b... maybe there is a reason for that.

I installed USB drivers & Odin
I downloaded Philz_touch (and g9008v-cmw)
I Connect the phone to the PC in Flash mode (Vol - + home + Power) and choose F option only. Select PDA file (Whichever) and then start
It says success.
I reboot into recovery mode and it says Detected blah blah setting security bit...

Setting Security

Oh that sucks, but it was expected.
The phone reboots. I shut it off and then boot into recovery mode expecting to see Philz... but all I get is the same Android system recovery.

Now my phone shows custom Binary, custom System, and knox is tripped but I can't get into Philz or CWM only the regular system recovery.
I feel dumb and angry. All I wanted was the google play store, but I have to try and hack my phone so I can BUY apps. Retarded. Thanks China Mobile. But without this version, no 4G here.

I think it's dumb I have to do this to get google apps.

So my phone is SM-G9008V and anything you guys could suggest for me to try would be very much appreciated. I would love to be able to root this phone, especially since I've already voided the warranty.

Sorry if this comes off as bitter. I'm just frustrated.


I guess Philz wasn't compatible. Used CMW and it worked.... what a PITA glad it's going now. It just didn't act the same each flash. I must have repeated 10 times until it worked once
Vash the Stampede
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jul 2014
Default How to get Google Play Store to work on Galaxy S5 G9008V?

Hi everyone!
I recently bought a G9008V from a Walmart in Shanghai.

I was able to root it by using the root tool from Towelroot.
The root was confirmed successful by "root checker" from Amazon app store. (Poor me could only install Amazon app store on it).

Now I am still unable to use Google Play after I installed it.
It just won't connect and kept giving me the "retry" button. I am on a VPN from StrongVPN servers located in California, and I am able to watch netflix/youtube/facebook etc. So the great firewall isn't the problem here.

So what is wrong with this Google Play?
(by google around, some other people say all phones in China need a firmware flash before be able to get Play Store to work. Is it true?)

Could someone please give detailed step by step instruction for how to get Google Play to work on this version of Galaxy S5?
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jul 2014
Hello Bobopopo,

Can I use the same to root the S5 90008W Duos?

Originally Posted by bobopopo View Post
Hi otby,

I am not an expert on the google apps but I also encountered problems before (unexpected shutdowns etc.)

If I understand you correctly, you have used a different file than I did. My file (see link in my instructions above installed flawless and worked out fine. Maybe you just try the same file? If your wife is using the calendar sync then you need to install separately (also under the link above). All works well for my wife's phone; so if you have the same phone with the same original stock ROM it should be reproducable. Maybe the gapps that you installed do not match the ROM.

Please also make sure the following:

1. Check that your phone is really successfully rooted.
2. Make sure that you really install the gapps when being in recovery mode. The file I used was giving a lot of feedback during installation and also confirmed in the end that the installation was successful.

Installing an international ROM according my experience should kill the radio function of the phone (because this thread is about the G9008V which is China Mobile 4G which relies on TD-SCDMA standard which is mostly used by China Mobile only). If you install an international ROM your phone will be flashed with a different radio stack and does not know how to connect to the China Mobile network anymore. I did that with a HTC S720t and all I was left with was a PDA with wifi. So better do not try that.

My wifes phone still has the original ROM, just rooted and with Google Apps. To clean up the useless China Mobile rubbish from the ROM you can e.g. use Titanium Backup to free it from bloat ware (but be careful not to kill the ROM).

Good luck with the Google apps; maybe someone else with more experience than me can also comment on why your Gapps did not install successful.

If you can get it running, that phone will really rock; so keep on trying...


Junior Member
Thanks Meter 0
Posts: 3
Join Date: Jul 2014
Default I also require the file urgent

Originally Posted by flollop View Post
That would be great, thank you! I'll PM you my email address. Thanks!
can you please email me the file aswell as this link is not working thanks
PJ6363's Avatar
Senior Member
Thanks Meter 0
Posts: 348
Join Date: Feb 2007
Location: Perth
Default please......

Originally Posted by kistvan80 View Post
@flollop - i have it, if you give me an email address i can send it to you
Hi kistvan, could you please send me a copy of, I cant find it anywhere...many thanks

HTC Velocity, Telstra Stock
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Aug 2014
Originally Posted by kistvan80 View Post
@flollop - i have it, if you give me an email address i can send it to you
@kistvan80 Would you be able to send me the file too? Thank you very much! pm-ed you my email!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes