Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,599 Members 35,958 Now Online
XDA Developers Android and Mobile Development Forum

Galaxy Gear won't charge or turn on

Tip us?
 
chm0dvii
Old
#31  
chm0dvii's Avatar
Member
Thanks Meter 28
Posts: 88
Join Date: Dec 2010
Location: New Orleans
Smile Charging!

Thanks to everyone for all the advice.

I couldn't for the life of me get the watch charging after letting it sit for days without charging. The battery was completely discharged. I tried several wall chargers, cradles, etc.

I then tried the multiple tap and holds sequences, then plugged in to laptop using an S4 cable and presto! It's showing that it's charging. I thought it was shot.


Thanks again.
Phone: Tmobile Samsung Galaxy Note 3/ Galaxy Gear


Previous Android Phones:
Tmobile Samsung Galaxy S4
Samsung Galaxy S 3
Samsung Galaxy S2 one week before switching out to S3
HTC Sensation T-mobile
LG G2X
Samsung Vibrant
Motorola Defy
MyTouch Slide
MyTouch 3G
 
tjtnt89
Old
#32  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Aug 2014
Default Thanks everyone...

I read all posts and figured out something that worked for me in just 10 mins... as well as everyone here, the gear wouldnt charge or turn on because I left it like 2 months.
I plugged the gear through a regular micro usb cable to my laptop and still doesnīt turn on but like magic I just opened the gear case where you have to put the gear to charge and moved it a little then close it again and vuala it turned on and started charging...

If this helps I firstly connected it through an usb 3.0 and nothing happened, then tried the usb 2.0 and it worked.
 
oddbehreif
Old
(Last edited by oddbehreif; 29th August 2014 at 06:12 PM.)
#33  
oddbehreif's Avatar
Senior Member
Thanks Meter 47
Posts: 134
Join Date: Sep 2012
My two cents.

Charging with the wall charger didn't yield any results, even after a week of sitting and charging. Cleaned all contacts with a toothpick and did the same thing, nothing. Tried plugging into my laptop (something that worked for some posters), still nothing.

What finally did the trick was actually picking up a screwdriver and briefly disconnecting the battery from the motherboard, then putting it back together. When I plugged it in afterwards the orange clock icon appeared immediately, and my Gear begun charging. Hooray!

So, if nothing else, I confirm the battery disconnect trick - works like a charm. Don't worry about not having small TORX drivers; a 1.4mm flathead should work fine - be careful though, you may ruin the screws if you use too much force. You've been warned!

Cheers,
-odd
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes