Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,803,209 Members 44,022 Now Online
XDA Developers Android and Mobile Development Forum

F2FS for Evita?

Tip us?
 
Protogon
Old
(Last edited by Protogon; 20th May 2014 at 08:07 AM.)
#1  
Protogon's Avatar
Senior Member - OP
Thanks Meter 26
Posts: 183
Join Date: Jul 2012
Location: 127.0.0.1
Default F2FS for Evita?

Here's an XDA link explaining F2FS if you're not familiar: http://forum.xda-developers.com/show....php?t=2634271

Edit: Here's another, also including nil2fs: http://forum.xda-developers.com/show....php?t=1890129

Basically, Samsung developed a filesystem allegedly geared towards the nuances of NAND flash. With the recent buzz surrounding the Moto E and the X, F2FS seems to be getting thrown around a lot as partial explanation towards those devices' snappiness despite "lower-end" hardware.

Everyone here knows that the Evita has some pretty bad issues with its eMMC, and we've tried a bunch of different things to try to mitigate its poor quality. Maybe this is worth a shot?
HTC One (M8)
S-OFF | HBOOT 2.23

HTC One X [MSM8960] - RETIRED
S-OFF | HBOOT 2.18
 
jrior001
Old
#2  
jrior001's Avatar
Senior Member
Thanks Meter 2,620
Posts: 1,769
Join Date: Aug 2010
Location: Va Beach

 
DONATE TO ME
Current Aosp ROMs only

http://forum.xda-developers.com/show...php?p=54012357
The Following User Says Thank You to jrior001 For This Useful Post: [ Click to Expand ]
 
henry_mac
Old
#3  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Jan 2012
Default Stuck at boot animation

Greetings! I'm a new member to the forum, but I've lurked for a long time, so I posted this in the general Questions and Answers forum first. I've successfully flashed many ROMs, including Paranoid Android (including the latest release) but am dissatisfied with the performance, so I thought I'd try to convert to f2fs. I apologize if I mix up terminology anywhere, but I think I've got most of it.

Here are the steps that I have taken:

1. Flashed latest TWRP with support for f2fs
2. Performed a full wipe
3. Went to Advanced Wipe, converted data first, then cache partition to f2fs.
4. Flashed PA ROM
5. Wiped cache/dalvik
6. Flashed Torched Kernel (with support for f2fs)
7. Flashed f2fs-fstab conversion tool (v1.2)
8. Reboot System

I've even tried flashing the boot.img from the PA ROM in fastboot, but no dice. I can't figure out why I'm still getting stuck on the boot animation. Anybody have an idea? Thank you in advance for your time and consideration.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes