Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,786,645 Members 38,546 Now Online
XDA Developers Android and Mobile Development Forum
View Poll Results: Is this guide helping you ?
Yes 34 89.47%
No 4 10.53%
Voters: 38. You may not vote on this poll

[GUIDE]Porting Any Custom Roms[Fastest method][Update for porting MIUI Kitkat]

Tip us?
 
Nasheich Xfiles
Old
#161  
Nasheich Xfiles's Avatar
Recognized Contributor - OP
Thanks Meter 1,907
Posts: 1,871
Join Date: Aug 2012
Location: Jakarta Utara

 
DONATE TO ME
Quote:
Originally Posted by AlphaBeta View Post
Ok i will do it again but after i reach home i am at my college at the moment

And the link i gave above has the log file
Check this link:http://speedy.sh/dbx2w/name.txt
Download this text it is the log file only

It was quite big so i couldnot paste it

Sent from my C2104 using XDA Free mobile app
Ok, I'm waiting the next ramdisk.cpio


Your logcat is too long, filter the logcat to WARN/ERROR to make it easier to read...



Indonesian Developer

From Indonesia, to peoples around the world..

Follow my
Facebook | Twitter | Google+ | Instragram | Blog

My Contributions on XDA
Roms, Guides, Apps, etc
 
Krizthian
Old
#162  
Krizthian's Avatar
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Sep 2013
Location: Portovelo

 
DONATE TO ME
This guide not working in Moto G
 
AlphaBeta
Old
(Last edited by AlphaBeta; 1st September 2014 at 06:20 PM.)
#163  
AlphaBeta's Avatar
Member
Thanks Meter 49
Posts: 48
Join Date: May 2004
Location: delhi
Quote:
Originally Posted by Nasheich Xfiles View Post
Ok, I'm waiting the next ramdisk.cpio


Your logcat is too long, filter the logcat to WARN/ERROR to make it easier to read...
http://d-h.st/hz6
here is your ramdisk
i checked twice it has no extra folder this time

Logcat:
 

[ 01-02 13:00:01.681 332: 332 E/mm-camera ]
qcamsvr_load_gesture_lib Error opening gesture library
[ 01-02 13:00:01.681 332: 332 E/mm-camera ]
Cannot init Gesture library
[ 01-02 13:00:06.145 443: 443 W/InterfaceController ]
Warning (dlopen failed: library "/system/lib/libnetcmdiface.so" not found) while opening the net interface command library
[ 01-02 13:00:10.500 536: 536 W/InterfaceController ]
Warning (dlopen failed: library "/system/lib/libnetcmdiface.so" not found) while opening the net interface command library
[ 08-31 13:37:47.816 191: 191 E/tadif ]
Failed to connect to tad.
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 60203: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 60220: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 60221: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 60240: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2560: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_macaddr0
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2561: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_macaddr1
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2562: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_macaddr2
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2563: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_macaddr3
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2564: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_txpower_2_4g
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to read unit 2565: Unit not found
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_txpower_5g_low
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to read unit 2566: Unit not found
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_txpower_5g_mid
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to read unit 2567: Unit not found
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_txpower_5g_high
[ 01-02 13:08:22.966 9874: 9874 E/MediaPlayerFactory ]
calling dlopen on FACTORY_LIB
[ 01-02 13:08:22.976 9874: 9874 E/MediaPlayerFactory ]
calling dlsym on pFactoryLib for FACTORY_CREATE_FN
[ 01-02 13:08:22.976 9874: 9874 E/MediaPlayerFactory ]
registering DASH Player factory...
[ 01-02 13:08:22.976 9874: 9874 I/CameraService ]
CameraService started (pid=9874)
[ 01-02 13:08:22.976 9874: 9874 I/CameraService ]
Loaded "Xperia Camera Wrapper" camera module
[ 01-02 13:08:23.046 9874: 9874 E/HAL ]
load: module=/system/lib/hw/vendor-camera.msm8960.sodlopen failed: cannot locate symbol "morpho_HDRChecker_setSensitivity" referenced by "vendor-camera.msm8960.so"...
[ 01-02 13:08:23.046 9874: 9874 E/CameraWrapper ]
failed to open vendor camera module
[ 01-02 13:08:23.136 9874: 9874 E/ACDB-LOADER ]
done with conversion, anc config size is 148
[ 01-02 13:08:23.136 9874: 9874 D/ACDB-LOADER ]
ACDB -> ACDB_CMD_GET_ANC_SETTING
[ 01-02 13:08:23.536 9874: 9874 E/alsa_ucm ]
EC_REF_RX mixer ctl: SLIM_RX
[ 01-02 13:08:23.706 9874: 9874 E/MonoPipe ]
Failed to fetch local time frequency when constructing a MonoPipe (res = -32). getNextWriteTimestamp calls will be non-functiona
l[ 01-02 13:08:28.321 10005:10005 E/MediaPlayerFactory ]
calling dlopen on FACTORY_LIB
[ 01-02 13:08:28.331 10005:10005 E/MediaPlayerFactory ]
calling dlsym on pFactoryLib for FACTORY_CREATE_FN
[ 01-02 13:08:28.331 10005:10005 E/MediaPlayerFactory ]
registering DASH Player factory...
[ 01-02 13:08:28.331 10005:10005 I/CameraService ]
Loaded "Xperia Camera Wrapper" camera module
[ 01-02 13:08:28.341 10005:10005 E/HAL ]
load: module=/system/lib/hw/vendor-camera.msm8960.sodlopen failed: cannot locate symbol "morpho_HDRChecker_setSensitivity" referenced by "vendor-camera.msm8960.so"...
[ 01-02 13:08:28.341 10005:10005 E/CameraWrapper ]
failed to open vendor camera module
 
Nasheich Xfiles
Old
(Last edited by Nasheich Xfiles; Yesterday at 07:25 AM.)
#164  
Nasheich Xfiles's Avatar
Recognized Contributor - OP
Thanks Meter 1,907
Posts: 1,871
Join Date: Aug 2012
Location: Jakarta Utara

 
DONATE TO ME
Quote:
Originally Posted by Krizthian View Post
This guide not working in Moto G

what rom you wanna port and from what device?
Quote:
Originally Posted by AlphaBeta View Post
http://d-h.st/hz6
here is your ramdisk
i checked twice it has no extra folder this time




Logcat:
 

[ 01-02 13:00:01.681 332: 332 E/mm-camera ]
qcamsvr_load_gesture_lib Error opening gesture library
[ 01-02 13:00:01.681 332: 332 E/mm-camera ]
Cannot init Gesture library
[ 01-02 13:00:06.145 443: 443 W/InterfaceController ]
Warning (dlopen failed: library "/system/lib/libnetcmdiface.so" not found) while opening the net interface command library
[ 01-02 13:00:10.500 536: 536 W/InterfaceController ]
Warning (dlopen failed: library "/system/lib/libnetcmdiface.so" not found) while opening the net interface command library
[ 08-31 13:37:47.816 191: 191 E/tadif ]
Failed to connect to tad.
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 60203: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 60220: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 60221: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 60240: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2560: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_macaddr0
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2561: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_macaddr1
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2562: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_macaddr2
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2563: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_macaddr3
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to read unit 2564: Unit not found
[ 08-31 13:37:47.866 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_txpower_2_4g
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to read unit 2565: Unit not found
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_txpower_5g_low
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to read unit 2566: Unit not found
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_txpower_5g_mid
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to read unit 2567: Unit not found
[ 08-31 13:37:47.876 193: 193 E/taimport ]
Failed to put unit to /data/etc/wlan_txpower_5g_high
[ 01-02 13:08:22.966 9874: 9874 E/MediaPlayerFactory ]
calling dlopen on FACTORY_LIB
[ 01-02 13:08:22.976 9874: 9874 E/MediaPlayerFactory ]
calling dlsym on pFactoryLib for FACTORY_CREATE_FN
[ 01-02 13:08:22.976 9874: 9874 E/MediaPlayerFactory ]
registering DASH Player factory...
[ 01-02 13:08:22.976 9874: 9874 I/CameraService ]
CameraService started (pid=9874)
[ 01-02 13:08:22.976 9874: 9874 I/CameraService ]
Loaded "Xperia Camera Wrapper" camera module
[ 01-02 13:08:23.046 9874: 9874 E/HAL ]
load: module=/system/lib/hw/vendor-camera.msm8960.sodlopen failed: cannot locate symbol "morpho_HDRChecker_setSensitivity" referenced by "vendor-camera.msm8960.so"...
[ 01-02 13:08:23.046 9874: 9874 E/CameraWrapper ]
failed to open vendor camera module
[ 01-02 13:08:23.136 9874: 9874 E/ACDB-LOADER ]
done with conversion, anc config size is 148
[ 01-02 13:08:23.136 9874: 9874 D/ACDB-LOADER ]
ACDB -> ACDB_CMD_GET_ANC_SETTING
[ 01-02 13:08:23.536 9874: 9874 E/alsa_ucm ]
EC_REF_RX mixer ctl: SLIM_RX
[ 01-02 13:08:23.706 9874: 9874 E/MonoPipe ]
Failed to fetch local time frequency when constructing a MonoPipe (res = -32). getNextWriteTimestamp calls will be non-functiona
l[ 01-02 13:08:28.321 10005:10005 E/MediaPlayerFactory ]
calling dlopen on FACTORY_LIB
[ 01-02 13:08:28.331 10005:10005 E/MediaPlayerFactory ]
calling dlsym on pFactoryLib for FACTORY_CREATE_FN
[ 01-02 13:08:28.331 10005:10005 E/MediaPlayerFactory ]
registering DASH Player factory...
[ 01-02 13:08:28.331 10005:10005 I/CameraService ]
Loaded "Xperia Camera Wrapper" camera module
[ 01-02 13:08:28.341 10005:10005 E/HAL ]
load: module=/system/lib/hw/vendor-camera.msm8960.sodlopen failed: cannot locate symbol "morpho_HDRChecker_setSensitivity" referenced by "vendor-camera.msm8960.so"...
[ 01-02 13:08:28.341 10005:10005 E/CameraWrapper ]
failed to open vendor camera module



Thanks for new cpio,

I'll learning your log





edited

@AlphaBeta


it's still there bro, look
 




I have last request for you, please guide me how you repack it, with some screenshots to make me esier to understand, starting while you opening Cygwn program...





For you problems, replace these lib in system/lib

> All libs related to camera (libs with "cam/camera)
> libnetcmdiface.so
> libstagefright.so
limemtrack.so and libmemloc.so



Indonesian Developer

From Indonesia, to peoples around the world..

Follow my
Facebook | Twitter | Google+ | Instragram | Blog

My Contributions on XDA
Roms, Guides, Apps, etc
Tags
porting miui, porting mokee open source project, porting pac slimkat sokp aokp aosb carbon aospa, porting rom
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes