Backup+ Lets You Backup Your App Data on Android Lollipop

Even though Android 5.0 Lollipop hasn’t yet seen its official release, quite … more

TechTalk Compiles All the Android News You Need in One App

If you’re as obsessed with mobile devices as the vast majority of our forum … more

Android App Review: Google Inbox to Improve Your Life – XDA TV

Recently, Google+ exploded with the announcement of Google Inbox, as … more

Damp the LG G3 Thermal Throttling

As our mobile devices grow thinner and more powerfulwith each passing generation, it’s inevitable … more
Post Reply

Zero'ed my IMEI,HELP! iphone personal hotspot & ilex RAT

OP aviwdoowks

3rd February 2014, 06:19 PM   |  #1  
OP Senior Member
Thanks Meter: 520
 
2,553 posts
Join Date:Joined: Sep 2012
Well I am without signal & have zero'ed IMEI.
I assume the # on the card cover is the imei, 15 digits.
I flashed the wrong radio & have done a full rsd retsore to ...94.
I will try this next. I have all the components lined up for Win7 64bit with parallels desktop/Mac.
This process seems not to work on the 926. Has anyone tried this or anything else on the M?
http://forum.xda-developers.com/show...&postcount=109

Thanks to all for your consideration.
Edit @cellzealot what do you think? Sticky Wicket?

Edit
I am using my resurrected iphone 4s as a phone & hotspot tether for now.
I thought I might share some info/issues about it.
I am on ios-7.0.6 and while I hate the keyboard, Bluetooth-connectivity & browsers, the voice recognition for dialing (not to mention Siri) is better than the M. Also the stock "personal hotspot" is lame. It refuses to reconnect to the M after a call & at other times too. I tried insomnia & it seems to help. You must keep to hotspot screen open to keep a connection. But you must, !, close the same screen to get the off button to stick off!!

ILEX R.A.T TUTORIAL
As to restoring cydia apps when re-jailbreaking there is nothing as good as ilex rat (& source saver too).
Yet ilex puts a springboard icon that is terribly misleading. The app is to be run from mobile terminal. And as such it is good. You can create a .zip of all your .deb files, move them off the phone with iexplorer then use the same to put them in var/root/Media/Cydia/AutoInstall. Unzip with ifile. Remove zip. Reboot.
Last edited by aviwdoowks; 9th March 2014 at 09:09 PM.
4th February 2014, 10:00 PM   |  #2  
Senior Member
Flag Philadelphia, PA
Thanks Meter: 865
 
1,335 posts
Join Date:Joined: Jan 2008
More
Did you try the method described in the RAZR HD forum using EFS Professional to write back your IMEI?
That tool has the function to convert your IMEI into the proper little endian format for the hex data.

Have you tried just reflashing the fsg.mbn and modem?
The Following User Says Thank You to cellzealot For This Useful Post: [ View ]
5th February 2014, 06:12 PM   |  #3  
OP Senior Member
Thanks Meter: 520
 
2,553 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by cellzealot

Did you try the method described in the RAZR HD forum using EFS Professional to write back your IMEI?
That tool has the function to convert your IMEI into the proper little endian format for the hex data.

Have you tried just reflashing the fsg.mbn and modem?

Have you tried just reflashing the fsg.mbn and modem?
Yea. Both in the xml's : ...94 & 4.0.4.

.... tool has the function to convert your IMEI into the proper little endian format for the hex data.
Yes. seems to write but does not.
It is read only. How to find a bit to flip?

What about
http://forum.xda-developers.com/show...2&postcount=81 ?

8035 or any other seem may have a lock bit?
What about the Op's version?

I did get 4g working on 404!
Last edited by aviwdoowks; 5th February 2014 at 06:15 PM.
5th February 2014, 07:45 PM   |  #4  
Senior Member
Flag Philadelphia, PA
Thanks Meter: 865
 
1,335 posts
Join Date:Joined: Jan 2008
More
Quote:
Originally Posted by aviwdoowks

Have you tried just reflashing the fsg.mbn and modem?
Yea. Both in the xml's : ...94 & 4.0.4.

.... tool has the function to convert your IMEI into the proper little endian format for the hex data.
Yes. seems to write but does not.
It is read only. How to find a bit to flip?

What about
http://forum.xda-developers.com/show...2&postcount=81 ?

8035 or any other seem may have a lock bit?
What about the Op's version?

I did get 4g working on 404!

It may help me understand better if you explain exactly how this occurred. You say you flashed the "wrong radio" using CWM.

Which radio and how did you flash it in CWM?

Do you have QPST installed and know how to use the Software Download client to make a backup .qcn file?

If so, have you made a backup before when everything was functioning?
If you haven't made one, try running one now with no SIM installed and save it and send it to me so I can take a look at it.
There are a number of other NV Items involved that may affect the issue and that is one way to dump and examine them.

You say you got 4G working once under the ICS radio? That should not be possible without a valid IMEI.

Sorry, but I have many more questions than answers at this stage.


The 8035 NV Item for unlocking the MIP profile only affects CDMA/EvDO 3g authentication and the values are read from the SIM and written to the MIP at boot when USIM based authentication is enabled as it is on these models. The IMEI is not referenced at all in the MIP profile.
The Following User Says Thank You to cellzealot For This Useful Post: [ View ]
5th February 2014, 09:16 PM   |  #5  
OP Senior Member
Thanks Meter: 520
 
2,553 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by cellzealot

....
You say you got 4G working once under the ICS radio? That should not be possible without a valid IMEI.

I can recovery restore to 404 & post a ss but I am on my iphone, activated right now. If it is such an amazing anomaly I will.
5th February 2014, 09:34 PM   |  #6  
Senior Member
Flag Philadelphia, PA
Thanks Meter: 865
 
1,335 posts
Join Date:Joined: Jan 2008
More
I was mostly interested in how it happened.
The fact that it worked at all indicates the IMEI isn't actually blank or 0s but can't be read by the radio properly due to some other factor.
29th August 2014, 07:06 PM   |  #7  
Junior Member
Thanks Meter: 7
 
15 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by cellzealot

I was mostly interested in how it happened.
The fact that it worked at all indicates the IMEI isn't actually blank or 0s but can't be read by the radio properly due to some other factor.

my xt907 got this problem too...

I made a mistake flashing KK radio onto JB ROM, so when the phone turn on, it won't get any network signal, and then i realize that i'm flashing wrong radio, i tried reflashing with JB radio... it works, got the signal... but when i'm check IMEI status it show 0...

the reasons i'm reflashing radio, becaused the phone show "restricted access changed" after i'm turn on airplane mode for more than 24 hours (i was going hiked)...

i have to turn off then turn on phone again and find places for good signal, otherwise the phone show that message again.. this message show almost everytime when i'm turn on the phone, it's really annoying... and i can't find the reasons and the solutions for this problem on internet... and this is weird, after flashing wrong radio and my phone IMEI show 0, the message "restricted access change" it's only show if i'm going to places where the signal are really weak (it's should switch to 2G when 3G signal are weak, but it's not)..

how can i recover my IMEI back?

and how to fix "restricted access changed" ? i think this is bug, last year i was going hiked and bring xperia miro, i'm turn on airplane mode too for more than 24 hours.. and when i'm turn off airplane mode, it's never show that message...

many thanks in advance.
Last edited by dumplank; 29th August 2014 at 07:11 PM.
29th August 2014, 07:44 PM   |  #8  
OP Senior Member
Thanks Meter: 520
 
2,553 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by dumplank

my xt907 got this problem too...

I made a mistake flashing KK radio onto JB ROM, so when the phone turn on, it won't get any network signal, and then i realize that i'm flashing wrong radio, i tried reflashing with JB radio... it works, got the signal... but when i'm check IMEI status it show 0...

the reasons i'm reflashing radio, becaused the phone show "restricted access changed" after i'm turn on airplane mode for more than 24 hours (i was going hiked)...

i have to turn off then turn on phone again and find places for good signal, otherwise the phone show that message again.. this message show almost everytime when i'm turn on the phone, it's really annoying... and i can't find the reasons and the solutions for this problem on internet... and this is weird, after flashing wrong radio and my phone IMEI show 0, the message "restricted access change" it's only show if i'm going to places where the signal are really weak (it's should switch to 2G when 3G signal are weak, but it's not)..

how can i recover my IMEI back?

and how to fix "restricted access changed" ? i think this is bug, last year i was going hiked and bring xperia miro, i'm turn on airplane mode too for more than 24 hours.. and when i'm turn off airplane mode, it's never show that message...

many thanks in advance.

You can't on the 907/926. The data field is not writable. I got Droid Maxx.
3rd September 2014, 05:40 AM   |  #9  
Junior Member
Thanks Meter: 7
 
15 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by aviwdoowks

You can't on the 907/926. The data field is not writable. I got Droid Maxx.

I know, that field is not writeable on XT907...

i'm looking for another solutions... and i think this problem is tied with network carrier it self too...

today i' tried to set UTMS only, and the problem come up again, but this time look different...

i can use internet connection, but looks like GSM (related to voice and text message) is out of service...

but i have not try to use text messaging or try to call from my phone...

and here's the capture...

is anyone here ever have the same problem?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-09-03-11-22-13.png
Views:	18
Size:	63.3 KB
ID:	2922700   Click image for larger version

Name:	Screenshot_2014-09-03-11-23-06.png
Views:	19
Size:	112.0 KB
ID:	2922701  
3rd September 2014, 06:26 AM   |  #10  
OP Senior Member
Thanks Meter: 520
 
2,553 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by dumplank

I know, that field is not writeable on XT907...

i'm looking for another solutions... and i think this problem is tied with network carrier it self too...

today i' tried to set UTMS only, and the problem come up again, but this time look different...

i can use internet connection, but looks like GSM (related to voice and text message) is out of service...

but i have not try to use text messaging or try to call from my phone...

and here's the capture...

is anyone here ever have the same problem?

Could it be related to this known issue with the M or sister phones.
http://forum.xda-developers.com/show....php?t=2346623

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes