Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[ZU_GPe] Port of Sony Xperia KitKat ROM FW .681 (20140525)

OP DooMLoRD

25th May 2014, 09:40 AM   |  #1  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,017
 
13,124 posts
Join Date:Joined: Jul 2010
[ intro ]

firstly thanks to the user community to donate this device to me!

so guys I have done an initial port of Sony Xperia KitKat ROM from the ZU to the ZU_GPe!

it is still very much in test phase but i am sure other devs here can help out to get it working... the ZU_GPe has a smaller system partition so I had to remove a lot of files/apps from the Stock Sony Xperia firmware... but most of these apps can be separately downloaded and installed from the Play Store...



[ screenshot ]





[ what works ]
  • ROM Boots
  • Display/TouchScreen
  • 3G modem
  • Bluetooth



[ what doesnt work ]
  • Camera
  • WiFi

please keep reporting other bugs!


[ requirements ]



[ how to install ]
  • copy the ROM update zip to the sdcard
  • reboot into custom recovery
  • flash ROM update.zip (ROM package contains kernel with recovery)
  • Recommend wiping cache/dalvik-cache while in recovery
  • reboot from recovery and ROM will start booting



[ donations ]

if u feel that this work has helped u OR u think that the work i put into making this is worthy of donations, then click on the following link for buying me some coffee/beer/etc

PAYPAL DONATION LINK

OR

you can buy one of my awesome apps from Play Store!





[ downloads ]

KINDLY DO NOT MIRROR MY FILES


v01:

ZU_GPe-DooMLoRD-XZU_Port_KK-681_v1 {MIRROR}
MD5: 7731fa000e047767b3eeeab6832ec605



regards,

DooMLoRD
Last edited by DooMLoRD; 25th May 2014 at 09:44 AM.
The Following 7 Users Say Thank You to DooMLoRD For This Useful Post: [ View ]
25th May 2014, 06:05 PM   |  #2  
Account currently disabled
Flag Kepler-34b
Thanks Meter: 5,663
 
15,002 posts
Join Date:Joined: Oct 2007
More
Thanks! I don't have a GPe device, but thanks for doing this

Sent from my C6806_GPe using Tapatalk
The Following 2 Users Say Thank You to LordManhattan For This Useful Post: [ View ]
26th May 2014, 04:08 AM   |  #3  
Senior Member
Thanks Meter: 644
 
1,778 posts
Join Date:Joined: Jan 2011
@DooMLoRD is there anything you need tested? Would you like for me to try this Sony port, or is more for developers to try out?
26th May 2014, 05:23 AM   |  #4  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,017
 
13,124 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by adfurgerson

@DooMLoRD is there anything you need tested? Would you like for me to try this Sony port, or is more for developers to try out?

If you can test it out and report all bugs it would be great!

Also I think the internal sdcard doesn't mount correctly in the Sony ROM...

Sent from my D6503 using XDA Free mobile app
26th May 2014, 05:27 AM   |  #5  
Senior Member
Thanks Meter: 644
 
1,778 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by DooMLoRD

If you can test it out and report all bugs it would be great!

Also I think the internal sdcard doesn't mount correctly in the Sony ROM...

Sent from my D6503 using XDA Free mobile app

I will do that and report back. My findings after testing are listed below.

1. Auto-rotate broken.
2. Couldn't connect to Bluetooth headset.
3. Internal storage confirmed not working.

Dirty flashed over GPe ROM after wiping caches, had constant process.acore has stopped messages until cleared data for contacts and contacts storage.
@DooMLoRD ^^^^
Last edited by adfurgerson; 26th May 2014 at 04:54 PM.
The Following User Says Thank You to adfurgerson For This Useful Post: [ View ]
25th July 2014, 12:31 AM   |  #6  
Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: Dec 2007
Is there any new update to this thread? I am interested to see if the above issues were fixed.
25th July 2014, 12:43 AM   |  #7  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,380
 
3,005 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by sganta

Is there any new update to this thread? I am interested to see if the above issues were fixed.

No, I dont think any more work has been done on the port.

I might have a chance to do some work on this in a few weeks
The Following 3 Users Say Thank You to blueether For This Useful Post: [ View ]
24th August 2014, 03:27 AM   |  #8  
Senior Member
Thanks Meter: 219
 
360 posts
Join Date:Joined: Jan 2011
I'm just curious, if the regular ROM uses the same hardware why would wifi not load? Is it one of the things that had to be removed is why?
8th September 2014, 02:11 AM   |  #9  
Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: Dec 2007
Any update on the Standard Xperia Z Ultra rom on Sony Ultra Z GPE
8th September 2014, 08:55 AM   |  #10  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,380
 
3,005 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by sganta

Any update on the Standard Xperia Z Ultra rom on Sony Ultra Z GPE

I was thinking about having a look into this, if/when I get the time - so it might happen, but if @DooMLoRD cant get it stable...

The Following 2 Users Say Thank You to blueether For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes