Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Broken Chariging Port

OP FrozenPanda

23rd June 2014, 06:34 PM   |  #1  
OP Member
Thanks Meter: 4
 
34 posts
Join Date:Joined: Dec 2011
The charging port on my TF201 has broken. It's not charging when plugged into the wall or the computer and the cable is brand new. Has anybody else had this issue? Is there a fix for it other than sending it back to ASUS? My tablet is well over 2 years old and is not covered by warranty and they are asking well over $100 for the repair.
27th August 2014, 02:04 PM   |  #2  
xxbeanxx's Avatar
Senior Member
Flag Conception Bay South
Thanks Meter: 51
 
318 posts
Join Date:Joined: Sep 2010
More
Same problem. The device charges only when powered down.. Try that.

This tablet is the worst piece of hardware I've ever bought.
12th September 2014, 10:49 PM   |  #3  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Sep 2014
Have you tried holding it on the charger for like 20 hours? I have an issue, where I have 3 original chargers, but none enter the 15V charging mode, they only stick in the 5V mode (lower current, slower charging, just like from a PC). What I did, was I took a random 15V DC brick (at least 1.2A current rating) and hooked up a usb socket into which I input the original asus cable. The LED on the power button lights up, and the tablet charges quickly. So far I've been unable to diagnose why the original ones don't enter the 15V mode - my best guess is the cables I have are sucky, and the pin that tells the charger to go into the higher voltage mode is broken.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes