Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,829 Members 42,670 Now Online
XDA Developers Android and Mobile Development Forum

Chromebook Hacked: Trackpad / Touchpad

Tip us?
 
Rtistique
Old
(Last edited by Rtistique; 4th January 2014 at 03:53 PM.)
#1  
Rtistique's Avatar
Member - OP
Thanks Meter 99
Posts: 48
Join Date: Dec 2009
Location: Beaufort
Cool Chromebook Hacked: Trackpad / Touchpad

Have you just install Ubuntu on your Chromebook and your track-pad is aka broken or did not work. Now you have to suck it up and use a mouse or went back to ChromeOs because of this reason. I'm here to save your day. Listed below is step-by-step to fix your track-pad problem.



Track-pad Fix:


1. Open Terminal and gain access to root:

Sudo -s

2. Once you have login as a root user:

nano -w /etc/modules
or
sudo gedit /etc/modules

3. Add the following lines in this order:

loop
lp
rtc
i2c-i801
i2c-dev
chromeos-laptop
cyapa


4. Save (Ctrl-O)

5. Reboot

*Note if you are run Ubuntu 14.04 the track-pad should work once your system boots back up. If so skip to 10.

6. Log back in to the terminal as a root user:

Sudo -s

7. Download 64 bit kernel 3.11:

*Note if you need the 32 bit kernel I will have it listed below.

wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/linux-headers-3.11.0-031100_3.11.0-031100.201309021735_all.deb

wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/linux-headers-3.11.0-031100-generic_3.11.0-031100.201309021735_amd64.deb

wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/linux-image-3.11.0-031100-generic_3.11.0-031100.201309021735_amd64.deb


8. Now it’s time to install the kernel:

sudo dpkg -i linux-headers* linux-image*

9. Reboot

Ok track-pad should be working like a champ. If you have any problem on the steps above you can pm me.


10. Now it’s time to adjust Some Synaptics Options Edit /usr/share/X11/xorg.conf.d/50-synaptics.conf by running:

sudo gedit /usr/share/X11/xorg.conf.d/50-synaptics.conf

Find the line

MatchDevicePath "/dev/input/event*"

and add these after

Option "FingerHigh" "10"
Option "FingerLow" "5"
Option "HorizHysteresis" "12"
Option "VertHysteresis" "12"



11. Save (Ctrl-O)

12. Reboot


<---Please hit the thanks button if this work for you. If not Please post below and i will do my best to help you.


32 bit Kernel:

wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/linux-headers-3.11.0-031100_3.11.0-031100.201309021735_all.deb

wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/linux-headers-3.11.0-031100-generic_3.11.0-031100.201309021735_i386.deb

wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-saucy/linux-image-3.11.0-031100-generic_3.11.0-031100.201309021735_i386.deb
 
dEris
Old
#2  
dEris's Avatar
Senior Member
Thanks Meter 685
Posts: 2,814
Join Date: Nov 2009
Location: Dallas Texas

 
DONATE TO ME
Awesome thanks
 
wierdlmate
Old
#3  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Sep 2014
Default still doesn't work on ubuntu 14.04

I have Acer c720 with ubuntu 14.04 installed, but after executing 5) (reboot), touchpad still doesn't work.
Tags
acer c7, chromebook, fix, track pad, ubuntu
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes