Post Reply

[Q] SGH-M919 and Car Bluetooth Issues

OP myb120

21st May 2014, 01:51 AM   |  #11  
PanchoPlanet's Avatar
Senior Member
Flag Crooklyn
Thanks Meter: 642
 
2,484 posts
Join Date:Joined: Oct 2011
Donate to Me
More
Quote:
Originally Posted by myb120

Thanks for the heads up. I will give it a go. What ever happened to your Bluetooth controlled toaster? It was the only thing I could find when I was looking for a solution.

Here you go.

Pp.

Sent from my Touchwiz device that never forgets apps.
Attached Thumbnails
Click image for larger version

Name:	1400633442197.jpg
Views:	29
Size:	20.6 KB
ID:	2754734  
21st May 2014, 02:04 AM   |  #12  
Member
Thanks Meter: 8
 
80 posts
Join Date:Joined: Dec 2012
I had this exact same issue. The only work around is to not allow the car access to the contact list and call history. Messages seems to be fine though. this fixed it for me.
The Following User Says Thank You to Drizzythebiker For This Useful Post: [ View ]
21st May 2014, 02:17 AM   |  #13  
OP Junior Member
Thanks Meter: 3
 
10 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by PanchoPlanet

Here you go.

Pp.

Sent from my Touchwiz device that never forgets apps.

You talk to Fenny from time to time. Would you ask him if he knows what's going on here?

Quote:

05-20 10:00:31.546 8085 32642 W ContextImpl: Implicit intents with startService are not safe: Intent { act=com.samsung.ble.ACTION_SERVICE_BLE_AUTO_CONNEC T } android.content.ContextWrapper.startService:506 com.android.bluetooth.btservice.AdapterService.upd ateAdapterState:645 com.android.bluetooth.btservice.AdapterState.notif yAdapterStateChange:591

05-20 10:00:31.546 21859 22000 W ContextImpl: Calling a method in the system process without a qualified user: android.app.ContextImpl.bindService:1896 android.bluetooth.BluetoothA2dp.doBind:165 android.bluetooth.BluetoothA2dp$1.onBluetoothState Change:131 com.android.server.BluetoothManagerService.sendBlu etoothStateCallback:792 com.android.server.BluetoothManagerService.bluetoo thStateChangeHandler:1624

05-20 10:00:31.566 21859 22000 W ContextImpl: Calling a method in the system process without a qualified user: android.app.ContextImpl.bindService:1896 android.bluetooth.BluetoothHeadset.doBind:292 android.bluetooth.BluetoothHeadset$1.onBluetoothSt ateChange:255 com.android.server.BluetoothManagerService.sendBlu etoothStateCallback:792 com.android.server.BluetoothManagerService.bluetoo thStateChangeHandler:1624

05-20 10:00:31.566 21859 22000 W ContextImpl: Calling a method in the system process without a qualified user: android.app.ContextImpl.bindService:1896 android.bluetooth.BluetoothPan.doBind:173 android.bluetooth.BluetoothPan$2.onBluetoothStateC hange:216 com.android.server.BluetoothManagerService.sendBlu etoothStateCallback:792 com.android.server.BluetoothManagerService.bluetoo thStateChangeHandler:1624

21st May 2014, 02:56 AM   |  #14  
PanchoPlanet's Avatar
Senior Member
Flag Crooklyn
Thanks Meter: 642
 
2,484 posts
Join Date:Joined: Oct 2011
Donate to Me
More
I'll present it to him in his thread, it looks mind boggling to me but he may be able to decipher.

Pp.

Sent from my Touchwiz device that never forgets apps.
The Following User Says Thank You to PanchoPlanet For This Useful Post: [ View ]
28th May 2014, 08:31 PM   |  #15  
OP Junior Member
Thanks Meter: 3
 
10 posts
Join Date:Joined: Jan 2014
Solution!?!?
So here's a little update:

Right now problem solved!

Noticed that BluetoothPbapService would be the last thread in LogCat before Bluetooth disconnected. I remember reading somewhere that it was the sms/mms message transfer to the car that was causing the disconnect. Here are the steps I took to fix the problem:
  1. Unpair and delete phone from Car
  2. Delete Car from Pone
  3. Pair Phone to Car
  4. Accept Contact Transfer to Car
  5. Deny Message Transfer to Car

This seems to have fixed the problem.


Thanks for all your help.
The Following 2 Users Say Thank You to myb120 For This Useful Post: [ View ]
29th May 2014, 04:07 AM   |  #16  
PanchoPlanet's Avatar
Senior Member
Flag Crooklyn
Thanks Meter: 642
 
2,484 posts
Join Date:Joined: Oct 2011
Donate to Me
More
Glad to hear you solved the problem and sharing your find will help others with a similar problem.

Pp.

Sent from my Touchwiz device that never forgets apps.
15th September 2014, 02:46 PM   |  #17  
Senior Member
Thanks Meter: 19
 
691 posts
Join Date:Joined: Aug 2009
Quote:
Originally Posted by myb120

So here's a little update:

Right now problem solved!

Noticed that BluetoothPbapService would be the last thread in LogCat before Bluetooth disconnected. I remember reading somewhere that it was the sms/mms message transfer to the car that was causing the disconnect. Here are the steps I took to fix the problem:

  1. Unpair and delete phone from Car
  2. Delete Car from Pone
  3. Pair Phone to Car
  4. Accept Contact Transfer to Car
  5. Deny Message Transfer to Car

This seems to have fixed the problem.


Thanks for all your help.

I just wanted to chime in in case this thread helps anyone. I have had this issue with the bluetooth ever since I got my new car in June.. Old car didn't support media streaming but new one does so I was excited to stream my music and Pandora to the car. However, I had several issues.

Background:
1.) I'm running slimkat on Android 4.4.4
2.) I had the same trouble even when i switched to dandroid
3.) I could connect via bluetooth but it would skip so much that it was pointless to try to stream
4.) I started searching forums and found that in a few threads people mentioned that it was the contacts transfer that was causing the issue and I followed the instructions above to re-establish the bluetooth connection
5.) This time, the bluetooth would actually disconnect and reconnect, disconnect and reconnect
6.) I realized that I had no trouble connecting to my mini bose soundlink

My "solution"
- Once I connected to bluetooth, I go into phone settings, bluetooth, go to the profile settings for my car, there are two profiles 1) phone audio and 2) media audio
- I uncheck phone audio


With only the media audio profile, i have ZERO skipping, ZERO disconnecting so it's great for my music.

However, I can't get the phone audio to work so I can go hands free.

Luckily, no one ever calls me so I don't really need it.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes