Thanks man! this worked for me great!

Quote:
Originally Posted by GeekSpin View Post
Don't Do that, actually its the software problem here is mine workaround I use

Follow step carefully

Step 1 - Go to dialer and dial *#*#4636#*#*

Step 2 - Select Phone Information

Step 3 - Scroll down, select preferred network type to WCDMA only.

Step 4 - Enable data

Step 5 - Enjoy HSPA+

Step 6 - Press Thanks if helped