Post Reply

FIX!! No APN specified on device (MMS not sending/receiving)

OP jdinardo22

8th May 2014, 06:47 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
1 posts
Join Date:Joined: Feb 2012
Hey guys,

So I know I'm not alone on this issue, I've come across countless topics and I couldn't find a solid solution ANYWHERE and I tried EVERYTHING. I finally stumbled upon a solution that worked for me and it DIDN'T involve a clean wipe of my ROM.
(oh and a little background, I'm running a Droid 4 on Verizon with stargo's port of CM11 KitKat)

The topic is on the cyanogenmod website (can't post the link because of stupid forum rules), and I found the solution in the comments. Here is the comment by Matt Mower:

"Michael Gernoth, after changing apns-conf.xml, you might need to force a reload of apns-conf.xml. One way to achieve this is:

1) Enable airplane mode
2) Restart phone
3) Settings > Mobile networks should now show "Access point names" as a menu you can enter
4) In Access point names menu, choose "Reset to default" from the drop menu
5) Disable airplane mode"


So I did that, and wallah, I was able to send and receive MMS again and the error is gone!! I've seen soo many other people on here who have the same issue and have tried to reset to default and they mention that it wouldn't save, and I think the reason is it just needed that said manual reload of apns-config.xml.

Please note that I take NO CREDIT FOR THIS FIX, I just happened to find the post that contained the info that I believe many others have missed. Please share this info with anyone else having this issue as it could save them a ton of frustration as well.

Thanks for reading!
Last edited by jdinardo22; 8th May 2014 at 07:02 AM.
The Following User Says Thank You to jdinardo22 For This Useful Post: [ View ]
22nd September 2014, 03:34 AM   |  #2  
Member
Thanks Meter: 11
 
62 posts
Join Date:Joined: Feb 2007
I personally tried several solutions including replacing the apns-conf.xml file, manually entering all the APN info and others without any real permanent success.

There is a ridiculously simple fix to cure this issue once and for all.

Make sure your Droid 4 is rooted and open the Play Store. Install Root Tweaker by broodplank. Open the app and check the box next to Cyanogenmod APNS List. Click "Tweak now!" You'll get a message advising it has been applied. Close the app, reboot your device and you should be good to go.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in General by ThreadRank