Post Reply

[FIX] Data Encryption Problem AOSP Roms

OP maxrdlf95

2nd September 2014, 08:09 AM   |  #71  
Darknites's Avatar
Senior Member
Thanks Meter: 2,332
 
5,702 posts
Join Date:Joined: Jul 2011
More
Quote:
Originally Posted by vince47

Well Saturday I installed cm-11-20140830-NIGHTLY-m8 to try it out (came from CleanROM 1.4) At the end of the day I decided to go back to cleanrom so I tried to restore my nandroid from TWRP. -ERROR- could not mount data within TWRP. Found this thread and tried the command in ADB Shell. Still couldn't mount DATA (internal SD). I ended up formatting data from within TWRP and then was able to restore my backup. I did not use the power and volume up to reboot so I don't know what would have caused the encryption problem but at least I'm functioning again. Thank you all for providing your valuable input.

Ya i kinder had this, couldn't see internal sd but after trying many things it seemed wiping caches fixed it for me.

Sent from my One M8 using Tapatalk
5th September 2014, 06:15 PM   |  #72  
Member
Thanks Meter: 25
 
87 posts
Join Date:Joined: Aug 2014
Not sure if it was posted in the thread, but I've had this happen to me before and all I did was a RUU and it fixed it. Maybe that's an alternate method you guys having problems can use.

I'm on Verizon btw.

Sent from my One M8 using XDA Free mobile app
19th September 2014, 02:17 AM   |  #73  
fix-this!'s Avatar
Senior Member
midwest
Thanks Meter: 324
 
2,386 posts
Join Date:Joined: Apr 2012
More
Is this rom or kernel related? Just had this on aicp + furnace kernel. What causes it and why hasnt a permanant fix been implemented?
20th September 2014, 04:28 AM   |  #74  
S1L3nTShaDoWz's Avatar
Senior Member
Thanks Meter: 44
 
283 posts
Join Date:Joined: Dec 2013
More
I have an alternative solution that just saved me.

A few weeks ago someone posted in a thread I was replying to about having a special version of TWRP called "Buck's TWRP" and I downloaded it and have been using it since, now before someone blasts me about this, I have no idea who's TWRP this is or if it's the normal one but all I know is I never had these features I'm about to mention before I installed it. Anyways I flashed that a while back when I found it and came to like it quite the bit more so kept using it. Today I did the Vol up + Power and encountered this when, it happened right after flashing the brand new CM nightly that came out 9/19 (today).

Anyways onto the solution that fixed it for me.

1) in Buck's TWRP go to > Wipe > Advanced Wipe > Repair Filesystem or change Filesystem > Change Filesystem
2) Change it to Exfat4 or whatever you already have (should tell you above it) and then navigate to 'Repair Filesystem' and repair it.
3) After having done those steps it should've passed/completed all of them with no errors and your /data should now be mountable with no data losses.
4) Restore a Nandroid of your old ROM or whatever you want and be glad you didn't lose your pictures/music/internal storage (if it worked)

Lastly, yes I know saying "special" makes it sound shady, but take my word for it it worked for me and is worth a shot. Will link it below and if anyone can tell me who made this and or link me to the original download link I'll credit them and link to their thread or whatever they have. For now all I know is it was called and named "Bucks TWRP" and I found it on another forum after failing to find anything else on Google.
Oh and this may be in the newer TWRP's, not exactly sure as I haven't tried them but I'm just posting this from what I myself did.


Download link file exceeds limit and can't upload on-site.
Edit: Never mind, normal TWRP has the feature, I just never noticed it as I was never looking for new features until I flashed that. Still it solves the encryption bug or at least it did for me and also solves other problems with an unmountable partition (system, data, cache, etc)
Last edited by S1L3nTShaDoWz; 22nd September 2014 at 11:04 PM.
22nd September 2014, 02:51 PM   |  #75  
maxrdlf95's Avatar
OP Senior Member
Flag Caracas
Thanks Meter: 377
 
862 posts
Join Date:Joined: Sep 2012
Donate to Me
More
That feature its already on twrp and once you restore or fix data you can boot into current rom
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in One (M8) General by ThreadRank