Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Stop Your Screen From Turning Off with KeepItOn

We all know the feeling of reading a news article orrather longdocument, when our screen … more

The XDA LG QPair Developer Challenge Voting Has Begun!

It seems like it was just yesterday that weannounced that we had paired up with LGto … more

Major Update for the Sony Smartwatch 2 Brings DND and More

With the wearables landscape now dominated by Android Wear and Pebble, its … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Unlocked G2 no data on AT&T

OP feelingnerdi

26th September 2014, 09:11 AM   |  #11  
Junior Member
Thanks Meter: 0
 
14 posts
Join Date:Joined: Apr 2014
Quote:
Originally Posted by feelingnerdi

Hi all!

I unlocked my T-Mobile G2 successfully and took it to AT&T to get on the Go Plan.. The sales rep put in the sim card, money into my account and my call and text is good to go.. however there is no data at all.. I called AT&T CS and they gave me APN settings but still no data.. Ive seen people say they have LTE working on the same set up.. Any advice? Would flashing a stock AT&T G2 Rom work or would i get bricked?

Seems like the phone is compatible and uses similar bands.. At this point I don't care if it is 3G, 4G or LTE.. I just need data lol..

Do not flash ATT&T firmware on to your ATT&T phone.
You are describing the exact issue my bud had when he went to cricket. No Data Service. He called cricket and download a small package they sent through sms and then had him respond to the text with a pin. Fixed him right up. Call your service provider and explain the whole no Data issue.
Also, I don't know how you unlocked it, but if you used a method where you copied over files then that may be the problem.
I had a sprint G2 along with my TMO G2. With the sprint one I put a custom Firmware TMO base on there and it worked fantastic really glad someone made a sprint firmware that could support TMO. If you haven't tried this type of method I would. That could solve the problem.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes