Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] How to disable firmwar update notifications on Moto G ?

OP OzzyMadhoux

26th January 2014, 04:12 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2014
Hi, a short time ago i have returned again on my Moto G from firmware version 4.4.2 kitkat to stock firmware 4.3 because of lag on vibrations. But i can not disable update notification anyway and it appears each 30 min. on screen. Have you any suggestion to disable that fool thing ? That's really started to annoy me.

(it doesn't work to disabling "Google-Service-Framework" on that path "Settings> Apps > All Services" )
26th January 2014, 05:26 AM   |  #2  
lowrider262's Avatar
Senior Member
Flag Racine, WI
Thanks Meter: 553
 
1,383 posts
Join Date:Joined: Jan 2011
More
If you're rooted, use a file manager app and go to system/app and rename 3c_ota.apk to 3c_ota.apk.bak & reboot

Sent from my XT1034 using Tapatalk
26th January 2014, 01:07 PM   |  #3  
Senior Member
Thanks Meter: 17
 
109 posts
Join Date:Joined: Jan 2012
First install FOTAkill as described here:
http://forum.xda-developers.com/show....php?t=2249350

This worked for me for some weeks.
But then, messing about, I clicked on some Motorola app and it seems to have registered my ID with them. And I started getting prompts again. Then I noticed, via Titanium Backup, that there's a Motorola application associated with updates, 'MotorolaOTA 1.0'. Having frozen that, the prompts have stopped.
26th September 2014, 09:47 AM   |  #4  
tliebeck's Avatar
Senior Member
Flag Southern California
Thanks Meter: 2,286
 
10
1,109 posts
Join Date:Joined: Sep 2010
At least on the Verizon Moto G, I believe this is now "MotorolaOTA", package name com.motorola.ccc.ota. You can disable the package via root ("freeze" it) rather than renaming it (even with root methods that disallow writing to /system).

The APK is located at /system/priv-app/3c_ota.apk. If you're using FX with the root module (free one works) go to that file, long-press on it, tap "Details", scroll down a bit and tap "Disable Package".
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes