Post Reply

5GHz WiFi & DFS Channels?

10th May 2014, 10:53 AM   |  #1  
ADB100's Avatar
OP Senior Member
Thanks Meter: 28
 
1,058 posts
Join Date:Joined: Nov 2006
I have a One X running CM11. I noticed that it couldn't see my 5GHz WiFi signals at home whereas my two laptops can see them fine. After a bit of searching I discovered that there are various Android devices that have 5GHz radios but can't see any of the DFS channels (some information here). I therefore switched both my WiFi APs to static 5GHz channels, one to Channel 36 (5180GHz) and the other to Channel 48 (5240GHz) and now my One X can see them both.

It appears there are fixes for some devices but I can't find a fix for the One X. There is a file in /system/etc/wifi called 'TQS_D_1.7.ini' and another in /system/etc/wifi/ini_files called '128x_TQS_D_1.7.ini' that seem to contain some settings but I can't see anything that seems to suggest enabling or disabling 5GHz channels.

Has anyone else seen this and managed a fix or workaround? My workaround of using non-DFS channels is OK but I'd prefer it if I could allow the DFS channels.

Andy
Yesterday, 02:07 PM   |  #2  
ADB100's Avatar
OP Senior Member
Thanks Meter: 28
 
1,058 posts
Join Date:Joined: Nov 2006
Question
Quote:
Originally Posted by ADB100

I have a One X running CM11. I noticed that it couldn't see my 5GHz WiFi signals at home whereas my two laptops can see them fine. After a bit of searching I discovered that there are various Android devices that have 5GHz radios but can't see any of the DFS channels (some information here). I therefore switched both my WiFi APs to static 5GHz channels, one to Channel 36 (5180GHz) and the other to Channel 48 (5240GHz) and now my One X can see them both.

It appears there are fixes for some devices but I can't find a fix for the One X. There is a file in /system/etc/wifi called 'TQS_D_1.7.ini' and another in /system/etc/wifi/ini_files called '128x_TQS_D_1.7.ini' that seem to contain some settings but I can't see anything that seems to suggest enabling or disabling 5GHz channels.

Has anyone else seen this and managed a fix or workaround? My workaround of using non-DFS channels is OK but I'd prefer it if I could allow the DFS channels.

Andy

This is still an issue and doesn't seem to be on anyone's priority list....
I did some more digging and it looks like the file nvram_4329.txt in /system/etc is relevant to the Broadcom WLAN chipset. There is a country code setting:
Code:
# country code
ccode=ALL
cctl=0x0
which after lots of googling seems to be maybe what I am looking for, however I can't edit the file and I think I need to cook it in (I have edited it to read 'ccode=EU' but it seems to revert each time).

Anyone else any experience with this?

Andy
Last edited by ADB100; Yesterday at 08:46 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes