Android 5.0 Favorite Features, Release November 3rd? – XDA TV

Google Confirms Android 5.0 Lollipop for November 3rd! That and much more … more

Prepare Your Build Machines: Ubuntu 14.10 Utopic Unicorn Now Official

Today is an important day for any and all Linux enthusiasts. One of the … more

Track the Time You Waste on Social Media with Socials Addict

When you use your phone, you often don’t even realize how much time you … more

Document the Story of Your Social Life with 8tory

The different forms of social media are growing every day. It’s hard to imagine a day … more
Post Reply

[Q] Tab 4 7.0 forgets wifi

OP Toogoofy

11th August 2014, 02:42 AM   |  #11  
OP Junior Member
Thanks Meter: 0
20 posts
Join Date:Joined: Dec 2011
Think I have a solution
Hope 5th is will help out so far so good for me!
25th September 2014, 03:31 PM   |  #12  
Junior Member
Thanks Meter: 2
16 posts
Join Date:Joined: Jun 2013
I just got this tab 4 7 inch last week and I am having the same problem with connections showing connected but not having any data transfer. The steps in the above link did not help for me.
I have updated to the latest firmware posted on sammobile, both the Canada version and the nook (BNN) version. Neither have made a difference.

I have found another thread in thisnforrum for this same problem, and there wasn't any solution there either.

I did find wha I think might be solution but haven't proofed it yet. in the build prop there was two "ro.carrier" lines. I think there is only supposed to be one, so I commented out one.

Original Example:

ro.carrier=wifi only


Changed example:

ro.carrier=wifi only


If anybody can confirm this makes a difference or not please post results


After two weeks without problem anymore it appears the fix was the static IP address not the build prop change.

I found threads going back to at least 2007 about Samsung devices having trouble with dhcp and all the solutions being manually assign a static IP to the device.
Last edited by mrmazak; 8th October 2014 at 10:00 PM.
7th October 2014, 04:50 AM   |  #13  
Lacedaemon's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 42
223 posts
Join Date:Joined: Aug 2011
Same issue here. Sometimes I have to cycle the WiFi every webpage!

Both of the above solutions didn't work for me, unfortunately.

Edit: Okay, I may have found the issue, at least for me. Turns out, the tablet was auto-assigning the same IP as my RasPi. After setting a static IP, everything looks okay from here. Hope this helps!
Last edited by Lacedaemon; 7th October 2014 at 05:03 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes