Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Camera Fault, Haze + Creaking

OP daven

3rd October 2014, 04:16 PM   |  #21  
jakobdz's Avatar
Member
Flag Setif
Thanks Meter: 26
 
91 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by effective

Its not 100% sure that this is affecting Z2. No one complained by now.

hope so
3rd October 2014, 06:04 PM   |  #22  
Senior Member
Thanks Meter: 846
 
1,108 posts
Join Date:Joined: Jun 2012
More
I used to have an Xperia Ion, on the surface, the camera's lens looks spick and span but if you tilt it to a certain angle, some sort of scratch marks patches appears due to passage of time i guess, causing the camera to take hazy pictures.
4th October 2014, 08:50 PM   |  #23  
jakobdz's Avatar
Member
Flag Setif
Thanks Meter: 26
 
91 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by lee480

I used to have an Xperia Ion, on the surface, the camera's lens looks spick and span but if you tilt it to a certain angle, some sort of scratch marks patches appears due to passage of time i guess, causing the camera to take hazy pictures.

thanks



with cover >>

without>>

after clean it>>
Last edited by jakobdz; 4th October 2014 at 08:54 PM.
4th October 2014, 09:39 PM   |  #24  
Senior Member
Thanks Meter: 30
 
301 posts
Join Date:Joined: Apr 2013
Quote:
Originally Posted by jakobdz

thanks



with cover >>

without>>

after clean it>>

You dont losed the waterproofness if you opened the back of your phone?how you did it?



Sent from my C6903 using XDA Free mobile app
4th October 2014, 11:31 PM   |  #25  
jakobdz's Avatar
Member
Flag Setif
Thanks Meter: 26
 
91 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by Anonymuszymus

You dont losed the waterproofness if you opened the back of your phone?how you did it?



Sent from my C6903 using XDA Free mobile app

I've already lost

http://forum.xda-developers.com/xper...phone-t2884457
4th October 2014, 11:36 PM   |  #26  
Senior Member
Thanks Meter: 30
 
301 posts
Join Date:Joined: Apr 2013
Quote:
Originally Posted by jakobdz

I've already lost

http://forum.xda-developers.com/xper...phone-t2884457

Got it...i had similar problems with my z1,just my phone was not totally dead,my screen went to negative for 2 days....shame on Sony

Sent from my C6903 using XDA Free mobile app
9th October 2014, 07:12 PM   |  #27  
OP Senior Member
Thanks Meter: 3
 
108 posts
Join Date:Joined: Feb 2006
Quote:
Originally Posted by RanMN

Hey,i have the exact same creaking issue!I thought i was the only one.I took it to the Service Center and the guy at the counter acknowledged the issue and said ill get a replacement and removed my sim card and memory card etc and only then i realized they cant provide a standby phone so i said ill come back later and submit the phone for replacement.

Later the SONY Store where i bought the phone from provided me a standby phone and they itself submitted my Z2 to the service center but few days later they returned the phone saying there isn't any issue :X i took it up with their customer care and they asked me to go to the service center again but i haven't got the time yet.
My batch number is 14W18,what is yours?
I checked some test pieces at the SONY Store and they had a similar issue but i checked again at another store and they seemed fine -_-



I have the same flash bleed issue on all the cases including the OEM ones provided by SONY.

I actually got the phone replaced under the 28 days no questions return policy, I got it a week before the official release date so it was either the first batch or second. The replacement was perfect, no issues with creaking or even the camera regardless of how many times it got wet (I take my phones in the bath with me every morning, so it's safe to say I completely test out their waterproofing capabilities :P)

It's interesting to see the photos above though, looks like on the first phone some moisture got into the case although nothing was visible.

Unfortunately even though everything was great with the second phone for 4 months it self cracked last month so for the moment I'm back on my old trusty Z Ultra (which is yet to let me down).
13th October 2014, 01:39 PM   |  #28  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2014
Somewhat related, but my Xperia Z2 camera gave up working recently. I had it underwater for 2 mins (with everything sealed etc), then it had major condensation issues, which probably kicked off the following problems.

Started off with really high pitched whining sounds as it focused, then banded lines would appear on pictures, then total failure of the focus mechanism few days later.

Sony just fixed it and getting back today or tomorrow, but I am now very sceptical of how waterproof these phones really are.
13th October 2014, 04:42 PM   |  #29  
Senior Member
Thanks Meter: 19
 
132 posts
Join Date:Joined: Mar 2012
More
i got that phone 5 days ago and tested it under water three times that day to make sure it is really waterproof and it done its job well... no problems with phone so far except that creaky sound ....
under the sony logo on back cover when i press i mean press really hard i hear that creaky sound...but i can live with that
should i get a replacement or not??
btw am rooted and unlocked my bootloader (backup TA partition made)
15th October 2014, 06:56 AM   |  #30  
Junior Member
Flag Timisoara
Thanks Meter: 1
 
6 posts
Join Date:Joined: May 2013
More
same problem
Quote:
Originally Posted by daven

I'm not sure whether any other people have had this but it seems like there could be a fault with some of the camera on some devices (or just mine?).

I preordered and received my z2 on the 22nd april, my sister just bought one today and I was comparing the two - it definitely seems like the new one captures photos far better where sunlight is concerned, it looks like there's an area of haze/overexposure on my one - I've attached photos to illustrate.

The ones with the i's on the end of the file name are with my z2, the ones without are with the new one - both were taken with superior auto from almost exactly the same position and at the same time with exactly the same settings and both on the same firmware.

Also does anyone else's device creak when you push a little on the back just above the sony logo?

I've had the creaking from day one and hasn't affected the waterproofing or anything so I was just going to live with it, but now I've noticed the camera thing I'm going to try and get an exchange.

a friend of mine has the exact same problem, in his case the camera reflection coating has rubbed of by itself, it,s just poor quality constructed by sony, they all should use sapphire glass on the camera, it's small so it won't be expensive.. i have a S5 and never had problems with reflection. it's good that some of the Z2's don't have the problem, GUYS, BE AWARE! WHEN BUYING A NEW ONE, CHECK THE CAMERA FOR REFLECTIONS WHEN SHOOTING DIRECT LIGHT!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes