Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[GUIDE] Root the Samsung Galaxy S3 Mini Value Edition (i8200)(i8200L)

OP DanielCarbajal96

15th September 2014, 10:44 AM   |  #31  
Junior Member
Thanks Meter: 0
7 posts
Join Date:Joined: Sep 2010

i will root my i8200n.

i have try vroot. vroot install kinguser and have no problems.
i install root checker and it ask with kinguser. but root checker says he has no correct root.

titanium backup works, but orbot don't works.
i also try root genius application but it is the same.

what can i do?

EDIT: Kingo Root doesn't also not work. USB-degging is on.

EDIT2: ok... the rom is the problem. with I8200NXXUANG1 i have no prblems and root check say it is all ok.
but orbot doesn't work it connecting in green but no traffic
Attached Thumbnails
Click image for larger version

Name:	Unbenannt.png
Views:	196
Size:	60.8 KB
ID:	2937849  
Last edited by tojimori; 16th September 2014 at 11:24 AM.
17th September 2014, 09:53 AM   |  #32  
Junior Member
Thanks Meter: 0
1 posts
Join Date:Joined: Sep 2014
Originally Posted by DanielCarbajal96

I have the Samsung Galaxy S3 Mini Value Edition i8200L , i'm from Costa Rica and i tried everything to root it , from Android Unified Toolkit (That ensures that root the S3 Mini VE) to DoomLord and SRSRoot but nothing worked , the only metod available to root this phone is with VRoot this is the chinese version , the english version doesn't work cause i tried and nothing ,i think that was impossible to root it but i tried the chinese version and it works.

Here's my tutorial to root it (Sorry for my bad english)

1-Download VRoot in it official page , google it because i can't put links here cause i'm new member , the version that works it
VRoot if there are a new version just download it.

2-Install VRoot.

3-Download and install Samsung Drivers , google it to

3-Activate debug mode in developer options , if you dont have developer options go to About Phone and press 7 or 10 times in Build Number or Compilation Number and the developer options will be available , after go to it and activate debug mode.

4-Allow instalation from external sources , ubicated in security options.

5-Open VRoot and wait to detect your phone , if not reconnect the phone to the computer or reinstall drivers.

6-When VRoot detect your phone press Next in VRoot and the root procedure will begin , it will install 2 chinese aplications 1 is like Aptoide and the other is the Superuser , you need SuperSu because it is the more stable , after the root finishes the phone will reboot and you have root acces.

(Next Steps are optional because i'm gonna show you how to change to SuperSu)

6-Download SuperSu from Play Store , open it and install binaries.

7-Download Link2SD and make SuperSu a system application.

8-Reboot the phone.

9-Open SuperSu and if it asks you to update binaries , do it.

10-Go to Link2SD and uninstall the chinese apps that VRoot install.

11-Enjoy root

I posted a screenshot that VRoot shows when i rooted the phone.

Good Luck , any questions i'm here to answer it.

I did everything, but in the item 10, when i deleted all the apps installed by VRoot (including KingUser), i cant open SuperSU anymore (says that canīt install binaries), then i cant modifie nothing in Link2SD (not root access), and cant uninstall SuperSU either... (sorry abou the english)

My question is: must i have to leave KingUser also installed (with SuperSU)? or i can delete it?
24th September 2014, 02:27 AM   |  #33  
Junior Member
Thanks Meter: 0
8 posts
Join Date:Joined: Nov 2010
Hi, guys.

Well, all links of Vroot official like www.mgyun.com/en/getvroot, http://vrootdownload.org/ and http://vrootdownload.info/ only download the 1.7.3 version, until the links that say to be v1.7.6 and v1.7.8.
I have a model GT-I8200L, from Brazil:
- Android Version
- Baseband version

The 1.7.3 version not work to root my model and I found the 1.7.8 chinese version in other post inside here, on the message http://forum.xda-developers.com/show...5&postcount=41.
Only the v1.7.8 of Vroot worked to my model.
I hope this helps someone.

[ ].
29th September 2014, 09:36 AM   |  #34  
pjotfurek's Avatar
Junior Member
Flag Enniscorthy
Thanks Meter: 1
2 posts
Join Date:Joined: Jan 2013
Thumbs up
Hi all!

First of all I wish to confirm that Vroot 1.7.9 works fine and my S3 Mini VE is now ROOTed.
- VRoot v
- Galaxy S III Mini GT-I8200N [Android 4.2.2 Jelly Bean - Baseband I8200NXXUANG1 - Kernel v3.4.5]

Cheers mate! Many thanks for putting this Guide together and helping us noobs with ROOTing our Galaxies.

Do find an archive attached with this post. It is that thing which worked well for me.
Now You don't need to waste time, rummaging throug the Web, as most of rubbish out there is in fact an old 1.7.3 version...

As DanielCarbajal96 mentioned above, the entire rooting process took around 5mins, it was entirely in Chinese. There were some, easily understandable, pictures and symbols which lead me through the whole process.

Since I had Kies installed for a good while before I even thought of ROOTing my I8200N I decided not to bother going after any other drivers.

At long last, I can tidy up my App Drawer and do some Freezing and/or Unistalling
Firstly, all the rubbish such as Facebook or ChatOn... GONE Then some magic from Titanium Backup etc.

By the way, NONE of the lot such as Contacts, Messages, etc. were harmed during ROOTing process.
Work away freely then and enjoy some more freedom.

Again, much obliged to DanielCarbajal96 :beer:

Attached Files
File Type: zip VRoot_1.7.8.7753_Setup_Chinese.zip - [Click for QR Code] (9.54 MB, 325 views)
Last edited by pjotfurek; 29th September 2014 at 10:32 AM.
The Following User Says Thank You to pjotfurek For This Useful Post: [ View ]
20th October 2014, 12:02 PM   |  #35  
Junior Member
Thanks Meter: 0
1 posts
Join Date:Joined: Apr 2012
Thumbs up
Thanks for the guide, my i8200n is now rooted!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes