Google Allows Search Queries To Interact With Apps

Android 5.0 Lollipop brings lots of new features that are quite useful for end users and … more

Lenovo Officially Owns Motorola, Following ~$3 Billion Deal

Google is now officially no longer the owner of American phone manufacturer … more

Microsoft Band Fitness Tracker Announced, Available

The wearable market has been around for a few years, with Pebble and Samsung smartwatches … more

Forums Added for the Oppo R5, Oppo N3, and Xiaomi Redmi Note

Just yesterday, Oppo unveiled a pair of rather unique smartphones, the Oppo … more
Post Reply

[ROOT][Towelroot] MetroPCS LG Optimus L70

OP CuriousUser

9th August 2014, 02:22 AM   |  #11  
MartyMar_XVII's Avatar
Senior Member
Flag Bronx, New York
Thanks Meter: 26
 
184 posts
Join Date:Joined: Aug 2012
More
This was the easiest root I've ever done, I just wish this phone had a rom.
10th September 2014, 06:16 PM   |  #12  
DarkJohn55's Avatar
Junior Member
Flag Bakersfield
Thanks Meter: 0
 
8 posts
Join Date:Joined: Sep 2014
More
Awesome
Worked for me on my new phone i bought a few days ago but with no reboot rooted live either way i checked it with root checker said i was then rebooted to make sure and rechecked everything checked out a-ok! thanks for the tutorial btw I am new member to this site. lol ;P
18th September 2014, 06:00 AM   |  #13  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Sep 2014
last commenter is just a hater...
Worked just fine for me, first try, no complications at all... Thanx for the how to help guys, you're always the best for that.
25th September 2014, 06:05 PM   |  #14  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Sep 2014
It's working n my lg l70 d325.
26th September 2014, 09:52 AM   |  #15  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Sep 2014
[QUOTE=combatron;55667626]It's working n my lg l70 d325. Pretty easy. Just gonna ask how to unroot it just in case
22nd October 2014, 07:10 PM   |  #16  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Oct 2014
Problem using towelroot!!
HI,
I Installed towelroot and I installed SUPERUSER SU, But my hotspot stopped working AFTER I was able to use it for 5 months when i got this phone. I have the LG70 MS323, Now when i try to use the hotspot it brings up a metro/ tmobile page that says I need to upgrade my phone to get hotspot? I place a root on the phone so that i can acess the hot spot without being charged by tmobile/metropcs. How can i do this? I still have towellroot but it doesn't work to hide the phone and I no longer can use hotspot without TMOBILE/ METRO BLOCKING IT. I got this phone to hack it and use hotspot with out paying the crazy price they are asking me to pay. Please help. or please advise to how I fix this.
Thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Android General by ThreadRank