Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] How do I backup to extsdcard in MyBackupPro 4.0.5 on KitKat 4.4.2 on my i9505?

OP okizen

17th March 2014, 10:33 AM   |  #11  
Pfeffernuss's Avatar
Senior Member
Flag Wassenaar
Thanks Meter: 774
 
3,068 posts
Join Date:Joined: Jun 2009
More
Quote:
Originally Posted by okizen

Hi DarkCase

I've got Root Explorer 3.16 but I can't seem to edit the platform.xml file.

Did you press this first?

27th March 2014, 12:40 PM   |  #12  
ahdeshpande's Avatar
Senior Member
Flag Dubai
Thanks Meter: 0
 
148 posts
Join Date:Joined: Nov 2007
More
Thumbs up Thanks....
Quote:
Originally Posted by DarkCase

In the last few days Samsung has been pushing out Android 4.4.2 to flagship devices like the Galaxy
Note III and Galaxy S4. Unfortunately, Google implemented an SD card write restriction in the latest
Android version which can be quite annoying for users with an SD card in their phone.
The new “feature” basically restricts apps from writing to external SD cards. This can be quite
annoying, because many users want to store apps on a secondary SD card instead of the main storage
unit.
Luckily, how to fixing this problem can be easily done if you have root access. Here’s how you can do it
(Please be aware that you’re performing these changes on your own risk!):

Make sure that you have root access

1. Perform a NANDROID backup to be completely safe
2. Use a root-enabled file manager and navigate to /system/etc/permissions
3. Edit platform.xml and find “WRITE_EXTERNAL_STORAGE“
4. Add an additional group definition for this permission: <group gid=”media_rw” />
5. Save the changes and restart your device
6. You are now able to write on your external SD card again
I hope that I was able to help you.



Thanks , it worked for me
13th April 2014, 01:49 PM   |  #13  
Senior Member
Flag South West, England
Thanks Meter: 5
 
274 posts
Join Date:Joined: Mar 2009
I'm having the same problem too. I've e-mailed the developers of MyBackup Pro to see if they've got any ideas.

It says MyBackup Pro 4.0.9 fixes KitKat issues, it doesn't fix this one!

I will if I have to but I don't want to or see why I should have to, effectively break (root) my Galaxy S4 just to backup to SD card when it worked fine with Jellybean 4.3. I don't need Root access otherwise

--------------------------------------------------------------------------------------------------------------------------------------------------

None of this is mentioned in Google's KitKat Release Notes or on-screen when the Samsung Update Notification appeared. So far KitKat has broken for me:

1. SMS Backup+ prior to KitKat could restore SMS messages back to the phone, it can still back them up but not restore
2. LG G Pad's QPair It still works but used to be blue when connected, white when not connected. Now that everything is white (), it's grey when not connected and white when connected. No where near as clear.
3. MyBackup Pro can no longer backup to SD card

Being able to backup to SD card is obviously crucial!

I've seen zero benefits from going from Jellybean 4.3 to Kitkat.
Last edited by bradavon; 13th April 2014 at 01:51 PM.
13th April 2014, 04:33 PM   |  #14  
Junior Member
Thanks Meter: 3
 
18 posts
Join Date:Joined: May 2013
Talking
Quote:
Originally Posted by DarkCase

In the last few days Samsung has been pushing out Android 4.4.2 to flagship devices like the Galaxy
Note III and Galaxy S4. Unfortunately, Google implemented an SD card write restriction in the latest
Android version which can be quite annoying for users with an SD card in their phone.
The new “feature” basically restricts apps from writing to external SD cards. This can be quite
annoying, because many users want to store apps on a secondary SD card instead of the main storage
unit.
Luckily, how to fixing this problem can be easily done if you have root access. Here’s how you can do it
(Please be aware that you’re performing these changes on your own risk!):

Make sure that you have root access

1. Perform a NANDROID backup to be completely safe
2. Use a root-enabled file manager and navigate to /system/etc/permissions
3. Edit platform.xml and find “WRITE_EXTERNAL_STORAGE“
4. Add an additional group definition for this permission: <group gid=”media_rw” />
5. Save the changes and restart your device
6. You are now able to write on your external SD card again
I hope that I was able to help you.

++++++++1111111
7th June 2014, 10:18 AM   |  #15  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jul 2011
Quote:
Originally Posted by okizen

Hi DarkCase

I've got Root Explorer 3.16 but I can't seem to edit the platform.xml file.

I have already written this (media_rw) in xml file, but still go backup is unable to write to external sd card. With esfexplorer I can make folder or files on external sd card, so permission is rw?

any idea
Last edited by bnaglic; 7th June 2014 at 10:22 AM.
29th October 2014, 05:01 AM   |  #16  
Member
Thanks Meter: 5
 
56 posts
Join Date:Joined: Jan 2012
What is google thinking. Why would I save to internal memory and not be able to have a backup everywhere I go in multiple locations?

As for the fix you shouldnt have to root your device just to have it write to a card. this makes no sense
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes