Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[MOD] [All ROMS] F2FS for TF700T

OP Pretoriano80

4th October 2014, 04:32 PM   |  #271  
barbarony62's Avatar
Member
Thanks Meter: 2
 
45 posts
Join Date:Joined: Nov 2008
tried F2FS, Hard Bricked my transformer (or so I thought)... and saved it...
Hi,

Yesterday I tried to swap my data to F2FS. at one point my settings UI started FCing on me... could not do anything. rebooting also failed. Flashing a different rom did not help.. eventually, I could only start TWRP recovery. I tried to flash a different ROM and bamm... Reovery stops working. Now I cannot start in Recovery, a moment later I cannot start fastboot mode... I end up with a brick... stuck on twrp logo... no recovery, no fastboot.... no conneciton to PC, no ADB... nothing what-so-ever... I am thinking to myself: " at least its windy out there.... I can use the slate as a door-stop"

8 hours later, I am writing this report from my transformer.... its up and running again, in F2FS mode.... steps taken to save the slate
1. try everthing ever written on trying to get into recovery or fastboot... all fails.
2. using ADB try to recognize slate.... fails...
3. send these two commands to tf700 (for no good reason as the slate is not seen by PC)
a. dd if=/dev/zero of=/dev/block/mmcblk0p4 bs=100 count=1
b. dd if=/dev/zero of=/dev/block/mmcblk0p3 bs=16 count=1
4. something seems to happen but I do not know what
5. try to boot into fastboot.... success
6. try to flash twrp again... flash succeeds but cannot boot into recovery
7. flash CWM-- success... boot into recovery success... flash cm11 success... try to boot into cm11 fails.. encryption problem. /data formatted incorrectly
8. try to change to EXT4 fails
9. flash twrp_f2fs -- success... format /data t f2fs .. success... flash f2fs kernel success.... reboot to cm11 success...
10 . restore apps... at least I had these backed up...

phew.... and I thought I had a brick..... think about it... no recovery... no fastboot.... no ADB... PC does not see slate.... and yet....

BTW F2FS is working well
BarBarony
Last edited by barbarony62; 4th October 2014 at 04:35 PM. Reason: typos
31st October 2014, 11:46 PM   |  #272  
Senior Member
Thanks Meter: 13
 
143 posts
Join Date:Joined: Apr 2012
Gparted response regarding F2FS anomaly
Running Gparted Live 0.20.0.2
Three partitions on 64gb MicroSd: 12gb, 46gb, 1gb, formatted Fat32, F2Fs, Ext4 respectively.
Gparted shows error flag on F2FS format, others ok. Shows F2FS, Does NOT show partition size.
Can change 2nd partition to Ext4 or Fat32 without error flag, and they show partition size.
Only happens on F2Fs fomat.
MicroSD appears to work correctly, so suspect Gparted reading wrong.

Report Edit Reply Quick quote
2gedakcYesterday 11:20:44
Developer
Offline
Registered: 2007-11-30
Posts: 3,544
Thank you Immohr for your interest in GParted.
This behaviour is expected because the current f2fs code does not contain logic to determine the used and unused values. Hence GParted is warning that it is unable to read the file system (usage) and some operations may be unavailable.
Post Reply Subscribe to Thread

Tags
f2fs, mod, tf700t
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes