FORUMS

Defective SIM card slot

4 posts
Thanks Meter: 2
 
By Tom Mi, Junior Member on 17th January 2014, 09:07 PM
Post Reply Subscribe to Thread Email Thread
I'm losing my mind, I've tried a million time but when I put my sim card in I hear the click, but the card stays in place only for half a second, and then the slot releases it automatically. Does anybody have the same problem?

Sent from my XT1032 using xda app-developers app
 
 
18th January 2014, 02:12 AM |#2  
serophia's Avatar
Senior Member
San Diego
Thanks Meter: 75
 
More
When it click press it in again to secure it

Sent from my XT1034 using xda app-developers app
The Following User Says Thank You to serophia For This Useful Post: [ View ]
18th January 2014, 01:13 PM |#3  
Tom Mi's Avatar
OP Junior Member
Flag Verona
Thanks Meter: 2
 
More
Done, no difference

Sent from my XT1032 using xda app-developers app
1st April 2014, 12:31 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Tom Mi

Done, no difference

Sent from my XT1032 using xda app-developers app

I've had to send mine off for repair for this. I'd be curious to know how many other Moto G owners have the same problem.
5th November 2014, 12:11 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Nexxxeh

I've had to send mine off for repair for this. I'd be curious to know how many other Moto G owners have the same problem.

try to put a layer of tape on the back of the sim card. That should fix the problem.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes